cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <...@apache.org>
Subject Re: Password Management in OS Templates Not Working
Date Thu, 08 Aug 2013 06:42:53 GMT
Hit the "RAW" button and use the resulting link.

On Thu, Aug 08, 2013 at 02:37:46PM +0800, Punit Dambiwal wrote:
> Hi Prasanna,
> 
> *I try to wget this but the downloaded file is with html tags...do you
> have another way to download this.*
> 
> 
> On Thu, Aug 8, 2013 at 2:30 PM, Prasanna Santhanam <tsp@apache.org> wrote:
> 
> > There's a problem with your editor likely. From the guest
> >
> > just do a wget of the script and save it instead of copy-pasting using
> > an editor.
> >
> > On Thu, Aug 08, 2013 at 02:26:54PM +0800, Punit Dambiwal wrote:
> > > Hi Harikrishna,
> > >
> > > I tried with your and prasanna suggested scripts...but both have the same
> > > error :-
> > >
> > > ------------------------
> > > [root@test3 init.d]# sh cloud-set-guest-password
> > > : command not foundsword: line 7:
> > > : command not foundsword: line 24:
> > > : command not foundsword: line 25:
> > > : command not foundsword: line 28:
> > > : command not foundsword: line 34:
> > > 'loud-set-guest-password: line 36: syntax error near unexpected token `do
> > > 'loud-set-guest-password: line 36: `do
> > > [root@test3 init.d]# ./cloud-set-guest-password
> > > -bash: ./cloud-set-guest-password: /bin/bash^M: bad interpreter: No such
> > > file or directory
> > > [root@test3 init.d]#
> > > --------------------------
> > >
> > >
> > > On Thu, Aug 8, 2013 at 2:24 PM, Punit Dambiwal <hypunit@gmail.com>
> > wrote:
> > >
> > > > Hi,
> > > >
> > > > I tried this same error..
> > > >
> > > >
> > > > On Thu, Aug 8, 2013 at 2:14 PM, Prasanna Santhanam <tsp@apache.org>
> > wrote:
> > > >
> > > >> Try these:
> > > >> https://github.com/shankerbalan/cloudstack-scripts
> > > >>
> > > >> On Thu, Aug 08, 2013 at 02:09:02PM +0800, Punit Dambiwal wrote:
> > > >> > No....I just copied this from sourceforge and run
> > > >> >
> > > >> >
> > > >> > On Thu, Aug 8, 2013 at 1:47 PM, Harikrishna Patnala <
> > > >> > harikrishna.patnala@citrix.com> wrote:
> > > >> >
> > > >> > > Hi
> > > >> > > Did you prepare this script in windows environment? Seems
like
> > some
> > > >> > > control characters got inserted in the script.
> > > >> > >
> > > >> > > -Harikrishna
> > > >> > >
> > > >> > > On 08-Aug-2013, at 10:25 AM, Punit Dambiwal <hypunit@gmail.com>
> > > >> wrote:
> > > >> > >
> > > >> > > > Hi Venkata,
> > > >> > > >
> > > >> > > > Thanks for the reply....as the script run successfully
and
> > prompt
> > > >> the new
> > > >> > > > password...but when i try to login...i couldn't be
able to login
> > > >> with the
> > > >> > > > prompted password....
> > > >> > > >
> > > >> > > > I tried to run the script on guest VM,it throws error
:-
> > > >> > > >
> > > >> > > > ----------------------
> > > >> > > > [root@test3 init.d]# ./cloud-set-guest-password
> > > >> > > > -bash: ./cloud-set-guest-password: /bin/bash^M: bad
> > interpreter: No
> > > >> such
> > > >> > > > file or directory
> > > >> > > > [root@test3 init.d]#
> > > >> > > > -----------------------
> > > >> > > >
> > > >> > > > In the VR...it seems ok...the correct path is :-
> > > >> > > /var/cache/cloud/passwords
> > > >> > > >  (The new password for the corresponding ip address
listed in
> > this
> > > >> file)
> > > >> > > >
> > > >> > > >
> > > >> > > > On Thu, Aug 8, 2013 at 12:44 PM, Venkata SwamyBabu
Budumuru <
> > > >> > > > venkataswamybabu.budumuru@citrix.com> wrote:
> > > >> > > >
> > > >> > > >> Since you made this as a startup script, what do
you see just
> > > >> before the
> > > >> > > >> guest login prompt appears? Do you see any errors
when the
> > script
> > > >> > > executed
> > > >> > > >> or does it say it has set the password successfully.
> > > >> > > >>
> > > >> > > >> At the same time, you can also check on your VR
for
> > > >> > > >> /var/cloud/cache/password file and see the password
entry for
> > your
> > > >> guest
> > > >> > > >> ip. On successfully password setup, it will set
it to
> > save_password
> > > >> > > value.
> > > >> > > >>
> > > >> > > >> You can also just check by manually executing this
script
> > before
> > > >> you
> > > >> > > make
> > > >> > > >> template out of it.
> > > >> > > >>
> > > >> > > >> On 08/08/13 10:04 AM, "Punit Dambiwal" <hypunit@gmail.com>
> > wrote:
> > > >> > > >>
> > > >> > > >>> Hi,
> > > >> > > >>>
> > > >> > > >>> I Followed the following url to add the Password
Management
> > in OS
> > > >> > > >>> templates....place the "cloud-set-guest-password"
in the
> > > >> /etc/init.d/.
> > > >> > > >>>
> > > >> > > >>> When i try to deploy the new VM with this template,VM
deployed
> > > >> > > >>> successfully
> > > >> > > >>> and prompt the new password,but when try to
login to VM...the
> > new
> > > >> > > password
> > > >> > > >>> doesn't work...old password can still use.
> > > >> > > >>>
> > > >> > > >>> Thanks,
> > > >> > > >>> punit
> > > >> > > >>
> > > >> > > >>
> > > >> > >
> > > >> > >
> > > >>
> > > >> --
> > > >> Prasanna.,
> > > >>
> > > >> ------------------------
> > > >> Powered by BigRock.com
> > > >>
> > > >>
> > > >
> >
> > --
> > Prasanna.,
> >
> > ------------------------
> > Powered by BigRock.com
> >
> >

-- 
Prasanna.,

------------------------
Powered by BigRock.com


Mime
View raw message