cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anton Rubets <plejik....@gmail.com>
Subject Re: Virtual router failed
Date Wed, 03 Jul 2013 19:16:42 GMT
I am use advanced zone.
Now i am stuck more than 6 time,SSVM & CPVM start, VR start, network tag
problem, but almost done.
Now the last problem with instance creation and i think then i can say that
i finish him.
And some day ago i saw that XenServer now free =(


On Wed, Jul 3, 2013 at 9:28 PM, Dean Kamali <dean.kamali@gmail.com> wrote:

> Did you actually managed to get everything to work on XenCP 1.6?  are you
> setting up advanced zone? or basic?
>
>
> On Wed, Jul 3, 2013 at 2:26 PM, Anton Rubets <plejik.san@gmail.com> wrote:
>
> > Yeap, i found solution in CS4.2 bugtracker 0_o
> > In db cloud do
> >  update physical_network_traffic_types set xen_network_label=NULL;
> >
> >
> > On Wed, Jul 3, 2013 at 9:17 PM, Dean Kamali <dean.kamali@gmail.com>
> wrote:
> >
> > > XenCP 1.6 is not fully supported, and from the logs it sounds like you
> > have
> > > issue with networking setup.
> > >
> > >
> > > On Wed, Jul 3, 2013 at 4:30 AM, Anton Rubets <plejik.san@gmail.com>
> > wrote:
> > >
> > > > Hi. I have problem with create first instance at my CS4.1.
> > > > SSVM and CPVM  have been deployed without any problem/ But when i
> > create
> > > > instance in log i have
> > > >
> > > > 2013-07-03 11:18:39,039 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) 1. The VM r-21-VM is in Starting state.
> > > > 2013-07-03 11:18:39,125 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Created VM
> ea8c50b9-fd7a-9efd-1398-0dc7198034f8
> > > for
> > > > r-21-VM
> > > > 2013-07-03 11:18:39,227 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) PV args are -- quiet
> > > >
> > > >
> > >
> >
> console=hvc0%template=domP%name=r-21-VM%eth2ip=10.12.33.166%eth2mask=255.255.255.224%gateway=10.12.33.161%eth0ip=10.12.42.1%eth0mask=255.255.255.0%domain=
> > > > mydomain.com
> > > >
> > > >
> > >
> >
> %dhcprange=10.12.42.1%eth1ip=169.254.1.194%eth1mask=255.255.0.0%type=router%disable_rp_filter=true%dns1=10.255.12.3%dns2=10.12.41.1
> > > > 2013-07-03 11:18:39,266 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) VBD 53aa49ae-c3de-3684-4ecc-f61c7cc9ee0e
> created
> > > for
> > > > Vol[21|ROOT|812467f3-2c12-4414-bb26-e70d6b8231da|2147483648]
> > > > 2013-07-03 11:18:39,310 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Creating VIF for r-21-VM on nic
> > > > [Nic:Public-10.12.33.166-vlan://untagged]
> > > > 2013-07-03 11:18:39,315 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Looking for network named Vlan336
> > > > 2013-07-03 11:18:39,343 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Created a vif
> > 78f4db3a-d1bd-75a8-083c-4012dbdb2fce
> > > > on 2
> > > > 2013-07-03 11:18:39,343 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Creating VIF for r-21-VM on nic
> > > > [Nic:Guest-10.12.42.1-vlan://42]
> > > > 2013-07-03 11:18:39,347 DEBUG [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Looking for network named Vlan42
> > > > 2013-07-03 11:18:39,367 WARN [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Catch Exception: class
> > > > java.lang.NullPointerException due to java.lang.NullPointerException
> > > > java.lang.NullPointerException
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase$XsLocalNetwork.getPifRecord(CitrixResourceBase.java:7156)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.enableVlanNetwork(CitrixResourceBase.java:4092)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:797)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.createVif(CitrixResourceBase.java:842)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1311)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:517)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:51)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
> > > > at
> > > java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > > > at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
> > > > at java.util.concurrent.FutureTask.run(FutureTask.java:166)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > > at java.lang.Thread.run(Thread.java:679)
> > > > 2013-07-03 11:18:39,369 WARN [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Unable to start r-21-VM due to
> > > > java.lang.NullPointerException
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase$XsLocalNetwork.getPifRecord(CitrixResourceBase.java:7156)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.enableVlanNetwork(CitrixResourceBase.java:4092)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:797)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.createVif(CitrixResourceBase.java:842)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1311)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:517)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:51)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
> > > > at
> > > java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > > > at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
> > > > at java.util.concurrent.FutureTask.run(FutureTask.java:166)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > > at java.lang.Thread.run(Thread.java:679)
> > > > 2013-07-03 11:18:39,442 WARN [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Unable to clean up VBD due to
> > > > You gave an invalid object reference. The object may have recently
> been
> > > > deleted. The class parameter gives the type of reference given, and
> the
> > > > handle parameter echoes the bad value given.
> > > > at com.xensource.xenapi.Types.checkResponse(Types.java:209)
> > > > at com.xensource.xenapi.Connection.dispatch(Connection.java:368)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XenServerConnectionPool$XenServerConnection.dispatch(XenServerConnectionPool.java:909)
> > > > at com.xensource.xenapi.VBD.unplug(VBD.java:1059)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.handleVmStartFailure(CitrixResourceBase.java:1114)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1377)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:517)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:51)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
> > > > at
> > > java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > > > at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
> > > > at java.util.concurrent.FutureTask.run(FutureTask.java:166)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > > at java.lang.Thread.run(Thread.java:679)
> > > > 2013-07-03 11:18:39,456 WARN [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Unable to clean up VBD due to
> > > > You gave an invalid object reference. The object may have recently
> been
> > > > deleted. The class parameter gives the type of reference given, and
> the
> > > > handle parameter echoes the bad value given.
> > > > at com.xensource.xenapi.Types.checkResponse(Types.java:209)
> > > > at com.xensource.xenapi.Connection.dispatch(Connection.java:368)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XenServerConnectionPool$XenServerConnection.dispatch(XenServerConnectionPool.java:909)
> > > > at com.xensource.xenapi.VBD.unplug(VBD.java:1059)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.handleVmStartFailure(CitrixResourceBase.java:1114)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1377)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:517)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:51)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
> > > > at
> > > java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > > > at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
> > > > at java.util.concurrent.FutureTask.run(FutureTask.java:166)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > > at java.lang.Thread.run(Thread.java:679)
> > > > 2013-07-03 11:18:39,469 WARN [xen.resource.CitrixResourceBase]
> > > > (DirectAgent-175:null) Unable to cleanup VIF
> > > > You gave an invalid object reference. The object may have recently
> been
> > > > deleted. The class parameter gives the type of reference given, and
> the
> > > > handle parameter echoes the bad value given.
> > > > at com.xensource.xenapi.Types.checkResponse(Types.java:209)
> > > > at com.xensource.xenapi.Connection.dispatch(Connection.java:368)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XenServerConnectionPool$XenServerConnection.dispatch(XenServerConnectionPool.java:909)
> > > > at com.xensource.xenapi.VIF.unplug(VIF.java:878)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.handleVmStartFailure(CitrixResourceBase.java:1122)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1377)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:517)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:51)
> > > > at
> > > >
> > > >
> > >
> >
> com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
> > > > at
> > > java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > > > at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
> > > > at java.util.concurrent.FutureTask.run(FutureTask.java:166)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
> > > > at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > > at java.lang.Thread.run(Thread.java:679)
> > > >
> > > > Then i figure that i have one virtual router in zone(before havent)
> but
> > > it
> > > > s stopped.
> > > > I have Centos, CS4.1 XenCP 1.6
> > > > Thanks
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message