cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject Re: malformed uuid element? can't add host
Date Mon, 08 Jul 2013 07:34:53 GMT

Ryan, I am copying Marcus and Wido who might be able to help on this one

-sebastien

On Jul 8, 2013, at 1:17 AM, Ryan Hughes <rshughes@gmail.com> wrote:

> Hello,
> 
> I'm repeatedly running into the wall on trying to add an Ubuntu 12.04.2 KVM
> host to my new cloudstack instance. I've built everything from the proper
> repositories and after a long while of troubleshooting, every time I go to
> add a host to the environment I get the following:
> 
> 2013-07-08 01:09:07,804 INFO  [cloud.agent.Agent] (main:null) Agent [id =
> new : type = LibvirtComputingResource : zone = 2 : pod = 2 : workers = 5 :
> host = cloudmgr : port = 8250
> 2013-07-08 01:09:07,809 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> Connecting to cloudmgr:8250
> 2013-07-08 01:09:08,033 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> SSL: Handshake done
> 2013-07-08 01:09:08,179 ERROR [kvm.storage.LibvirtStorageAdaptor]
> (Agent-Handler-1:null) org.libvirt.LibvirtException: XML error: malformed
> uuid element
> 2013-07-08 01:09:08,180 WARN  [utils.nio.Task] (Agent-Handler-1:null)
> Caught the following exception but pushing on
> java.lang.NullPointerException
> at
> com.cloud.hypervisor.kvm.storage.LibvirtStorageAdaptor.createStoragePool(LibvirtStorageAdaptor.java:539)
> at
> com.cloud.hypervisor.kvm.storage.KVMStoragePoolManager.createStoragePool(KVMStoragePoolManager.java:57)
> at
> com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.initialize(LibvirtComputingResource.java:3328)
> at com.cloud.agent.Agent.sendStartup(Agent.java:320)
> at com.cloud.agent.Agent$ServerHandler.doTask(Agent.java:850)
> at com.cloud.utils.nio.Task.run(Task.java:83)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> at java.lang.Thread.run(Thread.java:679)
> 
> Any helpful pointers on remediating this would be greatly appreciated.
> 
> For what its worth, this is an Open vSwitch + Cloud Stack install.
> 
>    ovs_version: "1.4.0+build0"
> 
> Thanks!
> 
> Ryan


Mime
View raw message