cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <...@apache.org>
Subject Re: Unable to migrate VM to another host
Date Tue, 23 Jul 2013 10:43:58 GMT
On Tue, Jul 23, 2013 at 06:19:06PM +0800, Indra Pramana wrote:
> Dear Prasanna and all,
> 
> I have tried to remove the host from CloudStack, uninstall and reinstall
> cloudstack-agent and added the host back into CloudStack. The "cloud"
> user-id is still not yet created. I then tried to add the "cloud" user
> manually, using exactly the same credentials as the "cloud" user on the
> other host.
> 
> >From the host, I tried to do a virsh connect qemu+ssh to the other host
> using the "cloud" user (instead of root), and getting this error:
> 
> cloud@hv-kvm-01:~$ virsh --connect qemu+ssh://cloud@10.237.3.22/system list
> cloud@10.237.3.22's password:
> error: failed to connect to the hypervisor
> error: no valid connection
> error: End of file while reading data: : Input/output error
> 
> If you notice, the error is the same exact error message I see on the
> management-server.log when I tried to do a live migration of VM. So I tried
> to follow this lead and implement this instruction to allow the "cloud"
> user to have access to the hypervisor on the other host:
> 
> http://wiki.libvirt.org/page/SSHSetup
> 
> usermod -G libvirtd -a cloud
> 
> Enabled these on /etc/libvirt/libvirtd.conf:
> 
> unix_sock_group = "libvirtd"
> unix_sock_rw_perms = "0770"
> 
> I also copied the SSH keys of the cloud user to the other host, so that it
> will not prompt for password.
> 
> And I am now able to do a virsh connect using the "cloud" user:
> 
> cloud@hv-kvm-01:~$ virsh --connect qemu+ssh://cloud@10.237.3.22/system list
>  Id    Name                           State
> ----------------------------------------------------
>  2     i-2-275-VM                     running
>  3     i-2-276-VM                     running
>  4     i-2-293-VM                     running
> 
> But I am still not able to perform live migration of VM.
> 
> May I know how CloudStack connects to the hypervisors when it performs live
> migration, after finding a suitable target host? Does it request the source
> host to perform a qemu+ssh connect to the target host?
> 

I'm not sure about the specifics here. Perhaps someone else will chime
in - But from looking at the resource for KVM in cloudstack it appears
the libvirt XML contains a qemu+tcp:// connection on migrate. 

Can you tell us if the KVM hosts share the same management subnet?
Are they in the same cluster as CloudStack denotes a cluster?

Is there a way to trap the XMLs sent to the KVM resource in the
libvirt logs? I'd try to enable that if so.

-- 
Prasanna.,

------------------------
Powered by BigRock.com


Mime
View raw message