cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Er Krishna <erkris...@gmail.com>
Subject Re: unable to add host
Date Thu, 06 Jun 2013 06:30:31 GMT
Ahmad,

I have restarted clod-agent and the log is as follows: at this time I have
not tried to add the host from management server: This log is just after
cloud-agent restart:

2013-06-06 11:41:03,225 INFO  [utils.component.ComponentLocator]
(main:null) Unable to find components.xml
2013-06-06 11:41:03,226 INFO  [utils.component.ComponentLocator]
(main:null) Skipping configuration using components.xml
2013-06-06 11:41:03,226 INFO  [cloud.agent.AgentShell] (main:null)
Implementation Version is 4.0.2.20130501180711
2013-06-06 11:41:03,226 INFO  [cloud.agent.AgentShell] (main:null)
agent.properties found at /etc/cloud/agent/agent.properties
2013-06-06 11:41:03,227 INFO  [cloud.agent.AgentShell] (main:null)
Defaulting to using properties file for storage
2013-06-06 11:41:03,228 INFO  [cloud.agent.AgentShell] (main:null)
Defaulting to the constant time backoff algorithm
2013-06-06 11:41:03,350 INFO  [cloud.agent.Agent] (main:null) id is
2013-06-06 11:41:03,352 ERROR [cloud.resource.ServerResourceBase]
(main:null) Nics are not configured!
2013-06-06 11:41:03,355 INFO  [cloud.resource.ServerResourceBase]
(main:null) Designating private to be nic eth2
2013-06-06 11:41:03,420 INFO
[resource.virtualnetwork.VirtualRoutingResource] (main:null)
VirtualRoutingResource _scriptDir to use: scripts/network/domr/kvm
2013-06-06 11:41:03,961 INFO  [kvm.resource.LibvirtComputingResource]
(main:null) No libvirt.vif.driver specififed. Defaults to BridgeVifDriver.
2013-06-06 11:41:04,016 INFO  [cloud.agent.Agent] (main:null) Agent [id =
new : type = LibvirtComputingResource : zone = default : pod = default :
workers = 5 : host = localhost : port = 8250
2013-06-06 11:41:04,034 INFO  [utils.nio.NioClient] (Agent-Selector:null)
Connecting to localhost:8250
2013-06-06 11:41:04,036 ERROR [utils.nio.NioConnection]
(Agent-Selector:null) Unable to connect to remote
2013-06-06 11:41:09,041 INFO  [utils.nio.NioClient] (Agent-Selector:null)
Connecting to localhost:8250
2013-06-06 11:41:09,042 ERROR [utils.nio.NioConnection]
(Agent-Selector:null) Unable to connect to remote






I am first time using java and cloudstack so pls help me to set the log4j
properties to debug or trace level. How to do it, I dont know. I have used
repositories to install the cloudagent packages. pls tell me which file I
need to make what entries and how to restart it ?

Krishna




On Wed, Jun 5, 2013 at 10:22 PM, Ahmad Emneina <aemneina@gmail.com> wrote:

> Can you restart the cloud-agent service on the hypervisor host and post
> the output from those logs? Also ensure log4j is set to TRACE or DEBUG
> level logging before the restart.
>
> Ahmad
>
> On Jun 5, 2013, at 9:35 AM, Er Krishna <erkrishna@gmail.com> wrote:
>
> > On 5 Jun 2013 21:59, "Ahmad Emneina" <aemneina@gmail.com> wrote:
> >>
> >> Looks like there was a timeout connecting to the host. What hypervisor
> > are you using?
> >
> > Kvm
> >>
> >> Ahmad
> >>
> >> On Jun 5, 2013, at 7:14 AM, Er Krishna <erkrishna@gmail.com> wrote:
> >>
> >>> Host and management Server are seperated and both have Ubuntu 12.0.4
> and
> >>> cloudstack version on both node is 4.0.2 . I have exported primary and
> >>> secondry directory via NFS from management to host.  On secondry node
> VM
> >>> templates are there. I have configured NTP on both but still the
> problem
> >>> persist. I have pasted management server log at following location:
> >>>
> >>>
> >>> http://apaste.info/in3l
> >>>
> >>> Krishna
> >>>
> >>>
> >>> On Tue, Jun 4, 2013 at 6:04 PM, David Nalley <david@gnsa.us> wrote:
> >>>
> >>>> How about we start with what platform and what version of CloudStack.
> >>>>
> >>>> Also - your agent.log timestamp and management server log timestamps
> >>>> have a 30 minute skew, and the management server logs are remotely
> >>>> related to adding an agent - can we see the actual time period that
> >>>> you tried to add a host - preferably several hundred lines -
> >>>> apaste.info that and share a link.
> >>>>
> >>>> --David
> >>>>
> >>>> On Tue, Jun 4, 2013 at 7:56 AM, Er Krishna <erkrishna@gmail.com>
> wrote:
> >>>>> I am not able to add host. Pls help me to debug this.
> >>>>>
> >>>>> My host machine agent.log is:
> >>>>> 2016-11-02 18:46:56,633 INFO  [utils.nio.NioClient]
> > (Agent-Selector:null)
> >>>>> Connecting to localhost:8250
> >>>>> 2016-11-02 18:46:56,633 ERROR [utils.nio.NioConnection]
> >>>>> (Agent-Selector:null) Unable to connect to remote
> >>>>> 2016-11-02 18:46:56,732 INFO  [cloud.agent.Agent]
> >>>>> (AgentShutdownThread:null) Stopping the agent: Reason = sig.kill
> >>>>>
> >>>>>
> >>>>> Management server log is :
> >>>>>
> >>>>> 2013-06-04 17:18:14,118 DEBUG
> >>>>> [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
> > Zone
> >>>> 2
> >>>>> is not ready to launch secondary storage VM yet
> >>>>> 2013-06-04 17:18:14,157 DEBUG
> >>>> [cloud.consoleproxy.ConsoleProxyManagerImpl]
> >>>>> (consoleproxy-1:null) Skip capacity scan due to there is no Primary
> >>>> Storage
> >>>>> UPintenance mode
> >>>>> 2013-06-04 17:18:14,545 DEBUG [cloud.alert.AlertManagerImpl]
> >>>>> (CapacityChecker:null) Running Capacity Checker ...
> >>>>> 2013-06-04 17:18:14,545 DEBUG [cloud.alert.AlertManagerImpl]
> >>>>> (CapacityChecker:null) recalculating system capacity
> >>>>> 2013-06-04 17:18:14,545 DEBUG [cloud.alert.AlertManagerImpl]
> >>>>> (CapacityChecker:null) Executing cpu/ram capacity update
> >>>>> 2013-06-04 17:18:14,547 DEBUG [cloud.alert.AlertManagerImpl]
> >>>>> (CapacityChecker:null) Done executing cpu/ram capacity update
> >>>>>
> >>>>>
> >>>>>
> >>>>> Krishna
> >>>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message