cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wq meng <wqm...@gmail.com>
Subject Re: The client agent setup not get the correct mgmtcidr ?
Date Sat, 01 Jun 2013 11:05:55 GMT
Hello Paul

I use this command to setup the database.

cloud-setup-databases cloud:XXXXX@localhost --deploy-as=root:XXXX -i
192.168.100.2

I have manually forced the IP to use 192.168.100.2


Thank you.




On Sat, Jun 1, 2013 at 3:58 PM, Paul Angus <paul.angus@shapeblue.com> wrote:

> When you run cloud(stack)-setup-databases CloudStack picks one of the
> host's IP addresses to declare as 'THE' management address
>
> There is a global setting called 'host' which you can change to the ip
> address you require CloudStack to use.
>
>
> Regards,
>
> Paul Angus
> S: +44 20 3603 0540 | M: +447711418784
> paul.angus@shapeblue.com
>
> -----Original Message-----
> From: wq meng [mailto:wqmeng@gmail.com]
> Sent: 31 May 2013 21:05
> To: users@cloudstack.apache.org
> Subject: The client agent setup not get the correct mgmtcidr ?
>
> The client agent setup not get the correct mgmtcidr ?
>
> On my ONE BOX set-up.
>
> I have one NIC.
>
> CloudStack 4.02  with  KVM on CentOS 6.4 x86_64.   for advance network.
>
> Here is how my bridge setup.
>
> eth1 --- *br0 *-------  192.168.100.0/24 is the management network for
> Cloudstack
> eth1 --- *br0:0* -----  3.3.3.0/29,  3.3.3.2 is a public IP for remote
> operate this computer.
> eth1.1200 --- cloudVirBr1200 --- Vlan 1200,  public network for Cloudstack
> with IP 4.4.4.0/24
> eth1.1300 --- cloudVirBr1300 --- Vlan 1300,  guest network for Cloudstack
> with 10.1.1.0/24
>
> Okay,
>
> Please see br0,  and br0:0,  this is ONE bridge,  but have assigned TWO ip
> cidr, one is 192.168.100.0/24 another one is 3.3.3.0/29 .
>
> As it is a ONE BOX, I have added 192.168.100.2 and also 3.3.3.2 to this
> computer. 3.3.3.2 is use for remote operate this host(computer), it is not
> related to Cloudstack at all.  192.168.100.2 is the IP for the host also I
> add it to the UI.
>
> Here the problem is,  when I added everything from the UI, I add the br0
> to the mgnt network, the cloud management and the agent is up and running,
> but in the /etc/cloud/agent/agent.properties , the host=3.3.3.2 but not
> 192.168.100.2,  and inside the SSVM and the CPVM, the mgmtcidr in the
> Kernel argument,  /var/cache/cloud/cmdline file,  it is 3.3.3.0/29 too
> but not 192.168.100.0/24 .
>
> So it is confusing here.  Why the agent set-up use 3.3.3.0/29 but not
> 192.168.100.0/24?
>
> It maybe a set-up configuration problem when deploy the ZONE?
>
>
> Thank you.
> This email and any attachments to it may be confidential and are intended
> solely for the use of the individual to whom it is addressed. Any views or
> opinions expressed are solely those of the author and do not necessarily
> represent those of Shape Blue Ltd or related companies. If you are not the
> intended recipient of this email, you must neither take any action based
> upon its contents, nor copy or show it to anyone. Please contact the sender
> if you believe you have received this email in error. Shape Blue Ltd is a
> company incorporated in England & Wales. ShapeBlue Services India LLP is
> operated under license from Shape Blue Ltd. ShapeBlue is a registered
> trademark.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message