cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Wheeler <rwhee...@artifact-software.com>
Subject Re: Unable to create host
Date Wed, 19 Jun 2013 12:41:35 GMT
This contradicts the documentation.


          8.1.7.2.1. Configure in RHEL or CentOS

vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
HWADDR=00:04:xx:xx:xx:xx
ONBOOT=yes
HOTPLUG=no
BOOTPROTO=none
TYPE=Ethernet

Which is right?

On 19/06/2013 8:19 AM, Nehal J. Wani wrote:
> Seems like you missed the step of creating the bridge interface cloudbr0
>
> 1. edit /etc/sysconfig/network-scripts/ifcfg-eth­0
>
> DEVICE=eth0
> HWADDR=52:54:00:B9:A6:C0 #Replace with appropriate MAC-ID
> NM_CONTROLLED=no
> ONBOOT=yes
> BOOTPROTO=none
> BRIDGE=cloudbr0
>
> 2. edit /etc/sysconfig/network-scripts/ifcfg-clo­udbr0
>
> DEVICE=cloudbr0
> HWADDR=52:54:00:B9:A6:C0 #Replace with appropriate MAC-ID
> NM_CONTROLLED=no
> ONBOOT=yes
> BOOTPROTO=none
> IPADDR=10.3.3.56           #Replace with correct ip
> NETMASK=255.255.255.0 #Replace with correct mac-id
> GATEWAY=10.3.3.1         #Replace with correct gateway
> DNS1=10.4.3.222             #Replace with correct DNS
> TYPE=Bridge
> DELAY=0
>
> On 6/19/13, Jefferson Briones (CONVERGE) <jcbriones@convergeict.com> wrote:
>> Hi Dean,
>> Im using  centos 6.3 minimal install.
>>
>> [root@srvr1 etc]# uname -a
>> Linux srvr1.cloud.priv 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC
>> 2013 x86_64 x86_64 x86_64 GNU/Linux
>>
>>
>> I also have this one nic only, and got this interface config.
>> [root@srvr1 etc]# ifconfig
>> cloud0    Link encap:Ethernet  HWaddr 42:B0:18:BA:CD:3E
>>            inet addr:169.254.0.1  Bcast:169.254.255.255  Mask:255.255.0.0
>>            inet6 addr: fe80::40b0:18ff:feba:cd3e/64 Scope:Link
>>            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>>            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>            TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
>>            collisions:0 txqueuelen:0
>>            RX bytes:0 (0.0 b)  TX bytes:468 (468.0 b)
>>
>> eth0      Link encap:Ethernet  HWaddr 14:DA:E9:78:81:FD
>>            inet addr:x.x.170.195  Bcast:x.x.170.223  Mask:255.255.255.224
>>            inet6 addr: fe80::16da:e9ff:fe78:81fd/64 Scope:Link
>>            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>>            RX packets:1878690 errors:0 dropped:0 overruns:0 frame:0
>>            TX packets:217665 errors:0 dropped:0 overruns:0 carrier:0
>>            collisions:0 txqueuelen:1000
>>            RX bytes:151244632 (144.2 MiB)  TX bytes:52239534 (49.8 MiB)
>>
>> lo        Link encap:Local Loopback
>>            inet addr:127.0.0.1  Mask:255.0.0.0
>>            inet6 addr: ::1/128 Scope:Host
>>            UP LOOPBACK RUNNING  MTU:16436  Metric:1
>>            RX packets:4558694 errors:0 dropped:0 overruns:0 frame:0
>>            TX packets:4558694 errors:0 dropped:0 overruns:0 carrier:0
>>            collisions:0 txqueuelen:0
>>            RX bytes:582826267 (555.8 MiB)  TX bytes:582826267 (555.8 MiB)
>>
>> virbr0    Link encap:Ethernet  HWaddr 52:54:00:69:3B:B5
>>            inet addr:192.168.122.1  Bcast:192.168.122.255
>> Mask:255.255.255.0
>>            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>>            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>            TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
>>            collisions:0 txqueuelen:0
>>            RX bytes:0 (0.0 b)  TX bytes:2520 (2.4 KiB)
>>
>> ^[^[INFO  [cloud.resource.ResourceManagerImpl] (catalina-exec-20:) Trying
>> to
>> add a new host at http://192.168.122.2 in data center 1
>> WARN  [kvm.discoverer.KvmServerDiscoverer] (catalina-exec-20:)  can't setup
>> agent, due to java.io.IOException: There was a problem while connecting to
>> 192.168.122.2:22 - There was a problem while connecting to 192.168.122.2:22
>> WARN  [cloud.resource.ResourceManagerImpl] (catalina-exec-20:) Unable to
>> find the server resources at http://192.168.122.2
>> WARN  [api.commands.AddHostCmd] (catalina-exec-20:) Exception:
>> com.cloud.exception.DiscoveryException: Unable to add the host
>>          at
>> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl
>> .java:737)
>>          at
>> com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.jav
>> a:544)
>>          at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:140)
>>          at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
>>          at com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
>>          at com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
>>          at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
>>          at com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
>>          at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
>>          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
>>          at
>> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
>> FilterChain.java:290)
>>          at
>> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
>> ain.java:206)
>>          at
>> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja
>> va:233)
>>          at
>> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
>> va:191)
>>          at
>> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127
>> )
>>          at
>> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102
>> )
>>          at
>> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
>>          at
>> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
>> :109)
>>          at
>> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
>>          at
>> org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:
>> 889)
>>          at
>> org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(H
>> ttp11NioProtocol.java:721)
>>          at
>> org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:
>> 2274)
>>          at
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:11
>> 46)
>>          at
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:6
>> 15)
>>          at java.lang.Thread.run(Thread.java:679)
>> WARN  [cloud.api.ApiDispatcher] (catalina-exec-20:) class
>> com.cloud.api.ServerApiException : Unable to add the host
>>
>>
>>
>>
>> -----Original Message-----
>> From: Dean Kamali [mailto:dean.kamali@gmail.com]
>> Sent: Wednesday, June 19, 2013 10:47 AM
>> To: users@cloudstack.apache.org
>> Subject: Re: Unable to create host
>>
>> Is ssh running on your KVM box?  Is it centos or Ubuntu ??
>>
>> Give us version, and more detailed info, pasting the log in email like this
>> is annoying, why don't you use pastebin??
>> On Jun 18, 2013 2:56 AM, "Jefferson Briones (CONVERGE)" <
>> jcbriones@convergeict.com> wrote:
>>
>>> Hi guys,
>>> After accessing the client web page, I was able to create zone, pod
>>> and cluster but I got a failed attempt on the host. Below are the
>>> logs.  What is missing in my config?
>>>
>>> [root@srvr1 management]# tail -f management-server.log
>>> 2013-06-18 14:51:19,925 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>>> timestamp but is pingable
>>> 2013-06-18 14:51:21,425 DEBUG [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Detected management node left, id:1,
>>> nodeIP:202.69.170.195
>>> 2013-06-18 14:51:21,425 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Trying to connect to 202.69.170.195
>>> 2013-06-18 14:51:21,425 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>>> timestamp but is pingable
>>> 2013-06-18 14:51:22,924 DEBUG [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Detected management node left, id:1,
>>> nodeIP:202.69.170.195
>>> 2013-06-18 14:51:22,924 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Trying to connect to 202.69.170.195
>>> 2013-06-18 14:51:22,924 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>>> timestamp but is pingable
>>> 2013-06-18 14:51:24,423 DEBUG [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Detected management node left, id:1,
>>> nodeIP:202.69.170.195
>>> 2013-06-18 14:51:24,423 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Trying to connect to 202.69.170.195
>>> 2013-06-18 14:51:24,423 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>>> timestamp but is pingable
>>> 2013-06-18 14:51:25,923 DEBUG [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Detected management node left, id:1,
>>> nodeIP:202.69.170.195
>>> 2013-06-18 14:51:25,923 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Trying to connect to 202.69.170.195
>>> 2013-06-18 14:51:25,923 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>>> timestamp but is pingable
>>> 2013-06-18 14:51:26,973 DEBUG
>>> [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
>>> Zone 1 is not ready to launch secondary storage VM yet
>>> 2013-06-18 14:51:27,067 DEBUG
>>> [cloud.consoleproxy.ConsoleProxyManagerImpl]
>>> (consoleproxy-1:null) Skip capacity scan due to there is no Primary
>>> Storage UPintenance mode
>>> 2013-06-18 14:51:27,432 DEBUG [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Detected management node left, id:1,
>>> nodeIP:202.69.170.195
>>> 2013-06-18 14:51:27,432 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Trying to connect to 202.69.170.195
>>> 2013-06-18 14:51:27,433 INFO  [cloud.cluster.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>>> timestamp but is pingable
>>> 2013-06-18 14:51:27,566 DEBUG
>>> [network.router.VirtualNetworkApplianceManagerImpl]
>>> (RouterStatusMonitor-1:null) Found 0 routers.
>>>
>>> Thanks.
>>> jeff
>>>
>>>
>>
>>
>> -----
>> No virus found in this message.
>> Checked by AVG - www.avg.com
>> Version: 2013.0.2904 / Virus Database: 3162/6324 - Release Date: 05/14/13
>> Internal Virus Database is out of date.
>>
>>
>


-- 
Ron Wheeler
President
Artifact Software Inc
email: rwheeler@artifact-software.com
skype: ronaldmwheeler
phone: 866-970-2435, ext 102


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message