cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Mehta <Nitin.Me...@citrix.com>
Subject Re: Deploy VM - Permission issue
Date Tue, 14 May 2013 11:02:17 GMT
Check with vm_template table with id=202 and see whether its removed or
something ?

VirtualMachineTemplate template = getTemplate(id);
        if (template == null) {
            throw new InvalidParameterValueException("unable to find " +
cmd.getMediaType() + " with id " + id);
        }



On 14/05/13 3:51 PM, "Asmita Vagyani" <Asmita.Vagyani@sigma-systems.com>
wrote:

>Yes, when my template was private I got this error.
>
>I created a new template with public, extractable, featured values as
>true.
>http://IP:8096/?command=deployVirtualMachine&apikey=uOlDcfeQ2adMyBsWz_5PBm
>UtbpV7Fw8sIYKPnl1zkPj17Ueu9EuqRoTVF0FQuRKSR_7qRVUYEdYP8-9rd9bo0w&serviceof
>feringid=6188618c-5a8e-4469-9bb7-13e5384ab9ca&templateid=23a7cd3f-3446-4d5
>7-83e8-8d1897792d5b&zoneid=1caa020c-c154-474b-aabd-cab1a6322917&displaynam
>e=Asmi1&domainid=294790f6-43df-4e3c-a73c-9f323dce04e0&account=asmita44&sig
>nature=27LYIdB1intwaDJczB8ZIAYSSjs%3D
>Now the same request gives me error -
><deployvirtualmachineresponse cloud-stack-version="4.0.0.20121024012150">
><errorcode>431</errorcode>
><cserrorcode>9999</cserrorcode>
><errortext>Unable to use template 202</errortext>
></deployvirtualmachineresponse>
>
>Any clue?
>
>-----Original Message-----
>From: Nitin Mehta [mailto:Nitin.Mehta@citrix.com]
>Sent: 14 May 2013 PM 02:29
>To: users@cloudstack.apache.org; cloudstack-users@incubator.apache.org
>Subject: Re: Deploy VM - Permission issue
>
>Are you trying to use any resource belonging to domain 1 like the
>template below - is it private by any chance ?
>
>
>On 14/05/13 12:57 PM, "Asmita Vagyani" <Asmita.Vagyani@sigma-systems.com>
>wrote:
>
>>Hi all,
>>
>>I created a domain , account for a user in cloudstack on port 8096.
>>
>>http://IP:8096/client/api?command=deployVirtualMachine&serviceofferingi
>>d=d
>>03f1c05-3f91-4352-bc42-260182318cbc&templateid=23a7cd3f-3446-4d57-83e8-
>>8d1 
>>897792d5b&zoneid=1caa020c-c154-474b-aabd-cab1a6322917&displayname=Asmi1
>>&do
>>mainid=294790f6-43df-4e3c-a73c-9f323dce04e0&account=asmita44
>>
>>I get error as :
>>
>>Response xml:
>><deployvirtualmachineresponse
>>cloud-stack-version="4.0.0.20121024012150">
>><errorcode>531</errorcode>
>><cserrorcode>9999</cserrorcode>
>><errortext>
>>Acct[5-asmita44] does not have permission to operate within domain id=1
>></errortext> </deployvirtualmachineresponse>
>>
>>For the account user asmita44- the domain Id is 4, account id is 5.
>>There is no relation with the domain id 1. Still it's taking domain id 1.
>>
>>Any clue why this is happening?
>>
>>Regards.
>>Asmita
>
>
>


Mime
View raw message