cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <aemne...@gmail.com>
Subject Re: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router
Date Tue, 14 May 2013 18:16:43 GMT
Agreeing with Geoff's suggestion. What you want to make sure is what you
defined for your zone vlan range, is present on the trunk ports that the
hosts are connected to.


On Tue, May 14, 2013 at 10:59 AM, ronald higgins
<ronald.higgins@gmail.com>wrote:

> Just to 2nd Geoff's diagnoses, on the occasions that I've experienced your
> symptoms it's always ended up being incorrect VLAN configurations across
> ports and or switches.
>
> Ronald
>
> On Tue, May 14, 2013 at 5:21 PM, Geoff Higginbottom <
> geoff.higginbottom@shapeblue.com> wrote:
>
> > Hi Ramkumar,
> >
> > I know you have already said that the VLANs are configured correctly, but
> > 99.99% of the time when you have these symptoms it is related to
> > misconfigured VLANs
> >
> > Please triple check your VLAN configurations, and even try rebooting the
> > switch to ensure the configuration has been applied correctly.
> >
> > Regards
> >
> > Geoff Higginbottom
> >
> > D: +44 20 3603 0542 | S: +44 20 3603 0540 | M: +447968161581
> >
> > geoff.higginbottom@shapeblue.com
> >
> > -----Original Message-----
> > From: Ramkumar Manickam [mailto:mramkumar@collab.net]
> > Sent: 14 May 2013 16:10
> > To: users@cloudstack.apache.org
> > Cc: keerthiraja s. Jegannathan
> > Subject: VM instance cannot aquire IP via DHCP when run on other host
> with
> > Virtual Router
> >
> > Hi Team,
> >
> >
> >
> > We setup cloudstack with Advance Network with two xenserver host with
> > Isolated Guest Network.
> >
> > Vm's are creating with virtual router in host1 and able to acquire IP
> > address.
> >
> > But the issue is when we migrate the VM  to  host2  the vm instance
> cannot
> > aquire IP from virtual router which is located in host1.
> >
> >
> >
> > Exact Issue: when vm and virtual router separated between 2 hosts the
> DHCP
> > request is not passing to from 1 host to another host.
> >
> >
> >
> > Note: -
> >
> >
> >
> > 1.    Both xenservers and cloudstack server are configured in the same
> > vlan.
> >
> > 2.    Xenservers physical nic's is configured as trunk port in physical
> > switch and allowed to pass  all  guest vlan traffics.
> >
> > 3.    Configured correct traffic label in cloudstack  physical network
> > setup and  same has been synced with xenserver's .
> >
> >
> >
> >
> >
> > Kindly let us know what is the cause for not getting ipaddress when vm
> and
> > router are separated.
> >
> >
> >
> > Your quick response is much appreciated. Thanks.
> >
> >
> >
> > Regards,
> >
> > Ramkumar
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > This email and any attachments to it may be confidential and are intended
> > solely for the use of the individual to whom it is addressed. Any views
> or
> > opinions expressed are solely those of the author and do not necessarily
> > represent those of Shape Blue Ltd or related companies. If you are not
> the
> > intended recipient of this email, you must neither take any action based
> > upon its contents, nor copy or show it to anyone. Please contact the
> sender
> > if you believe you have received this email in error. Shape Blue Ltd is a
> > company incorporated in England & Wales. ShapeBlue Services India LLP is
> > operated under license from Shape Blue Ltd. ShapeBlue is a registered
> > trademark.
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message