cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CK <cloudw...@gmail.com>
Subject Template download stuck at 1%
Date Tue, 14 May 2013 23:40:47 GMT
Running a fresh install of ACS on Centos 6.4 with KVM as the host. Having
setup a basic zone the CentOS 5.5(64-bit) no GUI (KVM) template is stuck at
1% downloaded.

I have run through the SSVM troubleshooting guide and everything appears to
be running fine on the SSVM - secstorage nfs mount, public access, etc.

I tried: wget
http://download.cloud.com/releases/2.2.0/eec2209b-9875-3c8d-92be-c001bd8a0faf.qcow2.bz2in
the SSVM a couple of times and it starts saving the template, but each
time is gets as far as around 7MB (eg.7,479,075,  7,173,935) = 1% it just
stops downloading.

Here is an extract of the systemvm.log on SSVM :
2013-05-14 23:39:16,722 DEBUG [cloud.agent.Agent] (UgentTask-5:) Sending
ping: Seq 4-43:  { Cmd , MgmtId: -1, via: 4, Ver: v1, Flags: 11,
[{"PingStorageCommand":{"changes":{},"hostType":"Storage","hostId":4,"wait":0}}]
}
2013-05-14 23:39:16,764 DEBUG [cloud.agent.Agent] (Agent-Handler-5:)
Received response: Seq 4-43:  { Ans: , MgmtId: 279278805450810, via: 4,
Ver: v1, Flags: 100010,
[{"PingAnswer":{"_command":{"hostType":"Storage","hostId":4,"wait":0},"result":true,"wait":0}}]
}
2013-05-14 23:39:24,275 DEBUG [cloud.agent.Agent] (agentRequest-Handler-5:)
Request:Seq 4-1002701101:  { Cmd , MgmtId: 279278805450810, via: 4, Ver:
v1, Flags: 100011,
[{"storage.DownloadProgressCommand":{"jobId":"5b01ccd2-5139-48db-8e67-1fcd7b04d234","request":"GET_STATUS","hvm":false,"description":"CentOS
5.5(64-bit) no GUI
(KVM)","checksum":"ed0e788280ff2912ea40f7f91ca7a249","maxDownloadSizeInBytes":53687091200,"id":4,"resourceType":"TEMPLATE","url":"
http://download.cloud.com/releases/2.2.0/eec2209b-9875-3c8d-92be-c001bd8a0faf.qcow2.bz2
","format":"QCOW2","accountId":1,"name":"centos55-x86_64","secUrl":"nfs://
192.168.2.22/export/secondary","wait":0}}] }
2013-05-14 23:39:24,275 DEBUG [cloud.agent.Agent] (agentRequest-Handler-5:)
Processing command: com.cloud.agent.api.storage.DownloadProgressCommand
2013-05-14 23:39:24,275 DEBUG [cloud.agent.Agent] (agentRequest-Handler-5:)
Seq 4-1002701101:  { Ans: , MgmtId: 279278805450810, via: 4, Ver: v1,
Flags: 10,
[{"storage.DownloadAnswer":{"jobId":"5b01ccd2-5139-48db-8e67-1fcd7b04d234","downloadPct":1,"errorString":"
","downloadStatus":"DOWNLOAD_IN_PROGRESS","downloadPath":"/mnt/SecStorage/9cf54ebb-4221-35ee-97ce-3ff3348c0e02/template/tmpl/1/4/dnld3836401611117167093tmp_","templateSize":0,"templatePhySicalSize":0,"checkSum":"ed0e788280ff2912ea40f7f91ca7a249","result":false,"details":"
","wait":0}}] }
2013-05-14 23:39:34,361 DEBUG [cloud.agent.Agent] (agentRequest-Handler-3:)
Request:Seq 4-1002701102:  { Cmd , MgmtId: 279278805450810, via: 4, Ver:
v1, Flags: 100011,
[{"storage.DownloadProgressCommand":{"jobId":"5b01ccd2-5139-48db-8e67-1fcd7b04d234","request":"GET_STATUS","hvm":false,"description":"CentOS
5.5(64-bit) no GUI
(KVM)","checksum":"ed0e788280ff2912ea40f7f91ca7a249","maxDownloadSizeInBytes":53687091200,"id":4,"resourceType":"TEMPLATE","url":"
http://download.cloud.com/releases/2.2.0/eec2209b-9875-3c8d-92be-c001bd8a0faf.qcow2.bz2
","format":"QCOW2","accountId":1,"name":"centos55-x86_64","secUrl":"nfs://
192.168.2.22/export/secondary","wait":0}}] }
2013-05-14 23:39:34,361 DEBUG [cloud.agent.Agent] (agentRequest-Handler-3:)
Processing command: com.cloud.agent.api.storage.DownloadProgressCommand
2013-05-14 23:39:34,362 DEBUG [cloud.agent.Agent] (agentRequest-Handler-3:)
Seq 4-1002701102:  { Ans: , MgmtId: 279278805450810, via: 4, Ver: v1,
Flags: 10,
[{"storage.DownloadAnswer":{"jobId":"5b01ccd2-5139-48db-8e67-1fcd7b04d234","downloadPct":1,"errorString":"
","downloadStatus":"DOWNLOAD_IN_PROGRESS","downloadPath":"/mnt/SecStorage/9cf54ebb-4221-35ee-97ce-3ff3348c0e02/template/tmpl/1/4/dnld3836401611117167093tmp_","templateSize":0,"templatePhySicalSize":0,"checkSum":"ed0e788280ff2912ea40f7f91ca7a249","result":false,"details":"
","wait":0}}] }


Any idea why it is stopping and not fully downloading the template?

Regards

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message