cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanley Kaytovich <Stanl...@qwertyc.com>
Subject RE: Problem creating VMware cluster after building 4.0.2 from source - Found word(s) list error in the Text body
Date Tue, 07 May 2013 21:29:15 GMT
David,

Certainly, how do I do this?

Regards,
Stan

-----Original Message-----
From: David Nalley [mailto:david@gnsa.us] 
Sent: Tuesday, May 7, 2013 5:14 PM
To: users@cloudstack.apache.org
Subject: RE: Problem creating VMware cluster after building 4.0.2 from source - Found word(s)
list error in the Text body

Would you mind updating the wiki with the missing steps?
On May 7, 2013 5:05 PM, "Stanley Kaytovich" <StanleyK@qwertyc.com> wrote:

> The last error was solved by copying the commons-discover-0.5.jar to 
> /usr/share/java and restarting the server.
>
> VMWare Cluster can now be added.
>
> Thank you.
>
> -----Original Message-----
> From: Stanley Kaytovich
> Sent: Tuesday, May 7, 2013 3:57 PM
> To: users@cloudstack.apache.org; aemneina@gmail.com; Kelven Yang
> Subject: RE: Problem creating VMware cluster after building 4.0.2 from 
> source - Found word(s) list error in the Text body
>
> Hi Vijay and David (and everyone else),
>
> We were able to build 4.0.1 successfully and install the debs after 
> switching to 4.0 branch with the non-oss patch.
>
> Now we are getting the following error when creating a new VMware cluster:
> ERROR [cloud.api.ApiDispatcher] (catalina-exec-18:null) Exception 
> while executing AddClusterCmd:
> java.lang.NoClassDefFoundError:
> org/apache/commons/discovery/tools/DiscoverSingleton
>
> We suspect the file is being referenced does not exist. Searching for 
> DiscoverSingleton.java did not show results.
>
> We have commons-discovery-0.5.jar in the deps folder when building.
>
> Thank you,
>
> Stan
>
> -----Original Message-----
> From: Vijayendra Bhamidipati 
> [mailto:vijayendra.bhamidipati@citrix.com]
> Sent: Tuesday, May 7, 2013 1:21 PM
> To: users@cloudstack.apache.org; aemneina@gmail.com; Kelven Yang
> Subject: RE: Problem creating VMware cluster after building 4.0.2 from 
> source - Found word(s) list error in the Text body
>
> Hi Stanley,
>
> To build nonoss from source, please try the instructions given in this 
> link to build the nonoss components - 
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/How+to+build+on
> +master+branch
>
> You need to just take care to ensure that you extract the vim* jar 
> files (for vmware's vi sdk) after you download the websdk 510 file, 
> and copy them over to your deps directory.
>
> Typically, for non-oss, this is what you will need to do:
>
> find / | grep -I "systemvm.iso"; rm all the files found (you needn't 
> do this everytime - I do this whenever I deploy a fresh cloudstack testbed).
> cd deps;
> wget and rename all jar files as directed; download the vi sdk jar 
> files, and extract the jars from them; rename as directed; 
> ./install-non-oss.sh
>
> cd ../
> mvn clean; mvn install -P systemvm -Dnonoss -DskipTests; mvn install 
> -Dnonoss -DskipTests If you have a mysql root password set, cp 
> utils/conf/db.properties utils/conf/db.properties.override; edit 
> db.properties.override to set 
> db.root.password=<your_mysql_root_password>
> mvn -e -P developer -pl developer -Ddeploydb; mvn -pl :cloud-client-ui 
> jetty:run -Dnonoss
>
>
> The -DskipTests should not be used if you have edited any part of the 
> code, for it skips running mockito tests.
>
> Regards,
> Vijay
>
>
> -----Original Message-----
> From: Stanley Kaytovich [mailto:StanleyK@qwertyc.com]
> Sent: Tuesday, May 07, 2013 8:03 AM
> To: aemneina@gmail.com; Kelven Yang; Vijayendra Bhamidipati
> Cc: users@cloudstack.apache.org
> Subject: RE: Problem creating VMware cluster after building 4.0.2 from 
> source - Found word(s) list error in the Text body
>
> Ahmad,
>
> If not from source, how else can I install with nonoss? Seems like 
> we've tried everything we could find, including a Jenkins package, 
> which gave us different errors.
>
> As of right now, we are suspecting that something is wrong during the 
> build process since we are getting the same results every time. We 
> will try using ant instead of mvn3.
>
> From: Ahmad Emneina [mailto:aemneina@gmail.com]
> Sent: Tuesday, May 7, 2013 10:58 AM
> To: Stanley Kaytovich; Kelven Yang; vijayendra.bhamidipati@citrix.com
> Cc: users@cloudstack.apache.org
> Subject: Re: Problem creating VMware cluster after building 4.0.2 from 
> source
>
> Sounds good, I havent built and deployed from source in a very long 
> time, so i wont be much help... but I know who has. Looping in Vijay and Kelven.
>
> On Tue, May 7, 2013 at 6:18 AM, Stanley Kaytovich 
> <StanleyK@qwertyc.com <mailto:StanleyK@qwertyc.com>> wrote:
> Ahmad,
>
> Thank you. I sent a copy to the dev list as well. In the meantime, 
> trying to perform the install on Debian following the same article and 
> see if we get the same results.
>
>
> -----Original Message-----
> From: Ahmad Emneina 
> [mailto:aemneina@gmail.com<mailto:aemneina@gmail.com>]
> Sent: Monday, May 6, 2013 5:36 PM
> To: Cloudstack users mailing list
> Subject: Re: Problem creating VMware cluster after building 4.0.2 from 
> source
>
> Hey Stanley, you might want to ping the dev list for this as well. I'm 
> sure people are more familiar with building cloudstack on that ml.
>
>
> On Mon, May 6, 2013 at 2:16 PM, Stanley Kaytovich 
> <StanleyK@qwertyc.com
> <mailto:StanleyK@qwertyc.com>>wrote:
>
> > Hello,
> >
> > I followed the documentation on
> > http://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.0.2/html
> > /I nstallation_Guide/index.html, and have tried this several times 
> > with no luck.
> >
> > Package: 4.0.2
> > OS: Ubuntu 12.04
> >
> > Below are the steps I took to perform the build as outlined in the 
> > above
> > article:
> >
> > Manually downloaded VMware-*.jar files into deps folder 
> > deps/install-non-oss.sh mvn -P deps -Dnonoss (fails looking for
> > vmware-base) cd ../vmware-base mvn install (completes) mvn -P deps 
> > -Dnonoss (completes) mvn install -Dnonoss (completes) build packages 
> > and install debs cloudstack UI works, but we cannot add the VMware 
> > cluster. We receive an error "Could not find corresponding resource 
> > manager for VMware"
> > Manually moved all the vmware-*.jar files into WEB-INF\lib checked 
> > components.xml and there were no references to VMWare nonoss added 
> > VMWare nonoss parameters manually  (from:
> > http://markmail.org/message/5eqasgpjxy2oqsoc#query:+page:1+mid:dvf3a
> > qb
> > syl4kphrm+state:resultsand also referenced
> > https://cwiki.apache.org/CLOUDSTACK/building.data/4.0-nonoss.patch ) 
> > Now can't start cloud-management with the
> > com.cloud.utils.exception.CloudRuntimeException: Unable to find class:
> > com.cloud.hypervisor.vmware.VmwareServerDiscoverer
> >
> > Additional info:
> > Once the lines added into components.xml are commented out, the 
> > service starts but we are back to the original error "Could not find 
> > corresponding resource manager for VMware"
> >
> > Any guidance on this is much appreciated!
> >
> >
>
>

Mime
View raw message