cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanley Kaytovich <Stanl...@qwertyc.com>
Subject Problem creating VMware cluster after building 4.0.2 from source
Date Mon, 06 May 2013 20:03:47 GMT
Hello,

I followed the documentation on http://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.0.2/html/Installation_Guide/index.html,
and have tried this several times with no luck.

Package: 4.0.2
OS: Ubuntu 12.04

Below are the steps I took to perform the build as outlined in the above article:

Manually downloaded VMware-*.jar files into deps folder
deps/install-non-oss.sh
mvn -P deps -Dnonoss (fails looking for vmware-base)
cd ../vmware-base
mvn install (completes)
mvn -P deps -Dnonoss (completes)
mvn install -Dnonoss (completes)
build packages and install debs
cloudstack UI works, but we cannot add the VMware cluster. We receive an error "Could not
find corresponding resource manager for VMware"
Manually moved all the vmware-*.jar files into WEB-INF\lib
checked components.xml and there were no references to VMWare nonoss
added VMWare nonoss parameters manually  (from: http://markmail.org/message/5eqasgpjxy2oqsoc#query:+page:1+mid:dvf3aqbsyl4kphrm+state:results
and also referenced https://cwiki.apache.org/CLOUDSTACK/building.data/4.0-nonoss.patch )
Now can't start cloud-management with the com.cloud.utils.exception.CloudRuntimeException:
Unable to find class: com.cloud.hypervisor.vmware.VmwareServerDiscoverer

Additional info:
Once the lines added into components.xml are commented out, the service starts but we are
back to the original error "Could not find corresponding resource manager for VMware"

Any guidance on this is much appreciated!



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message