cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kelven Yang <kelven.y...@citrix.com>
Subject Re: issue after upgrade from 2.2.14 to 4.0.0 "Unable to find or allocate console proxy resource"
Date Mon, 08 Apr 2013 21:23:09 GMT
You need to turn on management server log level instead of that in
agent.properties. (do it at /etc/cloud/management-server/log4j-cloud.xml"
). Need to more log info to find what's going on

Kelven

On 4/8/13 12:13 PM, "Shashi Dahal" <s.dahal@leaseweb.com> wrote:

>HI Kelvin, 
>
>Since the console proxy was not working , I deleted it hoping that it
>would be recreated. Now it is not being re-created  and all I have is the
>"Unable to find or allocate console proxy resource"  in the logs.
>
>I do not have any  console proxy now.
>
>Cheers,
>Shashi
>
>________________________________________
>From: Kelven Yang [kelven.yang@citrix.com]
>Sent: Monday, April 08, 2013 7:05 PM
>To: users@cloudstack.apache.org
>Subject: Re: issue after upgrade from 2.2.14 to 4.0.0  "Unable to find or
>allocate console proxy resource"
>
>What do you see from CloudStack management UI about the running status of
>console proxy VM?
>
>If you can login into console proxy VM, try to find log from within it
>under /var/log/cloud/systemvm.log
>
>Kelven
>
>On 4/8/13 6:15 AM, "Shashi Dahal" <s.dahal@leaseweb.com> wrote:
>
>>Hi,
>>
>>I did an upgrade from cloudstack 2.2.14 to 4.0.0 following the release
>>notes "Upgrade from 2.2.14 to 4.0.0-incubating" . I did not had any
>>issues with the upgrade itself.
>>
>>I had to change the command :  cloud-sysvmadm -d 192.168.1.5 -u cloud -p
>>password -c -r   to  cloud-sysvmadm -d 192.168.1.5 -u cloud -p password
>>-s -r
>>as the -c is not valid , and accordingly all system VMs were restarted
>>
>>-------
>>Stopping and starting 1 secondary storage vm(s)...
>>Done stopping and starting secondary storage vm(s)
>>
>>Stopping and starting 1 console proxy vm(s)...
>>Done stopping and starting console proxy vm(s).
>>
>>Stopping and starting 1 running routing vm(s)...
>>Done restarting router(s).
>>-------
>>
>>I was able to login to the console proxy and run
>>/usr/local/cloud/systemvm/ssvm-check.sh  and it reported everything
>>working fine.
>>But console did not worked, so I destroyed the console-proxy , as it
>>would recreate it again.
>>
>>Now, I end up with this line in the logs:
>>WARN  [cloud.consoleproxy.ConsoleProxyManagerImpl]
>>(catalina-exec-20:null) Unable to find or allocate console proxy resource
>>
>>I edited the debug level from INFO to DEBUG in agent.properties in the
>>hypervisors hoping it will show more lines, but that is the only line I
>>end up with regarding console proxy.
>>I also doubled the value in consoleproxy.capacity.standby  compared to
>>consoleproxy.session.max so that it would create a new console proxy,
>>which it is not.
>>
>>If you have faced this issue before, please do let me know how to
>>proceed.
>>
>>
>>Cheers,
>>Shashi
>>
>


Mime
View raw message