cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Brockmeier <...@zonker.net>
Subject Re: Failure to create deb packages
Date Sat, 20 Apr 2013 00:07:34 GMT
On Fri, Apr 19, 2013, at 06:48 PM, Preethi Natarajan wrote:
> Hi Joe,
> 
> Thanks for getting back.
> 
> dpkg-buildpackage complained about unmet build dependencies for tomcat6.
> 
> I don't understand since CATALINA_HOME and CATALINA_BASE are set to the
> install locations of tomcat-6.0.33 (in my HOME). Any ideas what may be
> happening? Many thanks.

You're building a debian package - dpkg-buildpackage doesn't know about
your install of Tomcat. You need to install the dependencies as
specified in the install guide for building Debian packages:

http://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.0.1-incubating/html/Installation_Guide/sect-source-builddebs.html

sudo apt-get install ant debhelper openjdk-6-jdk tomcat6
libws-commons-util-java genisoimage python-mysqldb libcommons-codec-java
libcommons-httpclient-java liblog4j1.2-java maven3

You may already have some of those packages, and it's possible that
4.2.0 requires different dependencies - but that's where I'd start. 

Best,

jzb
-- 
Joe Brockmeier
jzb@zonker.net
Twitter: @jzb
http://www.dissociatedpress.net/

Mime
View raw message