cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Musayev, Ilya" <imusa...@webmd.net>
Subject RE: CloudStack 4.0.1 VMWare Support
Date Tue, 05 Mar 2013 17:45:45 GMT
Scott,

This is a common question asked on dev@ list. You are missing the non-open source java dependencies.

In the nutshell, we have 2 versions of cloudstack

1) open source - oss - KVM and XEN
2) non open source - nonoss - NetApp, VmWare, F5, NetScaler, etc...

If you are installing with RPMs, make sure you download the nonoss version.

If you are downloading a source from apache git, the INSTALL.md file describes in good amount
of detail what to do and where to get the missing files. Please search the dev maling or cloudstack
wiki, Wido hosts a repository with all dependencies, I just don't have the link handy.

Regards
ilya


> -----Original Message-----
> From: Taubman, Scott A [mailto:scott.a.taubman@thesiorg.com]
> Sent: Tuesday, March 05, 2013 9:47 AM
> To: cloudstack-users@incubator.apache.org
> Subject: CloudStack 4.0.1 VMWare Support
> 
> I'm wondering if anyone has successfully gotten the VMWare hypervisor
> support working with CloudStack 4.0.1.  I know that the VMWare support is
> no longer in the official RPM packages, but even attempts to compile myself
> with the nonoss modules fails at trying to build the VMWare step.  I'm not a
> maven expert, but it looks like it's trying to download a POM and metadata
> file from
> http://repository.apache.org/snapshots/org/apache/cloudstack/cloud-
> vmware-base/4.0.1-incubating-SNAPSHOT/, which doesn't actually exist.
> 
> Anyway, I'm less looking to troubleshoot and more just curious if anyone has
> managed to get the VMWare hypervisor working in 4.0.1 or if I should just go
> back to 4.0.0 and wait for a future release.
> 
> Thanks for any insight you can provide.
> 
> Regards,
> Scott Taubman


Mime
View raw message