cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kirk Jantzer <kirk.jant...@gmail.com>
Subject Re: Unable to add rebuilt xenserver host
Date Fri, 29 Mar 2013 19:12:32 GMT
looks like they're both openvswitch

host1:  xe host-param-list uuid=<uuid> |grep "backend"
                     software-version (MRO): product_version: 6.0.2;
product_version_text: 6.0.2; product_version_text_short: 6.0.2;
product_brand: XenServer; build_number: 53456p; hg_id: ; hostname: choi-3;
date: 2012-03-20; dbv: 2010.0521; xapi: 1.3; xen: 4.1.2; linux:
2.6.32.12-0.7.1.xs6.0.2.542.170665xen; xencenter_min: 1.9; xencenter_max:
1.9;* network_backend: openvswitch*; xs:XS602E001.XS602E002: Hotfix
XS602E001.XS602E002, version 6.0.2; dell:OM-SrvAdmin-Dell-Web-LX:
OpenManage Supplemental Pack, version 6.5.0, build 3983; xs:main: XenServer
Pack, version 6.0.2, build 53456p; xcp:main: Base Pack, version 1.0.99,
build 53456p; xs:xenserver-transfer-vm: XenServer Transfer VM, version
6.0.2, build 53456p

host3: xe host-param-list uuid=<uuid> |grep "backend"
                     software-version (MRO): product_version: 6.0.2;
product_version_text: 6.0.2; product_version_text_short: 6.0.2;
product_brand: XenServer; build_number: 53456p; hg_id: ; hostname: choi-3;
date: 2012-03-20; dbv: 2010.0521; xapi: 1.3; xen: 4.1.2; linux:
2.6.32.12-0.7.1.xs6.0.2.542.170665xen; xencenter_min: 1.9; xencenter_max:
1.9; *network_backend: openvswitch*; xs:xenserver-transfer-vm: XenServer
Transfer VM, version 6.0.2, build 53456p; dell:OM-SrvAdmin-Dell-Web-LX:
OpenManage Supplemental Pack, version 6.5.0, build 3983;
xs:XS602E001.XS602E002: Hotfix XS602E001.XS602E002, version 6.0.2;
xcp:main: Base Pack, version 1.0.99, build 53456p; xs:main: XenServer Pack,
version 6.0.2, build 53456p



On Fri, Mar 29, 2013 at 3:12 PM, Ahmad Emneina <aemneina@gmail.com> wrote:

> You'll need to supply the host uuid, usually you can tab this out ( hit
> tab a few times after specifying uuid=) for a hint.
>
> Ahmad
>
> On Mar 29, 2013, at 11:57 AM, Kirk Jantzer <kirk.jantzer@gmail.com> wrote:
>
> > [root@<hostname> ~]# xe host-param-list | grep "backend"
> > Required parameter not found: uuid
> > For usage run: 'xe help'
> > [root@<hostname> ~]# xe host-param-list
> > Required parameter not found: uuid
> > For usage run: 'xe help'
> >
> >
> >
> > On Fri, Mar 29, 2013 at 2:53 PM, Ahmad Emneina <aemneina@gmail.com>
> wrote:
> >
> >> Can you grep for backend on xe host-param-list on the different hosts. I
> >> thing one might be bridged while the other is using openvswitch.
> >>
> >> Ahmad
> >>
> >> On Mar 29, 2013, at 11:46 AM, Kirk Jantzer <kirk.jantzer@gmail.com>
> wrote:
> >>
> >>> Sorry, proper link: http://pastebin.com/5b0hKfhK
> >>>
> >>>
> >>> On Fri, Mar 29, 2013 at 2:44 PM, Kirk Jantzer <kirk.jantzer@gmail.com
> >>> wrote:
> >>>
> >>>> the log when trying to add the host: http://pastebin.com/P8HUs1sG
> >>>>
> >>>>
> >>>> On Fri, Mar 29, 2013 at 2:36 PM, Ahmad Emneina <aemneina@gmail.com>
> >> wrote:
> >>>>
> >>>>> /var/log/xensource.log , one that captures the exception when failing
> >> to
> >>>>> add the host.
> >>>>>
> >>>>> Ahmad
> >>>>>
> >>>>> On Mar 29, 2013, at 11:28 AM, Kirk Jantzer <kirk.jantzer@gmail.com>
> >>>>> wrote:
> >>>>>
> >>>>>> host1 = currently in cluster
> >>>>>> host3 = host trying to add to cluster
> >>>>>>
> >>>>>> host1 xe network-list: http://pastebin.com/HVN6Crvy
> >>>>>> host1 xe pif-ist: http://pastebin.com/pzyHwMDz
> >>>>>> host3 xe network-list: http://pastebin.com/inBridi6
> >>>>>> host3 xe pif-ist: http://pastebin.com/UvL3NjpS
> >>>>>>
> >>>>>> ahmed - which log are you referring to?
> >>>>>>
> >>>>>>
> >>>>>> On Fri, Mar 29, 2013 at 2:29 AM, Ahmad Emneina <aemneina@gmail.com>
> >>>>> wrote:
> >>>>>>
> >>>>>>> Does the xensource log say anything informative when trying
to add
> >> the
> >>>>>>> host? I'd be interested in seeing what gets spewed there
after
> tying
> >> to
> >>>>>>> join it to the pool.
> >>>>>>>
> >>>>>>> Ahmad
> >>>>>>>
> >>>>>>> On Mar 26, 2013, at 8:30 AM, Kirk Jantzer <kirk.jantzer@gmail.com>
> >>>>> wrote:
> >>>>>>>
> >>>>>>>> Any more ideas? Haven't been able to add this no matter
what I do.
> >> If
> >>>>> I'm
> >>>>>>>> going to roll CS into production, re-adding a rebuilt
host should
> be
> >>>>>>>> trivial.
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> On Fri, Mar 22, 2013 at 2:48 PM, Warren Nicholson <
> >>>>>>>> warren.nicholson@nfinausa.com> wrote:
> >>>>>>>>
> >>>>>>>>> There are good articles for xe pif setup (including
the
> CloudStack
> >>>>> admin
> >>>>>>>>> guide).
> >>>>>>>>>
> >>>>>>>>> I've also noticed I had to reboot after setting
up the IP's in
> the
> >>>>>>>>> ifcg-xenbrx files.
> >>>>>>>>>
> >>>>>>>>> I'm sure the network & the bonding should be
similar to the old
> >> unit
> >>>>> to
> >>>>>>>>> reconnect....
> >>>>>>>>>
> >>>>>>>>> Warren
> >>>>>>>>>
> >>>>>>>>> -----Original Message-----
> >>>>>>>>> From: Ahmad Emneina [mailto:aemneina@gmail.com]
> >>>>>>>>> Sent: Friday, March 22, 2013 1:43 PM
> >>>>>>>>> To: Kirk Jantzer
> >>>>>>>>> Cc: Cloudstack users mailing list
> >>>>>>>>> Subject: Re: Unable to add rebuilt xenserver host
> >>>>>>>>>
> >>>>>>>>> there you go, it seems the nics/networks arent programmed
the
> same
> >> as
> >>>>>>> the
> >>>>>>>>> other hosts in the pool. if you clear that up...
add it back
> >> through
> >>>>>>>>> cloudstack.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> On Fri, Mar 22, 2013 at 11:35 AM, Kirk Jantzer
> >>>>>>>>> <kirk.jantzer@gmail.com>wrote:
> >>>>>>>>>
> >>>>>>>>>> I get: "This server's network backend is different
from the
> >>>>> master's"
> >>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>> On Fri, Mar 22, 2013 at 2:30 PM, Jason Davis
<scr512@gmail.com>
> >>>>> wrote:
> >>>>>>>>>>
> >>>>>>>>>>> Yeah had the same thought. Seems that the
cluster master is
> >>>>> balking.
> >>>>>>>>>>> So yeah, try in XenCenter.
> >>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>> On Fri, Mar 22, 2013 at 1:23 PM, Kirk Jantzer
<
> >>>>> kirk.jantzer@gmail.com
> >>>>>>>>>>>> wrote:
> >>>>>>>>>>>
> >>>>>>>>>>>> You mean through Xen Center?
> >>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>> On Fri, Mar 22, 2013 at 2:19 PM, Ahmad
Emneina <
> >>>>> aemneina@gmail.com>
> >>>>>>>>>>> wrote:
> >>>>>>>>>>>>
> >>>>>>>>>>>>> from the log snippet it seems the
host cant join the cluster.
> >> can
> >>>>>>>>>>>>> you
> >>>>>>>>>>> try
> >>>>>>>>>>>>> this out of band from cloudstack,
join pool from the host,
> and
> >>>>>>>>>>>>> see
> >>>>>>>>>>> what
> >>>>>>>>>>>> you
> >>>>>>>>>>>>> get?
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> On Fri, Mar 22, 2013 at 11:10 AM,
Kirk Jantzer <
> >>>>>>>>>>> kirk.jantzer@gmail.com
> >>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>> There's no entry for that host
in host_details :-(
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>> On Fri, Mar 22, 2013 at 1:30
PM, Ahmad Emneina
> >>>>>>>>>>>>>> <aemneina@gmail.com
> >>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>>> have you looked at host_details?
There should still be an
> >> entry
> >>>>>>>>>>>>>>> with
> >>>>>>>>>>>> the
> >>>>>>>>>>>>>>> same host details. I'm not
entirely sure if this is safe,
> but
> >>>>>>>>>>>>>>> you
> >>>>>>>>>>> might
> >>>>>>>>>>>>>>> want to back up your db,
then delete the entries for the
> >>>>>>>>>>>>>>> problem
> >>>>>>>>>>> host
> >>>>>>>>>>>>>>> from
> >>>>>>>>>>>>>>> both the cloud.host and
cloud.host_details tables.
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>> On Fri, Mar 22, 2013 at
9:57 AM, Kirk Jantzer <
> >>>>>>>>>>> kirk.jantzer@gmail.com
> >>>>>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> Anybody?
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> On Thu, Mar 21, 2013
at 8:58 PM, Kirk Jantzer <
> >>>>>>>>>>>> kirk.jantzer@gmail.com
> >>>>>>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>> I deleted the host
from cloud.host, as well as any old
> >>>>>>>>>>>>>>>>> guests in cloud.vm_instance
that had that host as
> >>>>>>>>> last_host_id.
> >>>>>>>>>>>>>>>>> On Mar 21, 2013
8:53 PM, "Jason Davis" <scr512@gmail.com
> >
> >>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>> Not in front
of my workstation but I bet the UUID in the
> >>>>>>>>>>>> cloud.host
> >>>>>>>>>>>>>>>>>> portion
> >>>>>>>>>>>>>>>>>> of the DB still
exists even if it is marked "removed".
> >>>>>>>>>>>>>>>>>> Easy
> >>>>>>>>>>> way to
> >>>>>>>>>>>>>>> fix
> >>>>>>>>>>>>>>>>>> this
> >>>>>>>>>>>>>>>>>> is to slightly
change that UUID.
> >>>>>>>>>>>>>>>>>> On Mar 21, 2013
2:34 PM, "Kirk Jantzer" <
> >>>>>>>>>>> kirk.jantzer@gmail.com>
> >>>>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>> Background:
I evicted a host from my cluster to do some
> >>>>>>>>>>> testing
> >>>>>>>>>>>>>>> with
> >>>>>>>>>>>>>>>>>> some
> >>>>>>>>>>>>>>>>>>> other opensource
products. When I was done, I
> >>>>>>>>>>>>>>>>>>> reinstalled
XS
> >>>>>>>>>>> as
> >>>>>>>>>>>> I
> >>>>>>>>>>>>>>> did
> >>>>>>>>>>>>>>>> to
> >>>>>>>>>>>>>>>>>>> all the
other hosts, however I am unable to add the
> host
> >>>>>>>>>>> back to
> >>>>>>>>>>>>>>> the
> >>>>>>>>>>>>>>>>>>> cluster.
I did find a post about duplicate entries in
> >>>>>>>>>>>>>>>>>>> the db,
> >>>>>>>>>>>> so I
> >>>>>>>>>>>>>>>>>> deleted
> >>>>>>>>>>>>>>>>>>> the entry,
but am still unable to add it. Thoughts?
> >>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>> CS 4.0.1
> >>>>>>>>>>>>>>>>>>> XenServer
6.0.2
> >>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>> Output of
> >> /var/log/cloud/management/management-server.log:
> >>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:11,989 DEBUG [cloud.api.ApiServlet]
> >>>>>>>>>>>>>>>> (http-8080-3:null)
> >>>>>>>>>>>>>>>>>>> ===START===
 <client_ipaddress> -- GET
> >>>>> command=addHost&zoneid=7551e0e8-5c64-4955-b368-cf497bd9fd16&podid=811
> >>>>> 51bfa-d519-4b1d-92ca-df7ce424460c&clusterid=9ec5ca37-df78-4910-b09f-d
> >>>>> 9be3bed2269&hypervisor=XenServer&clustertype=CloudManaged&hosttags=&u
> >>>>> sername=root&url=http%3A%2F%2F<host_name>&response=json&sessionkey=LP
> >>>>>>>>>>> R4A%2FAuwEtdUbF%2BdvSyLpg7rnA%3D&_=1363893870935
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:12,001 INFO
> >>>>>>>>>>>> [cloud.resource.ResourceManagerImpl]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Trying to add a new host at http://
> >>>>>>>>>>>> <host_name>
> >>>>>>>>>>>>>>> in
> >>>>>>>>>>>>>>>>>> data
> >>>>>>>>>>>>>>>>>>> center 1
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:12,059 DEBUG
> >>>>>>>>>>>>>>> [xen.resource.XenServerConnectionPool]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Slave logon to <host_ipaddress>
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:12,076 DEBUG
> >>>>>>>>>>>>>>> [xen.resource.XenServerConnectionPool]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Logging on as the master to
> >>>>>>>>>>> <host_ipaddress>
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,006 WARN
> >>>>>>>>>>>>>>> [xen.resource.XenServerConnectionPool]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Catch
> >>>>>>>>>>>>>>>> com.xensource.xenapi.Types$OperationNotAllowed
> >>>>>>>>>>>>>>>>>>> Unable to
allow host <host_ipaddress> to join pool
> >>>>>>>>>>>>>>> <master_ipaddress>
> >>>>>>>>>>>>>>>>>> due
> >>>>>>>>>>>>>>>>>>> to You attempted
an operation that was not allowed.
> >>>>>>>>>>>>>>>>>>> You attempted
an operation that was not allowed.
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.xensource.xenapi.Types.checkResponse(Types.java:1572)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> >> com.xensource.xenapi.Connection.dispatch(Connection.java:368)
> >>>>>>>>>>>>>>>>>>>     at com.xensource.xenapi.Pool.join(Pool.java:1054)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.hypervisor.xen.resource.XenServerConnectionPool.join(XenSer
> >>>>>>>>>>> verConnectionPool.java:785)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.hypervisor.xen.resource.XenServerConnectionPool.joinPool(Xe
> >>>>>>>>>>> nServerConnectionPool.java:159)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.addHostsToPoo
> >>>>>>>>>>> l(XcpServerDiscoverer.java:407)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.find(XcpServe
> >>>>>>>>>>> rDiscoverer.java:207)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceMana
> >>>>>>>>>>> gerImpl.java:687)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerI
> >>>>>>>>>>> mpl.java:544)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>>>
> com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:
> >>>>>>>>>>>>>>>>>> 140)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>> com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> >>>>>>>>>>> icationFilterChain.java:290)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> >>>>>>>>>>> ilterChain.java:206)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
> >>>>>>>>>>> alve.java:233)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
> >>>>>>>>>>> alve.java:191)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
> >>>>>>>>>>> ava:127)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
> >>>>>>>>>>> ava:102)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:
> >>>>>>>>>>> 555)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
> >>>>>>>>>>> ve.java:109)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
> >>>>>>>>>>> a:298)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
> >>>>>>>>>>> :857)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
> >>>>>>>>>>> ss(Http11Protocol.java:588)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:
> >>>>>>>>>>>> 489)
> >>>>>>>>>>>>>>>>>>>     at java.lang.Thread.run(Thread.java:679)
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,007 DEBUG
> >>>>>>>>>>>>>>> [xen.resource.XenServerConnectionPool]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Host(<host_ipaddress>) unable to
> Join
> >>>>>>>>>>>>>>>>>>> the
> >>>>>>>>>>>> pool
> >>>>>>>>>>>>>>> at
> >>>>>>>>>>>>>>>>>>> <master_ipaddress>
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,007 WARN
> >>>>>>>>>>>> [xen.discoverer.XcpServerDiscoverer]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Unable to join the pool
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,007 DEBUG
> >>>>>>>>>>>> [xen.discoverer.XcpServerDiscoverer]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
other exceptions:
> >>>>>>>>>>>>>>>>>>> com.cloud.exception.DiscoveryException:
Unable to join
> >>>>>>>>>>>>>>>>>>> the
> >>>>>>>>>>> pool
> >>>>>>>>>>>>>>>>>>> com.cloud.exception.DiscoveryException:
Unable to join
> >>>>>>>>>>>>>>>>>>> the
> >>>>>>>>>>> pool
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.addHostsToPoo
> >>>>>>>>>>> l(XcpServerDiscoverer.java:409)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.find(XcpServe
> >>>>>>>>>>> rDiscoverer.java:207)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceMana
> >>>>>>>>>>> gerImpl.java:687)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerI
> >>>>>>>>>>> mpl.java:544)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>>>
> com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:
> >>>>>>>>>>>>>>>>>> 140)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>> com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> >>>>>>>>>>> icationFilterChain.java:290)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> >>>>>>>>>>> ilterChain.java:206)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
> >>>>>>>>>>> alve.java:233)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
> >>>>>>>>>>> alve.java:191)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
> >>>>>>>>>>> ava:127)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
> >>>>>>>>>>> ava:102)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:
> >>>>>>>>>>> 555)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
> >>>>>>>>>>> ve.java:109)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
> >>>>>>>>>>> a:298)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
> >>>>>>>>>>> :857)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
> >>>>>>>>>>> ss(Http11Protocol.java:588)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:
> >>>>>>>>>>>> 489)
> >>>>>>>>>>>>>>>>>>>     at java.lang.Thread.run(Thread.java:679)
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,008 WARN
> >>>>>>>>>>>> [cloud.resource.ResourceManagerImpl]
> >>>>>>>>>>>>>>>>>>> (http-8080-3:null)
Unable to find the server resources
> >>>>>>>>>>>>>>>>>>> at
> >>>>>>>>>>>> http://
> >>>>>>>>>>>>>>>>>>> <host_name>
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,008 WARN  [api.commands.AddHostCmd]
> >>>>>>>>>>>>>>>>>> (http-8080-3:null)
> >>>>>>>>>>>>>>>>>>> Exception:
> >>>>>>>>>>>>>>>>>>> com.cloud.exception.DiscoveryException:
Unable to add
> >>>>>>>>>>>>>>>>>>> the
> >>>>>>>>>>> host
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceMana
> >>>>>>>>>>> gerImpl.java:737)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerI
> >>>>>>>>>>> mpl.java:544)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>>>
> com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:
> >>>>>>>>>>>>>>>>>> 140)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>> com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>> com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>>>>>>>>>>>>>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> >>>>>>>>>>> icationFilterChain.java:290)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> >>>>>>>>>>> ilterChain.java:206)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
> >>>>>>>>>>> alve.java:233)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
> >>>>>>>>>>> alve.java:191)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
> >>>>>>>>>>> ava:127)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
> >>>>>>>>>>> ava:102)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:
> >>>>>>>>>>> 555)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
> >>>>>>>>>>> ve.java:109)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
> >>>>>>>>>>> a:298)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
> >>>>>>>>>>> :857)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
> >>>>>>>>>>> ss(Http11Protocol.java:588)
> >>>>>>>>>>>>>>>>>>>     at
> >>>>> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:
> >>>>>>>>>>>> 489)
> >>>>>>>>>>>>>>>>>>>     at java.lang.Thread.run(Thread.java:679)
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,008 WARN  [cloud.api.ApiDispatcher]
> >>>>>>>>>>>>>>>>>> (http-8080-3:null)
> >>>>>>>>>>>>>>>>>>> class com.cloud.api.ServerApiException
: Unable to add
> >>>>>>>>>>>>>>>>>>> the
> >>>>>>>>>>> host
> >>>>>>>>>>>>>>>>>>> 2013-03-21
15:23:13,009 DEBUG [cloud.api.ApiServlet]
> >>>>>>>>>>>>>>>> (http-8080-3:null)
> >>>>>>>>>>>>>>>>>>> ===END===
 <client_ipaddress> -- GET
> >>>>> command=addHost&zoneid=7551e0e8-5c64-4955-b368-cf497bd9fd16&podid=811
> >>>>> 51bfa-d519-4b1d-92ca-df7ce424460c&clusterid=9ec5ca37-df78-4910-b09f-d
> >>>>> 9be3bed2269&hypervisor=XenServer&clustertype=CloudManaged&hosttags=&u
> >>>>> sername=root&url=http%3A%2F%2F<host_name>&response=json&sessionkey=LP
> >>>>>>>>>>> R4A%2FAuwEtdUbF%2BdvSyLpg7rnA%3D&_=1363893870935
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> --
> >>>>>>>>>>>>>>>> Regards,
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> Kirk Jantzer
> >>>>>>>>>>>>>>>> c: (678) 561-5475
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>> --
> >>>>>>>>>>>>>> Regards,
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>> Kirk Jantzer
> >>>>>>>>>>>>>> c: (678) 561-5475
> >>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>> --
> >>>>>>>>>>>> Regards,
> >>>>>>>>>>>>
> >>>>>>>>>>>> Kirk Jantzer
> >>>>>>>>>>>> c: (678) 561-5475
> >>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>> --
> >>>>>>>>>> Regards,
> >>>>>>>>>>
> >>>>>>>>>> Kirk Jantzer
> >>>>>>>>>> c: (678) 561-5475
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> --
> >>>>>>>> Regards,
> >>>>>>>>
> >>>>>>>> Kirk Jantzer
> >>>>>>>> c: (678) 561-5475
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> --
> >>>>>> Regards,
> >>>>>>
> >>>>>> Kirk Jantzer
> >>>>>> c: (678) 561-5475
> >>>>
> >>>>
> >>>>
> >>>> --
> >>>> Regards,
> >>>>
> >>>> Kirk Jantzer
> >>>> c: (678) 561-5475
> >>>
> >>>
> >>>
> >>> --
> >>> Regards,
> >>>
> >>> Kirk Jantzer
> >>> c: (678) 561-5475
> >>
> >
> >
> >
> > --
> > Regards,
> >
> > Kirk Jantzer
> > c: (678) 561-5475
>



-- 
Regards,

Kirk Jantzer
c: (678) 561-5475

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message