cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Vandenberghe <Sebastien.Vandenber...@asg.com>
Subject RE: Join domain fails from 2008R2 VM in basic networking
Date Sat, 02 Mar 2013 11:52:25 GMT
Hello Kirk,

The DNS configuration is the virtual Router and I added in DNS2 the DC.

I can ping the DS and nslookup returns the good IP for the domain I try to join. I have no
security group at all. The error message from windows when I try to join the domain is:
The error was: "No records found for given DNS query."
(error code 0x0000251D DNS_INFO_NO_RECORDS)

The query was for the SRV record for _ldap._tcp.dc._msdcs.cloud.poc

Other machines (not VM in cloudstack) can successfully join the domain.

I definitely think to a virtual router issue. Is there something else I can test?

Thank you,
Best Regards,

-----Original Message-----
From: Kirk Kosinski [mailto:kirkkosinski@gmail.com] 
Sent: samedi 2 mars 2013 02:44
To: cloudstack-users@incubator.apache.org
Subject: Re: Join domain fails from 2008R2 VM in basic networking

Hi, Sebastien.  Does the 2008 R2 VM actually have the correct DNS configuration (the DC)?
 CloudStack might not be assigning the DC as the DNS server for some reason.  If the DNS configuration
is correct on the VM, check if any DNS query works, and check other connectivity (ping, etc.).
 If the zone has security groups enabled, make sure there are no rules blocking access to
the DC.

Best regards,
Kirk


On 03/01/2013 02:46 PM, Sebastien Vandenberghe wrote:
> Hello,
> 
> My test environment (4.0) is in basic network mode and I have one 
> 2008R2 VM running. Aside from Cloudstack, I have one AD+DC+DNS(no 
> dhcp) that I configure as my zone DNS. If I try to enter my 2008R2 VM 
> to this DC Domain, it fails saying it could not find the domain.
> 
> From the 2008R2 I can ping the ADDC server but not the domain name.
> Nslookup fails and indicates the ip of the Virtual Router. I thought 
> when Virtual Router resolution fails it should use the zone DNS. (It 
> also fails with the flag use external dns active after Management 
> Server and Virtual Router reboot)
> 
> Is there any way to make this work or do I have to go to Advance 
> Networking?
> 
> Best Regards,
> Sebastien Vandenberghe
> 

Mime
View raw message