cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <aemne...@gmail.com>
Subject Re: unable to add host
Date Sun, 31 Mar 2013 18:47:04 GMT
Can you add more logs, we'll need more to troubleshoot. Also, can you post it to paste.cloudstack.org

Ahmad

On Mar 31, 2013, at 10:40 AM, Richard S <solid.snake25@gmail.com> wrote:

> I found this in the log
> 
> com.cloud.exception.DiscoveryException: Unable to add the host
>        at
> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:737)
>        at
> com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:544)
>        at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:140)
>        at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
>        at com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
>        at com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
>        at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
>        at com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
>        at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
>        at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>        at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
>        at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
>        at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
>        at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
>        at
> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
>        at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
>        at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
>        at
> org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
>        at
> org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:721)
>        at
> org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2274)
>        at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
>        at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
>        at java.lang.Thread.run(Thread.java:679)
> 2013-03-31 18:43:04,946 WARN  [cloud.api.ApiDispatcher]
> (catalina-exec-11:null) class com.cloud.api.ServerApiException : Unable to
> add the host
> 2013-03-31 18:43:04,947 DEBUG [cloud.api.ApiServlet]
> (catalina-exec-11:null) ===END===  151.230.16.29 -- GET
> command=addHost&zoneid=9b26870a-e224-4e75-b587-dde43e1c1fc6&podid=de1b160e-6542-4c5d-a9b8-f9f4b5912da8&cluster$
> 2013-03-31 18:43:30,394 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (consoleproxy-1:null) Skip capacity scan due to there is no Primary Storage
> UPintenance mode
> 2013-03-31 18:43:31,079 DEBUG [storage.snapshot.SnapshotSchedulerImpl]
> (SnapshotPollTask:null) Snapshot scheduler.poll is being called at
> 2013-03-31 17:43:31 GMT
> 2013-03-31 18:43:31,081 DEBUG [storage.snapshot.SnapshotSchedulerImpl]
> (SnapshotPollTask:null) Got 0 snapshots to be executed at 2013-03-31
> 17:43:31 GMT
> 2013-03-31 18:43:31,124 DEBUG
> [cloud.network.ExternalLoadBalancerUsageManagerImpl]
> (ExternalNetworkMonitor-1:null) External load balancer devices stats
> collector is running...
> 2013-03-31 18:43:31,204 INFO  [cloud.ha.HighAvailabilityManagerImpl]
> (HA-3:null) checking health of usage server
> 2013-03-31 18:43:31,206 DEBUG [cloud.ha.HighAvailabilityManagerImpl]
> (HA-3:null) usage server running? false, heartbeat: null
> 2013-03-31 18:43:31,210 DEBUG [cloud.alert.AlertManagerImpl] (HA-3:null)
> Have already sent: 1 emails for alert type '12' -- skipping send email
> 2013-03-31 18:43:31,211 DEBUG
> [network.router.VirtualNetworkApplianceManagerImpl] (RouterMonitor-1:null)
> Found 0 running routers.
> 2013-03-31 18:43:31,221 DEBUG
> [network.router.VirtualNetworkApplianceManagerImpl]
> (RouterStatusMonitor-1:null) Found 0 routers.
> 2013-03-31 18:43:44,721 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) VmStatsCollector is running...
> 2013-03-31 18:43:44,721 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-3:null) HostStatsCollector is running...
> 2013-03-31 18:43:44,770 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) StorageCollector is running...
> 
> 
> what could be the problem when I try to add the Xenserver host? I use to be
> able to do it on Cloudstack 3
> 
> 
> 
> On Sun, Mar 31, 2013 at 6:18 PM, Pranav Saxena <pranav.saxena@citrix.com>wrote:
> 
>> Check the management server log in your cloudstack repo . It will list you
>> the entire stacktrace of where the exception occurred and due to what
>> reason.  In case there's a problem with your host then you got to check the
>> xensource.log file in your xenserver host.
>> 
>> Thanks,
>> Pranav
>> -----Original Message-----
>> From: Richard S [mailto:solid.snake25@gmail.com]
>> Sent: Sunday, March 31, 2013 10:34 PM
>> To: users@cloudstack.apache.org
>> Subject: unable to add host
>> 
>> I'm running Xenserver 6.0 with Cloudstack 4.0.1. when I try to add the
>> Xenserver as s host I get "unable to add host". I can't find which log to
>> check to see what the problem is.
>> 

Mime
View raw message