cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject Re: secondary SR mount with XS 6.1
Date Fri, 08 Mar 2013 15:03:28 GMT

On Mar 8, 2013, at 9:58 AM, Kirk Jantzer <kirk.jantzer@gmail.com> wrote:

> You got farther than me :-) What was the hack you used?

let me check that everything works before I send you this $1M 3 liner :)

> 
> 
> On Fri, Mar 8, 2013 at 9:09 AM, Sebastien Goasguen <runseb@gmail.com> wrote:
> 
>> 
>> On Mar 8, 2013, at 9:01 AM, Kirk Jantzer <kirk.jantzer@gmail.com> wrote:
>> 
>>> Xenserver 6.1 is not approved for use with CS 4. You will need to use
>>> Xenserver 6.0.1
>>> 
>> 
>> I put a small hack so that 6.1 hosts would be added properly.
>> 
>>> 
>>> On Fri, Mar 8, 2013 at 8:38 AM, Sebastien Goasguen <runseb@gmail.com>
>> wrote:
>>> 
>>>> Hi,
>>>> 
>>>> I am setting up a small testbed with two XS 6.1 and ACS 4.0.1
>>>> I used NFS for both primary and secondary.
>>>> 
>>>> I can see the mounts on both hosts:
>>>> 
>>>> 192.168.56.10:/export/secondary
>>>>                      4127488   1954176   1963648  50%
>>>> /var/run/sr-mount/79ecd03c-df82-1552-8d9f-a8a330a57265
>>>> 192.168.56.10:/export/primary
>>>>                      4127488   1954176   1963648  50%
>>>> /var/run/sr-mount/ace6014e-0c78-42b0-fdae-fbd8ce57c4c8
>>>> 
>>>> I created the infra and everything is green. But the systemVMs don't
>> start
>>>> (surprise, surprise).
>>>> 
>>>> I get this error in ant debug:
>>>> 
>>>> [java] WARN  [xen.resource.CitrixResourceBase] (DirectAgent-81:)
>>>> destoryVDIbyNameLabel failed due to there are 0 VDIs with name
>>>> cloud-60ba706e-d5e3-4dea-925b-a0271802a2f9
>>>>    [java] WARN  [xen.resource.CitrixResourceBase] (DirectAgent-81:)
>>>> can't mount 192.168.56.10:/export/secondary/template/tmpl/1/1 to
>>>> /var/run/cloud_mount/a44be157-ac4b-459d-a069-c838f63f1dd1
>>>>    [java] WARN  [xen.resource.CitrixResourceBase] (DirectAgent-81:)
>>>> Catch Exception com.cloud.utils.exception.CloudRuntimeException on
>>>> host:dcd30867-47ed-4d20-9541-403a878c40a6 for template: nfs://
>>>> 192.168.56.10/export/secondary/template/tmpl/1/1/ due to
>>>> com.cloud.utils.exception.CloudRuntimeException: can't mount
>> 192.168.56.10:/export/secondary/template/tmpl/1/1
>>>> to /var/run/cloud_mount/a44be157-ac4b-459d-a069-c838f63f1dd1
>>>>    [java] com.cloud.utils.exception.CloudRuntimeException: can't mount
>>>> 192.168.56.10:/export/secondary/template/tmpl/1/1 to
>>>> /var/run/cloud_mount/a44be157-ac4b-459d-a069-c838f63f1dd1
>>>>    [java]     at
>>>> 
>> com.cloud.hypervisor.xen.resource.CitrixResourceBase.copy_vhd_from_secondarystorage(CitrixResourceBase.java:2672)
>>>>    [java]     at
>>>> 
>> com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:2694)
>>>>    [java]     at
>>>> 
>> com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:481)
>>>>    [java]     at
>>>> 
>> com.cloud.hypervisor.xen.resource.XenServer56Resource.executeRequest(XenServer56Resource.java:73)
>>>>    [java]     at
>>>> 
>> com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:191)
>>>>    [java]     at
>>>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
>>>>    [java]     at
>>>> java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
>>>>    [java]     at
>> java.util.concurrent.FutureTask.run(FutureTask.java:166)
>>>>    [java]     at
>>>> 
>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)
>>>>    [java]     at
>>>> 
>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)
>>>>    [java]     at
>>>> 
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
>>>>    [java]     at
>>>> 
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
>>>>    [java]     at java.lang.Thread.run(Thread.java:722)
>>>> 
>>>> 
>>>> I don't have a /var/run/cloud_mount on the hosts only a
>> /var/run/sr-mount
>>>> 
>>>> thoughts ?
>>>> 
>>>> -sebastien
>>> 
>>> 
>>> 
>>> 
>>> --
>>> Regards,
>>> 
>>> Kirk Jantzer
>>> c: (678) 561-5475
>> 
>> 
> 
> 
> -- 
> Regards,
> 
> Kirk Jantzer
> c: (678) 561-5475


Mime
View raw message