cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos ReƔtegui <create...@gmail.com>
Subject Re: Recommendations for a private cloud
Date Wed, 06 Mar 2013 08:44:22 GMT

On Mar 4, 2013, at 2:20 AM, Sebastien Goasguen <runseb@gmail.com> wrote:

> 
> On Feb 26, 2013, at 7:07 PM, Carlos Reategui <carlos@reategui.com> wrote:
> 
>> Sorry for the delay in getting back to you.  I was traveling and not able
>> to work on this.
>> 
>> I have added the NFS SR to my host.  I was also able to create a VM and got
>> decent performance to the NFS based storage (90MB/s).  I did all this using
>> xe command line so I believe at the very least Xen and xapi are working on
>> this host with my primary storage.
>> 
>> Unfortunately I did not have the same amount of luck with Cloudstack.  I
>> first tried using the setup wizard but the primary storage options do not
>> include "PreSetup"
> 
> You should have seen PreSetup.
> In the mgt server UI, if you go under infrastructure and add a zone, the UI will walk
you through the entire setup.
> If you click on primary storage you can add one and it should allow you to use PreSetup
(just use the drop down).
I only saw PreSetup in the non wizard mode.
> 
>> option so I went back and did the manual setup of the
>> Zone.  Everything seemed to go ok (after I added the .ssh dir in root's
>> home dir) but it now seems like the system VMs are not starting up
>> properly.
> 
> Any logs ?
I am stuck at the same place you were in your "How to get hosts out of 'avoid' state" thread.

Strange thing is that from the UI perspective it looks like the host is up, but it is only
in the logs that it says that the host is in the avoid state.

How does one get 4.0.2 which apparently fixes this?  Do I need to build from source? I am
currently using the ppa to install on ubuntu 12.04.  Do you know if that will get updated
to 4.0.2 any time soon?

> 
>> I have not tried creating an instance of my own yet (need to
>> read up on creating an ubuntu precise template first).  I'll try to debug
>> some more and will follow-up in a separate thread.
>> 
>> -Carlos
>> 
>> 
>> 
>> On Fri, Feb 22, 2013 at 2:57 AM, Sebastien Goasguen <runseb@gmail.com>wrote:
>> 
>>> 
>>> On Feb 13, 2013, at 2:51 AM, Carlos Reategui <carlos@reategui.com> wrote:
>>> 
>>>> Thanks for the pointers.
>>>> 
>>>> On Tue, Feb 12, 2013 at 1:29 AM, Sebastien Goasguen <runseb@gmail.com
>>>> wrote:
>>>> 
>>>>> 
>>>>> On Feb 10, 2013, at 8:43 AM, Carlos Reategui <carlos@reategui.com>
>>> wrote:
>>>>> 
>>>>>> Hi All, new to CloudStack and have many questions.  I am looking
to
>>>>>> implement a private cloud for our engineering and qa teams to play
>>> around
>>>>>> and be able to launch test clusters prior to doing so in the cloud
>>> (AWS).
>>>>>> I started messing around with the CloudStack installation (3.0.2)
and
>>>>>> setting up XCP 1.5  and 1.6 hosts and was a bit confused by the
>>>>> networking
>>>>>> setup (this is all internal, the VMs won't have a public interface).
 I
>>>>> am
>>>>>> now in the process of starting over.  This time with the incubating
>>>>> release
>>>>>> (4.0.0) and was hoping to use Ubuntu 12.04 + xapi (aka Kronos) as
it
>>>>>> provides better support for my network hardware (BCM quad 1Gbe) --
I
>>> had
>>>>> to
>>>>>> jump through hoops to get XCP 1.5 to work and 1.6 did not work with
CS
>>>>>> 3.0.2.
>>>>>> 
>>>>> 
>>>>> Hi Carlos,
>>>>> 
>>>>> I would use the 4.0.1 release.
>>>>> 
>>>> 
>>>> I'll give that a try.
>>>> 
>>>> For Ubuntu, Gerry Havinga just posted a script that helps with the
>>>>> installation, you might want to check it out:
>>>>> 
>>>>> 
>>> http://opensourcetutorials.blogspot.nl/2013/02/adding-ubuntu-1204-kvm-host-to.html
>>>> 
>>>> 
>>>> I notice his script installs cloud-agent and cloud-system-iso, do I need
>>>> those as well for xapi on ubuntu?  Or are those for KVM only.  In looking
>>>> at the install docs, I don't see them mentioned in the Xenserver section.
>>> 
>>> Carlos, sorry for the delay.
>>> 
>>> If you use Xen on ubuntu. CS will use xapi. You don't need to install the
>>> cloud-agent.
>>> 
>>> The issue of needing cloud-system-iso has been fixed in 4.0.1 but this is
>>> only needed for KVM.
>>> 
>>> I will try to add some docs in the coming weeks.
>>> 
>>>> 
>>>> 
>>>>> 
>>>>> As far as networking, the first decision will be to decide whether you
>>> are
>>>>> going to use VLANs or not. If you don't use VLANs, you will setup a
>>> "basic"
>>>>> zone, if you can do VLANs you might want to setup an "advanced" zone.
>>>>> 
>>>> 
>>>> I don't know much about VLANs so I was going to stick with a basic zone.
>>>> Especially since I don't have a need for a public network.
>>>> 
>>>> 
>>>>> Shapeblue has some blogs that are very useful in addition to reading
the
>>>>> documentation:
>>>>> 
>>>>> 
>>> http://www.shapeblue.com/2013/01/07/understanding-cloudstacks-physical-networking-architecture/
>>>>> 
>>> http://www.shapeblue.com/2012/05/01/cloudstack-networking-considerations/
>>>>> and:
>>>>> 
>>>>> 
>>> http://www.shapeblue.com/2012/05/10/using-the-api-for-advanced-network-management/
>>>> 
>>>> 
>>>> Thanks for these, somehow had not run across them in my google searches.
>>>> Although now I am confused about the "storage" network as he explains
>>> that
>>>> is for secondary storage.  In my setup I was going to start with the
>>>> management node also being the NFS storage for both primary and
>>> secondary.
>>>> It has a 2 10Gbe and 2 1Gbe ports. I have the 10Gbe ports going to a
>>>> switch (dell 6224) that is physically isolated from the the rest of the
>>>> network and was planning on only having NFS traffic on that.  Should I
>>> also
>>>> configure that to be my "management" network?
>>> 
>>> I am not an authority on this. But I believe that you could define a
>>> storage network as long as the hosts can access it.
>>> If you don't define a storage network the storage traffic will go over the
>>> management network.
>>> 
>>>> 
>>>> Anyhow I have made some progress with 4.0 but got stuck not being able to
>>>> add a host, which I am pretty sure has to do with my host network
>>>> settings/labels.  Also the management server seems to think my "storage"
>>> ip
>>>> (172.30.19.10) is the management network (there is an alarm saying the
>>>> management server node is up on that ip).  How do I change that?
>>>> Also I see a couple other alarms: "management network CIDR is not
>>>> configured originally. set it default to 172.30.45.0/24" and "no usage
>>>> server process running".  Should I worry about that.
>>>> 
>>>> I have updated to 4.0.1 and will try to figure out my host network as "xe
>>>> network-list" does not seem to match what I have actually configured.
>>> 
>>> Give us an update on this, as your email was 10 days ago, you may have
>>> made progress.
>>> 
>>>> 
>>>>> 
>>>>> 
>>>>> -Sebastien
>>>>> 
>>>>> 
>>>>>> Has anyone had any success with 12.04 + xapi for the nodes?  The
script
>>>>> to
>>>>>> add nodes seems to know about Kronos.  If this won't work is there
a
>>>>>> preferred Xen host with somewhat up to date drivers (for a Dell R620
>>> with
>>>>>> BCM 5720 Quad)?
>>>>>> 
>>>>>> Regarding the network setup, what is the recommended setup with 4
1Gbe
>>>>>> ports?  I already have a separate storage network (NFS server has
a
>>> 10Gbe
>>>>>> link) so I was thinking of bonding 2 ports for storage and 2 for
>>>>>> management/VM traffic.  Does this make sense to bond the second pair?
>>>>> Do I
>>>>>> need separate subnets for management and vm network or are different
>>>>> ranges
>>>>>> within the same subnet enough (security is not a concern in my
>>>>> deployment).
>>>>>> Currently, corporate IS is providing me a subnet with DHCP.  Is that
>>>>> going
>>>>>> to be a problem for CS?
>>>>>> 
>>>>>> I do have the option of adding another dual or quad port card.  If
I
>>> do,
>>>>>> what would the recommended setup be?  The nodes have 2x8core CPU
with
>>>>> 64GB
>>>>>> RAM.
>>>>>> 
>>>>>> I definitely appreciate any pointers to help me off the ground.
>>>>>> 
>>>>>> thank you,
>>>>>> Carlos
>>>>> 
>>>>> 
>>> 
>>> 
> 


Mime
View raw message