cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Smith <christopher.sm...@infotechfl.com>
Subject Re: Problem installing VMware Cluster in CloudStack 4.0.1
Date Thu, 21 Mar 2013 18:01:43 GMT
We are using distributed switches.

They are named "10GB", "Management", and "vmNetworks".

Our portgroup names are:

10GB -
     -dvSwitch1 (Uplink Port Group)
     -Storage (Distributed port group)
     -vMotion (Distributed port group)

Management -
     -dvSwitch3
     -management

vmNetworks -
     -dvSwitch4
     -dvPortGroup2
     -dvPortGroup3
     -dvPortGroup4

Also, the page at "https://<vSphere_IP>/Datacenter_Name/Cluster" is 
blank. Any ideas? What sort of data is it looking for there?

Thanks!

On 3/21/2013 1:13 PM, Musayev, Ilya wrote:
> Unable to find vSwitchvSwitch0
>
> What is your vswitch naming like and what portgroup names do you use for management?
>
> You can override the vswitch settings in physical network tab when you define Guest,
Public, Management and Storage Traffic Types.
>
> If you also use a different portgroup name for management network - that is - its not
equal to "Management Network", you can alter this name in Global Settings, just define vmware
on top filter and you should see it.
>
> Regards
> ilya
>
>> -----Original Message-----
>> From: Chris Smith [mailto:christopher.smith@infotechfl.com]
>> Sent: Thursday, March 21, 2013 12:57 PM
>> To: users@cloudstack.apache.org
>> Subject: Re: Problem installing VMware Cluster in CloudStack 4.0.1
>>
>> A follow up, here is the debug message:
>>
>> --BEGIN--
>>
>> 2013-03-21 12:43:09,112 DEBUG [cloud.api.ApiServlet]
>> (catalina-exec-18:null) ===START===  DesktopIP -- GET
>> command=addCluster&zoneId=0aa9a9d5-d2f0-4e51-9d43-
>> 12924b85b1f6&hypervisor=VMware&clustertype=ExternalManaged&podId=
>> 0df5135c-2bb8-4ad8-9c70-
>> 1d03f287633e&username=<username>&url=http%3A%2F%2F<vSphere_IP>
>> %2FDatacenterName%2FDatacenterName&DatacenterName=<vSphere_IP>
>> %2FDatacenterName%2FDatacenterName&response=json&sessionkey=oM
>> f%2FP%2BPT%2B6sjaNrezrVfONyGwlI%3D&_=1363884123876
>> 2013-03-21 12:43:09,135 INFO
>> [hypervisor.vmware.VmwareServerDiscoverer]
>> (catalina-exec-18:null) Discover host. dc: 1, pod: 2, cluster: 8, uri
>> host: <vSphere_IP>
>> 2013-03-21 12:43:09,139 DEBUG [vmware.resource.VmwareContextFactory]
>> (catalina-exec-18:null) initialize VmwareContext. url:
>> https://<vSphere_IP>/sdk/vimService, username: <username>, password:
>> <password>
>> 2013-03-21 12:43:10,942 INFO  [vmware.manager.VmwareManagerImpl]
>> (catalina-exec-18:null) Calling prepareNetwork :
>> com.cloud.hypervisor.vmware.util.VmwareContext@f520b9e
>> 2013-03-21 12:43:11,069 DEBUG
>> [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
>> Zone
>> 1 is not ready to launch secondary storage VM yet
>> 2013-03-21 12:43:11,172 ERROR [vmware.mo.HypervisorHostHelper]
>> (catalina-exec-18:null) Unable to find vSwitchvSwitch0
>> 2013-03-21 12:43:11,172 WARN
>> [hypervisor.vmware.VmwareServerDiscoverer]
>> (catalina-exec-18:null) Unable to connect to Vmware vSphere server.
>> service address: <vSphere_IP>
>> 2013-03-21 12:43:11,202 DEBUG
>> [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null) Skip
>> capacity scan due to there is no Primary Storage UPintenance mode
>> 2013-03-21 12:43:11,400 WARN  [cloud.resource.ResourceManagerImpl]
>> (catalina-exec-18:null) Unable to find the server resources at
>> http://<vSphere_IP>/DatacenterName/DatacenterName
>> 2013-03-21 12:43:11,419 WARN  [api.commands.AddClusterCmd]
>> (catalina-exec-18:null) Exception:
>> com.cloud.exception.DiscoveryException: Unable to add the external cluster
>>           at
>> com.cloud.resource.ResourceManagerImpl.discoverCluster(ResourceManag
>> erImpl.java:487)
>>           at
>> com.cloud.utils.db.DatabaseCallback.intercept(DatabaseCallback.java:34)
>>           at
>> com.cloud.api.commands.AddClusterCmd.execute(AddClusterCmd.java:153)
>>           at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
>>           at com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
>>           at com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
>>           at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
>>           at com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
>>           at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
>>           at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
>>           at
>> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFi
>> lterChain.java:290)
>>           at
>> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChai
>> n.java:206)
>>           at
>> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
>> alve.java:233)
>>           at
>> org.apache.catalina.core.StandardContextValve.invoke(StandardContextVal
>> ve.java:191)
>>           at
>> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:
>> 127)
>>           at
>> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:1
>> 02)
>>           at
>> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
>>           at
>> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.
>> java:109)
>>           at
>> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:2
>> 98)
>>           at
>> org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.j
>> ava:889)
>>           at
>> org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.pro
>> cess(Http11NioProtocol.java:721)
>>           at
>> org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.j
>> ava:2274)
>>           at
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.jav
>> a:1146)
>>           at
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.ja
>> va:615)
>>           at java.lang.Thread.run(Thread.java:679)
>> 2013-03-21 12:43:11,420 WARN  [cloud.api.ApiDispatcher]
>> (catalina-exec-18:null) class com.cloud.api.ServerApiException : Unable to
>> add the external cluster
>>
>> --END--
>>
>>
>> On 3/21/2013 12:38 PM, Chris Smith wrote:
>>> Hello list,
>>>
>>> I am trying to add a vSphere 5.1.0 cluster. I am presented with the
>>> error:
>>>
>>> "Unable to add the external cluster"
>>>
>>> I don't know where to go from here.
>>>
>>> Thank you!
>>>
>> --
>> Chris
>> Server Administrator I
>> InfoTech, Inc.
>> 5700 SW 34th Street, Suite 1235
>> Gainesville, FL
>> 352-381-4766
>>
>

-- 
Chris
Server Administrator I
InfoTech, Inc.
5700 SW 34th Street, Suite 1235
Gainesville, FL
352-381-4766


Mime
View raw message