cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <aemne...@gmail.com>
Subject Re: VLAN ISSUE ON KVM HOST
Date Mon, 04 Mar 2013 16:55:44 GMT
I believe you need to assign cloudbr0 an IP address and use that for guest public and private
interface. Cloudstack will tag and bridge public and guest traffic accordingly, if you're
using an advanced zone. Give that a try and let us know if you get any further.

Ahmad

On Mar 4, 2013, at 1:52 AM, Valery Fongang <fongang.valery@pertechtual.net> wrote:

> 
> Hi,
> 
> My physical switch is configured with 3 Vlans (vlan1, vlan200 and vlan300) and the host
is on a tagged trunk port. I must admit I am a bit confused on how I have to match this in
the /etc/cloud/agent/agent.properties config file. I have played a little bit around with
it hoping to get it working to no avail. Below is the configuration on my host and the content
of the agent.properties config file. Please let me know how you think my agent.properties
 file needs to be configured. Also note that my Public IPs and IPs on the POD (host and Cloud
Stack Management Server) are all accessible only via vlan1. 
> 
> [root@kvm ~]# ifconfig
> cloud0    Link encap:Ethernet  HWaddr B2:E1:19:7B:B7:B0
>          inet addr:169.254.0.1  Bcast:169.254.255.255  Mask:255.255.0.0
>          inet6 addr: fe80::b0e1:19ff:fe7b:b7b0/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:0 (0.0 b)  TX bytes:468 (468.0 b)
> 
> cloudbr0  Link encap:Ethernet  HWaddr C8:60:00:58:9F:13
>          inet6 addr: fe80::ca60:ff:fe58:9f13/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:0 (0.0 b)  TX bytes:578 (578.0 b)
> 
> cloudbr1  Link encap:Ethernet  HWaddr C8:60:00:58:9F:13
>          inet6 addr: fe80::ca60:ff:fe58:9f13/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:0 (0.0 b)  TX bytes:578 (578.0 b)
> 
> eth0      Link encap:Ethernet  HWaddr C8:60:00:58:9F:13
>          inet6 addr: fe80::ca60:ff:fe58:9f13/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:143358 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:145099 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:1000
>          RX bytes:25198081 (24.0 MiB)  TX bytes:25801567 (24.6 MiB)
>          Interrupt:34
> 
> eth0.1    Link encap:Ethernet  HWaddr C8:60:00:58:9F:13
>          inet addr:10.26.0.143  Bcast:10.26.255.255  Mask:255.255.0.0
>          inet6 addr: fe80::ca60:ff:fe58:9f13/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:138979 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:70589 errors:0 dropped:8 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:22987031 (21.9 MiB)  TX bytes:21894019 (20.8 MiB)
> 
> eth0.200  Link encap:Ethernet  HWaddr C8:60:00:58:9F:13
>          inet6 addr: fe80::ca60:ff:fe58:9f13/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:37251 errors:0 dropped:1 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:0 (0.0 b)  TX bytes:1953440 (1.8 MiB)
> 
> eth0.300  Link encap:Ethernet  HWaddr C8:60:00:58:9F:13
>          inet6 addr: fe80::ca60:ff:fe58:9f13/64 Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:37252 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:0 (0.0 b)  TX bytes:1953530 (1.8 MiB)
> 
> lo        Link encap:Local Loopback
>          inet addr:127.0.0.1  Mask:255.0.0.0
>          inet6 addr: ::1/128 Scope:Host
>          UP LOOPBACK RUNNING  MTU:16436  Metric:1
>          RX packets:62 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:62 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>          RX bytes:6944 (6.7 KiB)  TX bytes:6944 (6.7 KiB)
> 
> virbr0    Link encap:Ethernet  HWaddr 52:54:00:93:DC:18
>          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
> 
> 
> ----------------------------------------------------
> 
> [root@kvm ~]# cat /etc/cloud/agent/agent.properties #Storage #Wed Feb 27 13:54:27 GMT
2013
> guest.network.device=cloudbr0
> workers=5
> private.network.device=eth0.1
> port=8250
> resource=com.cloud.agent.resource.computing.LibvirtComputingResource
> pod=4
> vm.migrate.speed=1000
> zone=4
> guid=8e0e7646-93d0-357d-b44c-e5ec4088fdeb
> cluster=4
> public.network.device=eth0.1
> local.storage.uuid=417c7db1-2249-49e8-949f-3bd681cdc0cd
> domr.scripts.dir=scripts/network/domr/kvm
> LibvirtComputingResource.id=5
> host=10.26.0.90
> 
> -----------------------------------------------------------
> 
> -----Original Message-----
> From: Edison Su [mailto:Edison.su@citrix.com]
> Sent: 27 February 2013 19:15
> To: Cloudstack users; 'aemneina@gmail.com'
> Subject: RE: StoragePool is not of correct type
> 
> The error is creating vlan on your kvm host failed. May need to take a look at your bridge
configuration on kvm host.
> 1. check /etc/cloud/agent/agent.properties,  what's the value of public.network.device?
> 2. Is the bridge name get from above 1st step listed on your kvm host?  "brctl show"
will show you the result.
> 
> 
>> -----Original Message-----
>> From: Valery Fongang [mailto:fongang.valery@pertechtual.net]
>> Sent: Wednesday, February 27, 2013 2:45 AM
>> To: Cloudstack users; 'aemneina@gmail.com'
>> Subject: RE: StoragePool is not of correct type
>> 
>> Hi Ahmad,
>> 
>> Thanks for you great input that got me one step further. I had 
>> system.vm.use.local.storage set to true but use.local.storage was 
>> still on false. After setting the later to true I got pass the 
>> previous error message and I was able to see system VMs could pick up 
>> a public , private and link local IP address. However the state of my 
>> system VMs stays on Starting and goes back to Stopped after a while.
>> Below is the error part of the CMS log. Any Suggestions?...
>> 
>> 
>> 2013-02-27 10:42:41,636 DEBUG [agent.transport.Request] (AgentManager-
>> Handler-6:null) Seq 5-1496055849: Processing:  { Ans: , MgmtId:
>> 16279293006507, via: 5, Ver: v1, Flags: 110,
>> [{"StartAnswer":{"vm":{"id":1423,"name":"v-1423-
>> VM","type":"ConsoleProxy","cpus":1,"speed":500,"minRam":1073741824,"m
>> axRam":1073741824,"arch":"x86_64","os":"Debian GNU/Linux 5.0 (32- 
>> bit)","bootArgs":" template=domP type=consoleproxy host=10.26.0.90
>> port=8250 name=v-1423-VM premium=true zone=4 pod=4 guid=Proxy.1423
>> proxy_vm=1423 disable_rp_filter=true eth2ip=172.18.1.11
>> eth2mask=255.255.0.0 gateway=172.18.1.1 eth0ip=169.254.1.117
>> eth0mask=255.255.0.0 eth1ip=10.26.0.134 eth1mask=255.255.0.0
>> mgmtcidr=10.26.0.0/16 localgw=10.26.0.1 internaldns1=10.26.0.160
>> internaldns2=8.8.8.8 dns1=10.26.0.160
>> dns2=8.8.8.8","rebootOnCrash":false,"enableHA":false,"limitCpuUse":false,"
>> vncPassword":"3d03cc1bad8ede6b","params":{},"disks":[{"id":1423,"name":"
>> ROOT-1423","mountPoint":"/var/lib/libvirt/images/","path":"706fda6a-0d
>> cc-
>> 4ba2-8ff0-
>> 63a5fd0214a5","size":139264,"type":"ROOT","storagePoolType":"Filesystem"
>> ,"storagePoolUuid":"417c7db1-2249-49e8-949f-
>> 3bd681cdc0cd","deviceId":0}],"nics":[{"deviceId":2,"networkRateMbps":-
>> 1,"defaultNic":true,"ip":"172.18.1.11","netmask":"255.255.0.0","gatewa
>> y":"1
>> 72.18.1.1","mac":"06:be:2e:00:00:0d","dns1":"10.26.0.160","dns2":"8.8.8.8","
>> broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://1","isola
>> tionUr
>> i":"vlan://1","isSecurityGroupEnabled":false},{"deviceId":0,"networkRa
>> teMb
>> ps":-
>> 1,"defaultNic":false,"ip":"169.254.1.117","netmask":"255.255.0.0","gateway":
>> "169.254.0.1","mac":"0e:00:a9:fe:01:75","broadcastType":"LinkLocal","type":
>> "Control","isSecurityGroupEnabled":false},{"deviceId":1,"networkRateMb
>> ps
>> ":-
>> 1,"defaultNic":false,"ip":"10.26.0.134","netmask":"255.255.0.0","gatew
>> ay":"1
>> 0.26.0.1","mac":"06:ee:c2:00:00:05","broadcastType":"Native","type":"M
>> ana
>> gement","isSecurityGroupEnabled":false}]},"result":false,"details":"Fa
>> iled to create vnet 1: java.lang.NullPointerException\n\tat
>> java.lang.ProcessBuilder.start(ProcessBuilder.java:457)\n\tat
>> com.cloud.utils.script.Script.execute(Script.java:177)\n\tat
>> com.cloud.utils.script.Script.execute(Script.java:155)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.createVnet
>> (LibvirtComputingResource.java:2112)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.createVlan
>> Br(LibvirtComputingResource.java:2692)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.createVif(
>> Li bvirtComputingResource.java:2726)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.createVif(
>> Li bvirtComputingResource.java:2744)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.createVifs
>> ( LibvirtComputingResource.java:2489)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.execute(Li
>> b virtComputingResource.java:2512)\n\tat
>> com.cloud.agent.resource.computing.LibvirtComputingResource.executeRe
>> quest(LibvirtComputingResource.java:985)\n\tat
>> com.cloud.agent.Agent.processRequest(Agent.java:517)\n\tat
>> com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:827)\n\ta
>> t com.cloud.utils.nio.Task.run(Task.java:79)\n\tat
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.j
>> av
>> a:1146)\n\tat
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
>> ja
>> va:615)\n\tat
>> java.lang.Thread.run(Thread.java:679)\n","wait":0}},{"Answer":{"result
>> ":fals e,"details":"Stopped by previous failure","wait":0}}] }
>> 2013-02-27 10:42:41,636 WARN  [cloud.vm.VirtualMachineManagerImpl]
>> (consoleproxy-1:null) Cleanup failed due to Failed to create vnet 1:
>> java.lang.NullPointerException
>> 2013-02-27 10:42:41,637 WARN  [cloud.vm.VirtualMachineManagerImpl]
>> (consoleproxy-1:null) Cleanup failed due to Stopped by previous 
>> failure
>> 2013-02-27 10:42:41,638 WARN  [cloud.vm.VirtualMachineManagerImpl]
>> (AgentManager-Handler-6:null) Cleanup failed due to Failed to create vnet 1:
>> java.lang.NullPointerException
>> 2013-02-27 10:42:41,639 WARN  [cloud.vm.VirtualMachineManagerImpl]
>> (AgentManager-Handler-6:null) Cleanup failed due to Stopped by 
>> previous failure
>> 2013-02-27 10:42:41,644 INFO  [cloud.vm.VirtualMachineManagerImpl]
>> (consoleproxy-1:null) Unable to start VM on Host[-5-Routing] due to 
>> Failed to create vnet 1: java.lang.NullPointerException [root@cms ~]#
>> 
>> -----Original Message-----
>> From: Ahmad Emneina [mailto:aemneina@gmail.com]
>> Sent: 26 February 2013 19:15
>> To: Cloudstack users
>> Subject: Re: StoragePool is not of correct type
>> 
>> 2013-02-26 17:01:58,147 DEBUG
>> [storage.allocator.AbstractStoragePoolAllocator]
>> (consoleproxy-1:null) Is storage pool shared? true
>> 2013-02-26 17:01:58,147 DEBUG
>> [storage.allocator.AbstractStoragePoolAllocator]
>> (consoleproxy-1:null) StoragePool is not of correct type, skipping 
>> this pool
>> 
>> this might be your issue. are your system vm's set to use local storage?
>> 
>> 
>> On Tue, Feb 26, 2013 at 9:04 AM, Valery Fongang < 
>> fongang.valery@pertechtual.net> wrote:
>> 
>>> Hi all,****
>>> 
>>> ** **
>>> 
>>> I am trying to setup Cloudstack 3.0.2 with KVM hypervisor (on Centos
>>> 3.0)  and I am running into a number of issues. At this time I have 
>>> managed to get up to the following stage:****
>>> 
>>> ** **
>>> 
>>> **-          **Cloud Management Server installed.****
>>> 
>>> **-          **Host installed with KVM.****
>>> 
>>> **-          **Zone-Cluster-Pod-Host-Primary Storage- Secondary all setup
>>> and displaying on Cloudstack dashboard.****
>>> 
>>> **-          **System VM templates are available in Templates but no
>>> Centos Template.****
>>> 
>>> **-          **System VMs were generated but unable to boot.****
>>> 
>>> **-          **My Cloud Management Server Log shows the following:****
>>> 
>>> ** **
>>> 
>>> ** **
>>> 
>>> 2013-02-26 17:01:58,119 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:null) VM state transitted from :Stopped to Starting 
>>> with
>>> event: StartRequestedvm's original host id: null new host id: null 
>>> host id before state transition: null****
>>> 
>>> 2013-02-26 17:01:58,119 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>> (consoleproxy-1:null) Successfully transitioned to start state for 
>>> VM[ConsoleProxy|v-1423-VM] reservation id =
>>> a2d3825d-ffc7-411c-92ec-fc0872247923****
>>> 
>>> 2013-02-26 17:01:58,127 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>> (consoleproxy-1:null) Trying to deploy VM, vm has dcId: 4 and podId:
>>> null*
>>> ***
>>> 
>>> 2013-02-26 17:01:58,128 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>> (consoleproxy-1:null) Deploy avoids pods: null, clusters: null, hosts:
>>> null
>>> ****
>>> 
>>> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) DeploymentPlanner allocation algorithm:
>>> random****
>>> 
>>> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Trying to allocate a host and storage pools 
>>> from dc:4, pod:null,cluster:null, requested cpu: 500, requested ram:
>>> 1073741824
>>> ****
>>> 
>>> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Is ROOT volume READY (pool already allocated)?:
>>> No**
>>> **
>>> 
>>> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Searching all possible resources under this
>>> Zone: 4*
>>> ***
>>> 
>>> 2013-02-26 17:01:58,130 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Listing clusters in order of aggregate 
>>> capacity, that have (atleast one host with) enough CPU and RAM 
>>> capacity under this Zone: 4
>>> ****
>>> 
>>> 2013-02-26 17:01:58,130 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) CPUOverprovisioningFactor considered: 1.0****
>>> 
>>> 2013-02-26 17:01:58,139 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Checking resources in Cluster: 4 under Pod:
>>> 4****
>>> 
>>> 2013-02-26 17:01:58,139 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Calling HostAllocators to find suitable
>>> hosts****
>>> 
>>> 2013-02-26 17:01:58,139 DEBUG [allocator.impl.FirstFitAllocator]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Looking for hosts in dc: 4
>>> pod:4  cluster:4****
>>> 
>>> 2013-02-26 17:01:58,141 DEBUG [allocator.impl.FirstFitAllocator]
>>> (consoleproxy-1:FirstFitRoutingAllocator) FirstFitAllocator has 1 
>>> hosts to check for allocation: [Host[-5-Routing]]****
>>> 
>>> 2013-02-26 17:01:58,142 DEBUG [allocator.impl.FirstFitAllocator]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Found 1 hosts for 
>>> allocation after prioritization: [Host[-5-Routing]]****
>>> 
>>> 2013-02-26 17:01:58,142 DEBUG [allocator.impl.FirstFitAllocator]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Looking for speed=500Mhz,
>>> Ram=1024
>>> ****
>>> 
>>> 2013-02-26 17:01:58,143 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Checking if host: 5 has 
>>> enough capacity for requested CPU: 500 and requested RAM: 1073741824 
>>> ,
>>> cpuOverprovisioningFactor: 1.0****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Hosts's actual total CPU:
>>> 28920 and CPU after applying overprovisioning: 28920****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Free CPU: 28920 , Requested CPU:
>>> 500****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Free RAM: 24914546688 , 
>>> Requested
>>> RAM: 1073741824****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Host has enough CPU and 
>>> RAM
>>> available****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) STATS: Can alloc CPU from host:
>>> 5, used: 0, reserved: 0, actual total: 28920, total with overprovisioning:
>>> 28920; requested cpu:500,alloc_from_last_host?:false
>>> ,considerReservedCapacity?: true****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:FirstFitRoutingAllocator) STATS: Can alloc MEM from host:
>>> 5, used: 0, reserved: 0, total: 24914546688; requested mem:
>>> 1073741824,alloc_from_last_host?:false ,considerReservedCapacity?:
>>> true***
>>> *
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [allocator.impl.FirstFitAllocator]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Found a suitable host, 
>>> adding to
>>> list: 5****
>>> 
>>> 2013-02-26 17:01:58,145 DEBUG [allocator.impl.FirstFitAllocator]
>>> (consoleproxy-1:FirstFitRoutingAllocator) Host Allocator returning 1 
>>> suitable hosts****
>>> 
>>> 2013-02-26 17:01:58,146 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Checking suitable pools for volume (Id, Type):
>>> (1423,ROOT)****
>>> 
>>> 2013-02-26 17:01:58,146 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) We need to allocate new storagepool for this
>>> volume*
>>> ***
>>> 
>>> 2013-02-26 17:01:58,146 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Calling StoragePoolAllocators to find suitable 
>>> pools
>>> ****
>>> 
>>> 2013-02-26 17:01:58,146 DEBUG
>>> [storage.allocator.LocalStoragePoolAllocator] (consoleproxy-1:null) 
>>> LocalStoragePoolAllocator trying to find storage pool to fit the
>>> vm****
>>> 
>>> 2013-02-26 17:01:58,146 DEBUG
>>> [storage.allocator.FirstFitStoragePoolAllocator]
>>> (consoleproxy-1:null) Looking for pools in dc: 4  pod:4
>>> cluster:4****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.FirstFitStoragePoolAllocator]
>>> (consoleproxy-1:null) FirstFitStoragePoolAllocator has 1 pools to 
>>> check for allocation****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.AbstractStoragePoolAllocator]
>>> (consoleproxy-1:null) Checking if storage pool is suitable, name: 
>>> PRIMARY ,poolId: 224****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.AbstractStoragePoolAllocator]
>>> (consoleproxy-1:null) Is localStorageAllocationNeeded? true****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.AbstractStoragePoolAllocator]
>>> (consoleproxy-1:null) Is storage pool shared? true****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.AbstractStoragePoolAllocator]
>>> (consoleproxy-1:null) StoragePool is not of correct type, skipping 
>>> this pool****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.FirstFitStoragePoolAllocator]
>>> (consoleproxy-1:null) FirstFitStoragePoolAllocator returning 0 
>>> suitable storage pools****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.LocalStoragePoolAllocator] (consoleproxy-1:null) 
>>> LocalStoragePoolAllocator returning 0 suitable storage pools****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG
>>> [storage.allocator.LocalStoragePoolAllocator] (consoleproxy-1:null) 
>>> Unable to find storage pool to fit the vm****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) No suitable pools found for volume:
>>> Vol[1423|vm=1423|ROOT] under cluster: 4****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) No suitable pools found****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) No suitable storagePools found under this
>>> Cluster: 4
>>> ****
>>> 
>>> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
>>> (consoleproxy-1:null) Could not find suitable Deployment Destination 
>>> for this VM under any clusters, returning.****
>>> 
>>> 2013-02-26 17:01:58,165 DEBUG [cloud.capacity.CapacityManagerImpl]
>>> (consoleproxy-1:null) VM state transitted from :Starting to Stopped 
>>> with
>>> event: OperationFailedvm's original host id: null new host id: null 
>>> host id before state transition: null****
>>> 
>>> 2013-02-26 17:01:58,166 WARN
>>> [cloud.consoleproxy.ConsoleProxyManagerImpl]
>>> (consoleproxy-1:null) Exception while trying to start console
>>> proxy****
>>> 
>>> com.cloud.exception.InsufficientServerCapacityException: Unable to 
>>> create a deployment for VM[ConsoleProxy|v-1423-VM]Scope=interface
>>> com.cloud.dc.DataCenter; id=4****
>>> 
>>>   at
>> com.cloud.vm.VirtualMachineManagerImpl.advanceStart(VirtualMachineMa
>> na
>>> gerImpl.java:723)
>>> ****
>>> 
>>>   at
>> com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerIm
>> pl
>>> .java:461)
>>> ****
>>> 
>>>   at
>> com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerIm
>> pl
>>> .java:454)
>>> ****
>>> 
>>>   at
>> com.cloud.consoleproxy.ConsoleProxyManagerImpl.startProxy(ConsoleProx
>> y
>>> ManagerImpl.java:598)
>>> ****
>>> 
>>>   at
>> com.cloud.consoleproxy.ConsoleProxyManagerImpl.allocCapacity(ConsolePr
>>> oxyManagerImpl.java:1096)
>>> ****
>>> 
>>>   at
>> com.cloud.consoleproxy.ConsoleProxyManagerImpl.expandPool(ConsolePr
>> oxy
>>> ManagerImpl.java:1869)
>>> ****
>>> 
>>>   at
>> com.cloud.consoleproxy.ConsoleProxyManagerImpl.expandPool(ConsolePr
>> oxy
>>> ManagerImpl.java:155)
>>> ****
>>> 
>>>   at
>> com.cloud.vm.SystemVmLoadScanner.loadScan(SystemVmLoadScanner.java
>> :109
>>> )***
>>> *
>>> 
>>>   at
>> com.cloud.vm.SystemVmLoadScanner.access$100(SystemVmLoadScanner.ja
>> va:3
>>> 0)**
>>> **
>>> 
>>>   at
>> com.cloud.vm.SystemVmLoadScanner$1.reallyRun(SystemVmLoadScanner.j
>> ava:
>>> 79)*
>>> ***
>>> 
>>>   at
>> com.cloud.vm.SystemVmLoadScanner$1.run(SystemVmLoadScanner.java:69
>> )*
>>> ***
>>> 
>>>   at
>>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:4
>>> 71
>>> )***
>>> *
>>> 
>>>   at
>>> java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:
>>> 351)
>>> ****
>>> 
>>>   at
>>> java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)****
>>> 
>>>   at
>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.a
>>> ccess$201(ScheduledThreadPoolExecutor.java:165)
>>> ****
>>> 
>>>   at
>>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask
>>> .r
>>> un(ScheduledThreadPoolExecutor.java:267)
>>> ****
>>> 
>>>   at
>>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor
>>> .j
>>> ava:1110)
>>> ****
>>> 
>>>   at
>>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
>>> java:603)
>>> ****
>>> 
>>>   at java.lang.Thread.run(Thread.java:679)****
>>> 
>>> 2013-02-26 17:01:58,468 DEBUG
>>> [network.router.VirtualNetworkApplianceManagerImpl]
>>> (RouterStatusMonitor-1:null) Found 0 routers.****
>>> 
>>> 2013-02-26 17:02:00,013 DEBUG [agent.manager.AgentManagerImpl]
>>> (AgentManager-Handler-7:null) Ping from 5****
>>> 
>>> ** **
>>> 
>>> ** **
>>> 
>>> Can someone give me an idea on how to solve this issue?...****
>>> 
>>> ** **
>>> 
>>> **-          ******
>>> 

Mime
View raw message