cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tamas Monos <tam...@veber.co.uk>
Subject RE: trouble with upgrade 3.0.2 to 4.0 and systemvm no network
Date Mon, 04 Feb 2013 12:16:52 GMT
Hi,

Yes I can help you with it however you must turn off storage cleanup otherwise you whole environment
will self-destruct!!!
Do this for your own risk in your test environment first, and have backups of the database
and secondary storage before continuing.

Unfortunately the 3.0.2 -> 4.0 upgrade path is a bit broken so do not use it in production
if you need usage!!

3.0.2 -> 4.0 Upgrade workarounds (for vmware):
1. Add new vmware template to CS with name systemvm-vmware-4.0
2. Wait till the template is downloaded and installed successfully
3. Look up id of this template in DB (Name should match the input provided in step 1)

mysql> select id from `cloud`.`vm_template` where name = 'systemvm-vmware-4.0' and removed
is null;

4. Update template type to SYSTEM

mysql> update `cloud`.`vm_template` set type='SYSTEM' where id = <id-from-step3>;

5. Update template Id for all system Vms

mysql> update `cloud`.`vm_instance` set vm_template_id = <id-from-step3> where type
<> 'User' and hypervisor_type = 'VMware';

6. Restart all system Vms
7. Below column has to be added in cloud_usage db for usage server to work.

mysql> ALTER TABLE `cloud_usage`.`account` ADD COLUMN `default_zone_id` bigint unsigned;

Hope this helps.

Regards

Tamas Monos                                               DDI         +44(0)2034687012
Chief Technical                                             Office    +44(0)2034687000
Veber: The Hosting Specialists               Fax         +44(0)871 522 7057
http://www.veber.co.uk

Follow us on Twitter: www.twitter.com/veberhost
Follow us on Facebook: www.facebook.com/veberhost


-----Original Message-----
From: Andreas Huser [mailto:ahuser@7five-edv.de] 
Sent: 02 February 2013 19:19
To: cloudstack-users@incubator.apache.org
Subject: trouble with upgrade 3.0.2 to 4.0 and systemvm no network

Hi all, 

I upgrade from 3.0.2 to 4.0 according to the instructions. 
After upgrade i do "nohup cloud-sysvmadm -d localhost -u cloud -p xxx -c -r > sysvm.log
2>&1 &" 
All router are reboot but cloudstack have old router and systemvm version "Cloudstack Release
3.0 Mon Feb 6 15:10:04 PST 2012" 
The Virtual Router Starts, but the Network not work. I can not ping local, guest, public IP
etc. 

can anybody help me? 

Regards Andreas 


Mime
View raw message