cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <aemne...@gmail.com>
Subject Re: ssvm not re-created after removed
Date Tue, 05 Feb 2013 21:25:48 GMT
before the upgrade, did you download the new system vm templates using the
cloudstack UI? Did you modify the system vm offerings?


On Tue, Feb 5, 2013 at 1:22 PM, Andreas Huser <ahuser@7five-edv.de> wrote:

> Hi Ahmad,
>
> I have nothing changed during the upgrade and no problems found too.  The
> Network works fine.
>
> But all-clear. I have also destroyed the console proxy to look the result
> what happens.
> After a restart the cloud-management service the function
> "storage.secondary.SecondaryStorageManagerImpl"  create a new secstorage vm.
> and the console Proxy comes up too.
>
> For the documentation it's maybe helpful.
> For this problem destroy all system-vms in the zone and restart the
> managent service. that's it.
>
> I have no trivial erros found in the log.
> Also i found no command "storage.secondary.SecondaryStorageManagerImpl"
> this was missing!
>
>
> New log:
> 2013-02-05 19:12:49,143 DEBUG
> [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Zone 1
> is ready to launch secondary storage VM
> 2013-02-05 19:12:49,231 INFO
>  [cloud.secstorage.PremiumSecondaryStorageManagerImpl] (secstorage-1:null)
> No running secondary storage vms found in datacenter id=1, starting one
> 2013-02-05 19:12:49,263 INFO
>  [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) No
> stopped secondary storage vm is available, need to allocate a new secondary
> storage vm
> 2013-02-05 19:12:49,266 DEBUG
> [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Assign
> secondary storage vm from a newly started instance for request from data
> center : 1
> 2013-02-05 19:12:49,344 DEBUG [cloud.network.NetworkManagerImpl]
> (secstorage-1:null) Found existing network configuration for offering
> [Network Offering [1-Public-System-Public-Network]: Ntwk[200|Public|1]
>
>
>
> Many thanks from Germany and for your help!!!
> Andreas
>
>
>
> ----- Urspr√ľngliche Mail -----
>
> Von: "Ahmad Emneina" <aemneina@gmail.com>
> An: "Andreas Huser" <ahuser@7five-edv.de>
> CC: cloudstack-users@incubator.apache.org
> Gesendet: Dienstag, 5. Februar 2013 20:22:57
> Betreff: Re: ssvm not re-created after removed
>
> Was this setup working at some point? Has anything changed in the
> networking? Maybe the its a new host and the configuration hasnt been
> applied yet.... what I see is cloudstack tries to deploy your system vm's
> but cant ping them on their public interface:
> 2013-02-02 23:12:36,511 WARN [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (Job-Executor-26:job-91) Unable to ssh to the VM: Can not ping System vm
> v-1240-VMdue to:Unable to connect
>
>
>
> On Tue, Feb 5, 2013 at 6:35 AM, Andreas Huser <ahuser@7five-edv.de> wrote:
>
> > Hi Ahmad,
> >
> > thanks for your reply!
> >
> > I meant the ssvm has an error. then i have deleted it over cloudstack.
> > Infrastructure > Zone > System VM > "Destroy"
> >
> > At the previous version of cloudstack (3.0.2) a fresh ssvm takes maximum
> > 30 seconds for the automatic new creation.
> >
> > In the logs i have no info. No errors for creating a new ssvm.
> > I think the management Server initialized not the command to provision
> for
> > a new ssvm.
> >
> > I check the database and see the destroyed ssvm are correctly deleted.
> >
> > Here the logs, beginning at the ssvm destroy.
> > http://pastebin.com/knKJgL5S
> >
> > can i not trigger a manual creation for a new ssvm over cli?
> >
> > many Thanks!
> > Regards
> > Andreas
> >
> >
> >
> >
> > ----- Urspr√ľngliche Mail -----
> >
> > Von: "Ahmad Emneina" <aemneina@gmail.com>
> > An: cloudstack-users@incubator.apache.org
> > Gesendet: Montag, 4. Februar 2013 20:00:59
> > Betreff: Re: ssvm not re-created after removed
> >
> > Hey Andreas... can you post the logs to a place we can all view them,
> maybe
> > pastebin.com. Also this should be recoverable. What do you mean by
> > manually
> > deleting the ssvm? Did you do that on the host or via cloudstack. You
> might
> > need to mend your db to reflect the vm is completely gone, or use the
> > destroysystemvm api call.
> >
> >
> > On Mon, Feb 4, 2013 at 3:13 AM, Andreas Huser <ahuser@7five-edv.de>
> wrote:
> >
> > > Hi,
> > >
> > > I have delete manual my secondary storage vm after upgrade from 3.0.2
> to
> > > 4.0.
> > > And now they will not be created again automatically, what can I do.
> > >
> > > In the log files is not something you can use. Only "here is no
> secondary
> > > storage VM for secondary storage host"
> > > Can we create manual trigger to deploy a new SSVM?
> > >
> > > Regards
> > > Andreas
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message