cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nalley <da...@gnsa.us>
Subject Re: 4.0.1 upgrade failure
Date Thu, 14 Feb 2013 15:22:35 GMT
On Thu, Feb 14, 2013 at 10:20 AM, Nick Wales <nick@nickwales.co.uk> wrote:
>
>
>
> On 13 Feb 2013, at 22:30, David Nalley <david@gnsa.us> wrote:
>
>> On Wed, Feb 13, 2013 at 9:12 PM, Nick Wales <nick@nickwales.co.uk> wrote:
>>> Following the instructions in the release notes appeared to have worked
>>> until the error on line 127: http://pastebin.com/Hj6hncGm
>>>
>>> The following packages were ugpraded by yum:
>>>
>>>  cloud-deps-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-client-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-scripts-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-core-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-setup-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-client-ui-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-python-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-utils-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-server-4.0.0-0.140.el6.4.0.x86_64
>>> cloud-aws-api-4.0.0-0.140.el6.4.0.x86_64
>>> I'm running CentOS 6.2. The UI loads but I can't login, can anyone assist?
>>>
>>> Thanks
>>>
>>> Nick
>>
>>
>> Has your sudo configuration changed?
>> Can we see /etc/sudoers?
>>
>> --David
>
> Puppet may well have overridden anything cloudstack implemented.
>
> There's a large amount of data in sudoers i'm not willing to share to the general audience,
is there anything in particular I should be looking for?
>
>

Doh, yeah that will be the issue then.

Take a look at this manifest, which has the line needed by CloudStack:

https://github.com/ke4qqq/puppet-cloudstack/blob/master/manifests/init.pp
Lines 37-40

--David

Mime
View raw message