cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kan <extremeblu...@gmail.com>
Subject Invalid username and password after cloudstack 4.0 installation
Date Sat, 02 Feb 2013 18:36:28 GMT
Hi,
I'm having a hard time logging into cloudstack UI after installation (via
rpm). I kept getting invalid username password with admin/password after I
ran cloud-setup-databaes and cloud-setup-management. I checked mysql DB.
The admin user is in there. i'm running cloudstack 4.0 on centos 6.3 with
tomcat 6.0.33. I checked management-server.log. There weren't any errors.
One strange thing is that I enabled debug logging in log4j. I don't get any
logging when I hit the UI. I appreciate any help. I'm running out of ideas.
Thanks.

Dan

---+---------------------+---------+----------+--------------------+---------------+--------------------------+
| id | uuid | username | password                         | account_id |
firstname | lastname | email | state   | api_key | secret_key |
created             | removed | timezone | registration_token |
is_registered | incorrect_login_attempts |
+----+------+----------+----------------------------------+------------+-----------+----------+-------+---------+---------+------------+---------------------+---------+----------+--------------------+---------------+--------------------------+
|  1 | NULL | system   | 0.105902211839242                |          1 |
system    | cloud    | NULL  | enabled | NULL    | NULL       | 2013-02-01
21:48:51 | NULL    | NULL     | NULL               |             0
|                        0 |
|  2 | NULL | admin    | 5f4dcc3b5aa765d61d8327deb882cf99 |          2 |
admin     | cloud    | NULL  | enabled | NULL    | NULL       | 2013-02-01
21:48:51 | NULL    | NULL     | NULL               |             0
|                        0 |
+----+------+----------+----------------------------------+------------+-----------+----------+-------+---------+---------+------------+---------------------+---------+----------+--------------------+---------------+--------------------------+

Snippets from management-server.log
2013-02-02 10:34:13,887 INFO  [utils.component.ComponentLocator]
(main:null) Adding system integrity checker: DatabaseUpgradeChecker
2013-02-02 10:34:14,086 INFO  [cloud.upgrade.DatabaseIntegrityChecker]
(main:null) Grabbing lock to check for database integrity.
2013-02-02 10:34:14,396 INFO  [cloud.upgrade.DatabaseIntegrityChecker]
(main:null) Performing database integrity check
2013-02-02 10:34:14,527 INFO  [cloud.upgrade.DatabaseUpgradeChecker]
(main:null) Grabbing lock to check for database upgrade.
2013-02-02 10:34:14,532 INFO  [cloud.upgrade.DatabaseUpgradeChecker]
(main:null) DB version = 4.0.0.20121024012150 Code Version =
4.0.0.20121024012150
2013-02-02 10:34:14,533 INFO  [cloud.upgrade.DatabaseUpgradeChecker]
(main:null) DB version and code version matches so no upgrade needed.
2013-02-02 10:34:14,542 INFO  [utils.component.ComponentLocator]
(main:null) Config file found at /etc/cloud/management/components.xml.
Configuring configuration-server

Snippets from catalina.out
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
Configuration configuration server
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: Snapshot
policy defaults
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: DiskOffering
configuration server
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
ServiceOffering configuration server
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: DataCenterDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: host pod
configuration server
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: DomainDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
NetworkOfferingDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: NetworkDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: IpAddressDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: VlanDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
ResouceCountDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: AccountDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: UserDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
NetworkOfferingServiceDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
VirtualRouterProviderDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO: IdentityDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
Site2SiteCustomerGatewayDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
Site2SiteVpnGatewayDao
INFO  [utils.component.ComponentLocator] (main:) Starting DAO:
Site2SiteVpnConnectionDao
INFO: Starting Coyote HTTP/1.1 on http-8080
INFO: JK: ajp13 listening on /0.0.0.0:20400
INFO: Jk running ID=0 time=0/24  config=null
INFO: Starting service Catalina7080
INFO: Starting Servlet Engine: Apache Tomcat/6.0.33
INFO: Deploying web application directory awsapi
INFO: Starting Coyote HTTP/1.1 on http-7080
INFO: Server startup in 5564 ms

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message