cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sunilreddy Kovvuri <sunil570....@gmail.com>
Subject Re: Setting up private cloud
Date Sun, 24 Feb 2013 15:15:30 GMT
Hello,

I have one pc and it was not connected to internet

On Sun, Feb 24, 2013 at 7:38 PM, Sebastien Goasguen <runseb@gmail.com>wrote:

>
> On Feb 22, 2013, at 1:21 AM, Sunilreddy Kovvuri <sunil570.cse@gmail.com>
> wrote:
>
> > Background:
> > - We are using cloudstack 4.0 for our POC activities.
> > - Configuration details are as below:
> >    - Ubuntu 12.04 with 1 NIC card(eth0) and wifi(wlan0)
> >    - Router/switch:No
>
> How many machines do you have on your setup ?
> How are they connected and can they access the internet ?
>
> >
> > - One of the use-case that we are trying to accomplish is to provision
> > virtual machines from our private cloud.
> >
> > Issue:
> > - As we do not want to use a dedicated router, we would like to use the
> > same cloudstack server as router (i.e. DHCP server run by cloudstack
> should
> > communicate with this router for private IPs).
> > - We would like to nat the network traffic from public ip on to private
> ip
> > such that vm instances will only have ip which is from private network.
> > - Another reason why we want to go this route is, we have a very limited
> > number of public IPs.
> >
> > The issue is, we are unable to get this kind of a setup implemented.
> >
> > Options we tried so far:
> >
> > - Setting up a gateway on a different machine which can serve private IPs
> > - Using the above gateway for cloudstack server and agent
> >    - Reconfigured the Zones and Guest Network in cloudstack UI to point
> to
> > the new gateway
> > - Restarted the cloudstack server and attempting to launch consoles
> throws
> > up the error - "Server not found" and the log shows - "Found 0 routers"
> >
> > Any inputs on how we can fix this issue?
>
> I presume you have the mgt server running, and you were able to create a
> zone ?
> I also presume you created a basic zone ?
> Are your systemvms running ?
> Is the virtual router running ?
>
>
> >
> > Will realhostip.com will look for the public network for internet
> access?
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message