cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject Re: how to get hosts out of 'avoid' state
Date Thu, 21 Feb 2013 15:09:56 GMT

On Feb 21, 2013, at 4:03 PM, Carlos ReƔtegui <creategui@gmail.com> wrote:

> Hi Sebastien
> How did you make it past the alert state?  That is where I got stuck. I had installed
my 12.04 +xapi hosts using kickstart so the root user is there and I am able to log in with
it. 

I was able to ssh as root on the hosts but the /root/.ssh directory did not exist.
On the hosts I did: ssh-keygen and that created the missing .ssh (probably could have done
mkdir)

restarted the mgt server and the hosts got up.

secondary storage is NFS and that was added with no issue.

primary storage is nfs. I created it by hand with xe sr-create and added it in the ui using
the PresSetup protocol. That worked too (after couple tries to learn the xe sr related commands).

Now it seems CS thinks I don't have enough RAM on the hosts and that's why the systemvm don't
find anywhere to run.

-sebastien

> It was suggested that I try to add my NFS SR on the host before adding to CS but I have
not had a chance to try that yet. Is that what you did to get to this state?
> 
> Cheers
> Carlos
> 
> On Feb 21, 2013, at 6:25 AM, Sebastien Goasguen <runseb@gmail.com> wrote:
> 
>> Hi,
>> 
>> I got a basic zone with xen hosts. running 4.0.1.
>> 
>> My hosts are stuck in 'avoid' state according to the logs at:
>> http://pastebin.com/Vb1tg6Gq
>> 
>> And therefore the systemvms don't start.
>> 
>> I tried to restart the mgt server but that did not do anything.
>> 
>> -sebastien


Mime
View raw message