cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shane Witbeck <sh...@digitalsanctum.com>
Subject Re: install from 4.1 branch fails
Date Wed, 27 Feb 2013 15:06:18 GMT
Thanks Prasanna but unfortunately it looks like this is incomplete too: 

cloudstack@cs10:~$ sudo apt-get install cloud-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package cloud-client is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'cloud-client' has no installation candidate 

-- 
Shane Witbeck


On Tuesday, February 26, 2013 at 2:11 AM, Prasanna Santhanam wrote:

> On Tue, Feb 26, 2013 at 12:49:43AM +0530, Shane Witbeck wrote:
> > While trying to install CS from Debian/Ubuntu packages derived from source (4.1
branch), I get the following on Ubuntu 12.04.1:
> > 
> > Setting up cloud-client (1:4.0.0-1) ...
> > Warning: The home dir /var/lib/cloud/management you specified can't be accessed:
No such file or directory
> > Adding system user `cloud' (UID 106) ...
> > Adding new group `cloud' (GID 111) ...
> > Adding new user `cloud' (UID 106) with group `cloud' ...
> > Not creating home directory `/var/lib/cloud/management'.
> > chmod: cannot access `/var/lib/cloud/mnt': No such file or directory
> > dpkg: error processing cloud-client (--configure):
> > subprocess installed post-installation script returned error exit status 1
> > Setting up icedtea-6-jre-cacao (6b27-1.12.3-0ubuntu1~12.04) ...
> > Setting up icedtea-6-jre-jamvm (6b27-1.12.3-0ubuntu1~12.04) ...
> > Setting up icedtea-netx (1.2-2ubuntu1.3) ...
> > update-alternatives: using /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/javaws to provide
/usr/bin/javaws (javaws) in auto mode.
> > update-alternatives: using /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/itweb-settings
to provide /usr/bin/itweb-settings (itweb-settings) in auto mode.
> > Setting up openjdk-6-jre-lib (6b27-1.12.3-0ubuntu1~12.04) ...
> > Setting up libatk-wrapper-java-jni (0.30.4-0ubuntu2) ...
> > Processing triggers for libc-bin ...
> > ldconfig deferred processing now taking place
> > Errors were encountered while processing:
> > cloud-client
> > E: Sub-process /usr/bin/dpkg returned an error code (1)
> > 
> 
> The 4.1 packaging for debian is still in the works. Wido and Noa have
> been working on their github branch, perhaps try the source from
> there?
> 
> https://github.com/noaresare/incubator-cloudstack/tree/packaging
> 
> -- 
> Prasanna.,
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message