cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devdeep Singh <devdeep.si...@citrix.com>
Subject RE: StoragePool is not of correct type
Date Wed, 27 Feb 2013 08:09:09 GMT
For system vms this failure could happen if you selected the "use local" storage while creating
the zone. You may try creating a new zone and not check the "Use Local" option while doing
so.

Regards,
Devdeep

> -----Original Message-----
> From: Nitin Mehta [mailto:Nitin.Mehta@citrix.com]
> Sent: Wednesday, February 27, 2013 7:17 AM
> To: cloudstack-users@incubator.apache.org; aemneina@gmail.com
> Subject: Re: StoragePool is not of correct type
> 
> Are you using service offering with local storage ?
> 
> On 27/02/13 12:44 AM, "Ahmad Emneina" <aemneina@gmail.com> wrote:
> 
> >2013-02-26 17:01:58,147 DEBUG
> >[storage.allocator.AbstractStoragePoolAllocator]
> >(consoleproxy-1:null) Is storage pool shared? true
> >2013-02-26 17:01:58,147 DEBUG
> >[storage.allocator.AbstractStoragePoolAllocator]
> >(consoleproxy-1:null) StoragePool is not of correct type, skipping this
> >pool
> >
> >this might be your issue. are your system vm's set to use local storage?
> >
> >
> >On Tue, Feb 26, 2013 at 9:04 AM, Valery Fongang <
> >fongang.valery@pertechtual.net> wrote:
> >
> >>  Hi all,****
> >>
> >> ** **
> >>
> >> I am trying to setup Cloudstack 3.0.2 with KVM hypervisor (on Centos
> >>3.0)
> >>  and I am running into a number of issues. At this time I have
> >>managed to  get up to the following stage:****
> >>
> >> ** **
> >>
> >> **-          **Cloud Management Server installed.****
> >>
> >> **-          **Host installed with KVM.****
> >>
> >> **-          **Zone-Cluster-Pod-Host-Primary Storage- Secondary all
> >>setup
> >> and displaying on Cloudstack dashboard.****
> >>
> >> **-          **System VM templates are available in Templates but no
> >> Centos Template.****
> >>
> >> **-          **System VMs were generated but unable to boot.****
> >>
> >> **-          **My Cloud Management Server Log shows the following:****
> >>
> >> ** **
> >>
> >> ** **
> >>
> >> 2013-02-26 17:01:58,119 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:null) VM state transitted from :Stopped to Starting
> >>with
> >> event: StartRequestedvm's original host id: null new host id: null
> >>host id  before state transition: null****
> >>
> >> 2013-02-26 17:01:58,119 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> >> (consoleproxy-1:null) Successfully transitioned to start state for
> >> VM[ConsoleProxy|v-1423-VM] reservation id =
> >> a2d3825d-ffc7-411c-92ec-fc0872247923****
> >>
> >> 2013-02-26 17:01:58,127 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> >> (consoleproxy-1:null) Trying to deploy VM, vm has dcId: 4 and podId:
> >>null*
> >> ***
> >>
> >> 2013-02-26 17:01:58,128 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> >> (consoleproxy-1:null) Deploy avoids pods: null, clusters: null, hosts:
> >>null
> >> ****
> >>
> >> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) DeploymentPlanner allocation algorithm:
> >> random****
> >>
> >> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Trying to allocate a host and storage pools
> >>from  dc:4, pod:null,cluster:null, requested cpu: 500, requested ram:
> >>1073741824
> >> ****
> >>
> >> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Is ROOT volume READY (pool already allocated)?:
> >>No**
> >> **
> >>
> >> 2013-02-26 17:01:58,129 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Searching all possible resources under this Zone:
> >>4*
> >> ***
> >>
> >> 2013-02-26 17:01:58,130 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Listing clusters in order of aggregate
> >>capacity, that  have (atleast one host with) enough CPU and RAM
> >>capacity under this
> >>Zone: 4
> >> ****
> >>
> >> 2013-02-26 17:01:58,130 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) CPUOverprovisioningFactor considered: 1.0****
> >>
> >> 2013-02-26 17:01:58,139 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Checking resources in Cluster: 4 under Pod:
> >> 4****
> >>
> >> 2013-02-26 17:01:58,139 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Calling HostAllocators to find suitable
> >> hosts****
> >>
> >> 2013-02-26 17:01:58,139 DEBUG [allocator.impl.FirstFitAllocator]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Looking for hosts in dc: 4
> >> pod:4  cluster:4****
> >>
> >> 2013-02-26 17:01:58,141 DEBUG [allocator.impl.FirstFitAllocator]
> >> (consoleproxy-1:FirstFitRoutingAllocator) FirstFitAllocator has 1
> >>hosts to  check for allocation: [Host[-5-Routing]]****
> >>
> >> 2013-02-26 17:01:58,142 DEBUG [allocator.impl.FirstFitAllocator]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Found 1 hosts for
> >> allocation after prioritization: [Host[-5-Routing]]****
> >>
> >> 2013-02-26 17:01:58,142 DEBUG [allocator.impl.FirstFitAllocator]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Looking for speed=500Mhz,
> >>Ram=1024
> >> ****
> >>
> >> 2013-02-26 17:01:58,143 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Checking if host: 5 has
> >> enough capacity for requested CPU: 500 and requested RAM:
> 1073741824
> >> ,
> >> cpuOverprovisioningFactor: 1.0****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Hosts's actual total CPU:
> >>28920
> >> and CPU after applying overprovisioning: 28920****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Free CPU: 28920 , Requested
> >>CPU:
> >> 500****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Free RAM: 24914546688 ,
> >>Requested
> >> RAM: 1073741824****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Host has enough CPU and RAM
> >> available****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) STATS: Can alloc CPU from
> >>host:
> >> 5, used: 0, reserved: 0, actual total: 28920, total with
> >>overprovisioning:
> >> 28920; requested cpu:500,alloc_from_last_host?:false
> >> ,considerReservedCapacity?: true****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:FirstFitRoutingAllocator) STATS: Can alloc MEM from
> >>host:
> >> 5, used: 0, reserved: 0, total: 24914546688; requested mem:
> >> 1073741824,alloc_from_last_host?:false ,considerReservedCapacity?:
> >>true***
> >> *
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [allocator.impl.FirstFitAllocator]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Found a suitable host,
> >>adding to
> >> list: 5****
> >>
> >> 2013-02-26 17:01:58,145 DEBUG [allocator.impl.FirstFitAllocator]
> >> (consoleproxy-1:FirstFitRoutingAllocator) Host Allocator returning 1
> >> suitable hosts****
> >>
> >> 2013-02-26 17:01:58,146 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Checking suitable pools for volume (Id, Type):
> >> (1423,ROOT)****
> >>
> >> 2013-02-26 17:01:58,146 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) We need to allocate new storagepool for this
> >>volume*
> >> ***
> >>
> >> 2013-02-26 17:01:58,146 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Calling StoragePoolAllocators to find suitable
> >>pools
> >> ****
> >>
> >> 2013-02-26 17:01:58,146 DEBUG
> >> [storage.allocator.LocalStoragePoolAllocator] (consoleproxy-1:null)
> >> LocalStoragePoolAllocator trying to find storage pool to fit the
> >> vm****
> >>
> >> 2013-02-26 17:01:58,146 DEBUG
> >> [storage.allocator.FirstFitStoragePoolAllocator]
> >> (consoleproxy-1:null) Looking for pools in dc: 4  pod:4
> >> cluster:4****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.FirstFitStoragePoolAllocator]
> >> (consoleproxy-1:null) FirstFitStoragePoolAllocator has 1 pools to
> >> check for allocation****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.AbstractStoragePoolAllocator]
> >> (consoleproxy-1:null) Checking if storage pool is suitable, name:
> >> PRIMARY ,poolId: 224****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.AbstractStoragePoolAllocator]
> >>(consoleproxy-1:null) Is  localStorageAllocationNeeded? true****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.AbstractStoragePoolAllocator]
> >>(consoleproxy-1:null) Is  storage pool shared? true****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.AbstractStoragePoolAllocator]
> >> (consoleproxy-1:null) StoragePool is not of correct type, skipping
> >> this pool****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.FirstFitStoragePoolAllocator]
> >> (consoleproxy-1:null) FirstFitStoragePoolAllocator returning 0
> >> suitable storage pools****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.LocalStoragePoolAllocator] (consoleproxy-1:null)
> >> LocalStoragePoolAllocator returning 0 suitable storage pools****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG
> >> [storage.allocator.LocalStoragePoolAllocator] (consoleproxy-1:null)
> >>Unable  to find storage pool to fit the vm****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) No suitable pools found for volume:
> >> Vol[1423|vm=1423|ROOT] under cluster: 4****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) No suitable pools found****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) No suitable storagePools found under this
> >>Cluster: 4
> >> ****
> >>
> >> 2013-02-26 17:01:58,147 DEBUG [cloud.deploy.FirstFitPlanner]
> >> (consoleproxy-1:null) Could not find suitable Deployment Destination
> >> for this VM under any clusters, returning.****
> >>
> >> 2013-02-26 17:01:58,165 DEBUG [cloud.capacity.CapacityManagerImpl]
> >> (consoleproxy-1:null) VM state transitted from :Starting to Stopped
> >>with
> >> event: OperationFailedvm's original host id: null new host id: null
> >>host id  before state transition: null****
> >>
> >> 2013-02-26 17:01:58,166 WARN
> >>[cloud.consoleproxy.ConsoleProxyManagerImpl]
> >> (consoleproxy-1:null) Exception while trying to start console
> >>proxy****
> >>
> >> com.cloud.exception.InsufficientServerCapacityException: Unable to
> >>create  a deployment for VM[ConsoleProxy|v-1423-VM]Scope=interface
> >> com.cloud.dc.DataCenter; id=4****
> >>
> >>    at
> >>
> >>com.cloud.vm.VirtualMachineManagerImpl.advanceStart(VirtualMachineMa
> na
> >>ger
> >>Impl.java:723)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerIm
> pl
> >>.ja
> >>va:461)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerIm
> pl
> >>.ja
> >>va:454)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.consoleproxy.ConsoleProxyManagerImpl.startProxy(ConsolePro
> xy
> >>Man
> >>agerImpl.java:598)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.consoleproxy.ConsoleProxyManagerImpl.allocCapacity(ConsoleP
> r
> >>oxy
> >>ManagerImpl.java:1096)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.consoleproxy.ConsoleProxyManagerImpl.expandPool(ConsolePr
> oxy
> >>Man
> >>agerImpl.java:1869)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.consoleproxy.ConsoleProxyManagerImpl.expandPool(ConsolePr
> oxy
> >>Man
> >>agerImpl.java:155)
> >> ****
> >>
> >>    at
> >>
> >>com.cloud.vm.SystemVmLoadScanner.loadScan(SystemVmLoadScanner.java
> :109
> >>)**
> >>*
> >> *
> >>
> >>    at
> >>
> >>com.cloud.vm.SystemVmLoadScanner.access$100(SystemVmLoadScanner.j
> ava:3
> >>0)*
> >>*
> >> **
> >>
> >>    at
> >>
> >>com.cloud.vm.SystemVmLoadScanner$1.reallyRun(SystemVmLoadScanner.j
> ava:
> >>79)
> >>*
> >> ***
> >>
> >>    at
> >>com.cloud.vm.SystemVmLoadScanner$1.run(SystemVmLoadScanner.java:6
> 9)*
> >> ***
> >>
> >>    at
> >>
> >>java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471
> >>)**
> >>*
> >> *
> >>
> >>    at
> >>
> >>java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:
> >>351
> >>)
> >> ****
> >>
> >>    at
> >>java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)****
> >>
> >>    at
> >>
> >>java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.a
> >>cce
> >>ss$201(ScheduledThreadPoolExecutor.java:165)
> >> ****
> >>
> >>    at
> >>
> >>java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.r
> >>un(
> >>ScheduledThreadPoolExecutor.java:267)
> >> ****
> >>
> >>    at
> >>
> >>java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.j
> >>ava
> >>:1110)
> >> ****
> >>
> >>    at
> >>
> >>java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
> >>jav
> >>a:603)
> >> ****
> >>
> >>    at java.lang.Thread.run(Thread.java:679)****
> >>
> >> 2013-02-26 17:01:58,468 DEBUG
> >> [network.router.VirtualNetworkApplianceManagerImpl]
> >> (RouterStatusMonitor-1:null) Found 0 routers.****
> >>
> >> 2013-02-26 17:02:00,013 DEBUG [agent.manager.AgentManagerImpl]
> >> (AgentManager-Handler-7:null) Ping from 5****
> >>
> >> ** **
> >>
> >> ** **
> >>
> >> Can someone give me an idea on how to solve this issue?...****
> >>
> >> ** **
> >>
> >> **-          ******
> >>


Mime
View raw message