cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From li_fuqiong <>
Subject [Solved]Re: Re: Basic network zone, Instance's network is unreachable.
Date Fri, 22 Feb 2013 09:34:39 GMT
Hi Bryan:

It does work. Thank you very much. 
I marked it with solved.  Hope it's hopeful with the same problem.

From: Bryan Whitehead
Date: 2013-02-22 10:49
To:; li_fuqiong
CC: aemneina
Subject: Re: Re: Basic network zone, Instance's network is unreachable.
Sounds like you made this CentOS 6.2 disk image yourself. As in you created
a template from a running Centos6.2 VM.

If this is correct you have to clean up the CentOS disk image.

remove the ssh keys,
remove udev entries
remove mac/uuid's from /etc/sysconfig/network-scripts/ifcfg-eth0

The reason is, the OS that will be created as a template needs to be in a
state where the next boot will cause udev to create new entries for the new
hardware, fresh ssh keys will be made, and the network init.d script will
be able to start dhcp on any card reguardless of the UUID or MAC. (Since
every new Vm you make from the template will be different in these 3

So do the above cleanup, "poweroff" the cleaned up VM and create a template
from that.

On Thu, Feb 21, 2013 at 6:39 PM, li_fuqiong <>wrote:

> Thank your reply, Ahmad.
> the vm seems does not get an ip address.
> use "ifconfig" command, I just got an loopback interface.
> Do you  need more information about my environment ?
> From: Ahmad Emneina
> Date: 2013-02-22 10:33
> To: Cloudstack users; li_fuqiong
> Subject: Re: Basic network zone, Instance's network is unreachable.
> did the vm get an ip address, from within the guest?
> On Thu, Feb 21, 2013 at 6:28 PM, li_fuqiong <>
> wrote:
> Dear All,
> My hypervisor is VMware, I created an instance using my template(CentOS
> 6.2), I saw the instance is running, and its nic info as follows(got it
> from Cloudstack UI):
> NIC 1 (Default)
> Network NameguestNetworkForBasicZone
> IP Address192.168.12.234
> TypeShared
> Gateway192.168.12.1
> Netmask255.255.255.0
> Is DefaultYes
> but I cannot ping it through another pc, and log in the instance, ping
> another ip got error message "Network is Unreachable"?
> What's the reason ?  What should  I do to contact this instance in the
> guest network?
> Thank you.
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message