cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <aemne...@gmail.com>
Subject Re: Issue with secondary storage on Cloudstack 4 - Host sent incorrect data center: null
Date Mon, 28 Jan 2013 22:04:38 GMT
 On 1/24/13 11:21 AM, "Ben Linton" <ben@hivelocity.net> wrote:

>Our latest issue stemmed from an issue with a failed primary storage

>iscsi target.     Our system VMs were trying to boot using this target

>and we had quite a time removing this old failed target.    During this

>process we upgraded to 4.x to try to use the "Force" option on primary

>storage.     I eventually removed the primary storage entry from the

>database using a procedure I found online.     After that the system VMs

>weren't trying to boot off of that target however there was some issues

>with secondary storage so I tried to remove and re-add as this fixed a

>similar issue we had in the past.  However now we can't add storage back

>and I've search and tried many different things to no avail."


Can you check if the primary storage youre trying to add is already

mounted on the hypervisor. If its already present, I suspect

its failing to mount on the compute hosts, remove the primary storage mount

and readd it back to cloudstack.


For the system vm's you should set your zone to a disabled state, mark the

vm's as stopped in the database, and delete/destoy them via api or ui.

They should be recreated on a primary storage that doesn┬╣t have issues.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message