cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nik Martin <nik.mar...@nfinausa.com>
Subject Re: Console Proxy VM unavailable
Date Tue, 15 Jan 2013 22:40:18 GMT
On 01/15/2013 04:28 PM, Anthony Xu wrote:
> Hi Nik,
>
> List_domains and destroy_domain are working on host not pool.
>
> So if you have multiple hosts in a XenServer pool , you might need to execute above command
on that host,
>
> You can try following to find the host
>
> Xe vm-param-list uuid="vm uuid" | grep resident-on
> You will get the host uuid
> Xe host-param-list uuid="above host uuid"
>
> Then you get the host information.
>
> Log into the host and retry the procedure to destroy VM.
I ran that command on the VM in question, and it hangs, on any host in 
the pool.  The command works fine for any other VM.  This VM must be in 
bad shape.

>
>
> Anthony
>
>> -----Original Message-----
>> From: Nik Martin [mailto:nik.martin@nfinausa.com]
>> Sent: Tuesday, January 15, 2013 2:17 PM
>> To: cloudstack-users@incubator.apache.org
>> Subject: Re: Console Proxy VM unavailable
>>
>> On 01/15/2013 03:55 PM, Anthony Xu wrote:
>>> Hi Nik,
>>>
>>> Try this
>>> http://support.citrix.com/article/CTX131421
>>>
>>> Anthony
>>
>> Anthony,
>> Running list_domains with the VMs UUID does not return any results, but
>> if I just run list_domains, I get all the control domains, and one odd
>> one:
>>
>> 117 | deadbeef-dead-beef-dead-beef00000075 | DS
>>
>> could this be the control domain for the hung VM?
>>
>>>
>>>> -----Original Message-----
>>>> From: Nik Martin [mailto:nik.martin@nfinausa.com]
>>>> Sent: Tuesday, January 15, 2013 1:41 PM
>>>> To: cloudstack-users@incubator.apache.org
>>>> Subject: Re: Console Proxy VM unavailable
>>>>
>>>> A bit more information, I logged in to Xen center and the VM is hung
>>>> with a yellow arrow.  There are no options to shutdown, reboot, or
>>>> anything.  How do I force this VM off?
>>>>
>>>> On 01/15/2013 03:32 PM, Nik Martin wrote:
>>>>> I have a CS 3.02 cloud in production, and it has been running fine
>>>> since
>>>>> December 1.  Today, I tried to use the web console, and it times
>> out.
>>>> I
>>>>> turned debug up on the management server, and see the command to
>>>> launch
>>>>> the proxy go by, but no errors.  I tried to migrate it, and now
>> it's
>>>>> hung in a migrating state.  What is the best way to reset this VM
>> and
>>>>> get back on track, and also diagnose why this happened?
>>>>
>>>>
>>>> --
>>>>
>>>> Regards,
>>>>
>>>> Nik
>>>>
>>>> Nik Martin
>>>> nfina Technologies, Inc.
>>>> +1.251.243.0043 x1003
>>>> http://nfinausa.com
>>>> Relentless Reliability
>>
>>
>> --
>>
>> Regards,
>>
>> Nik
>>
>> Nik Martin
>> nfina Technologies, Inc.
>> +1.251.243.0043 x1003
>> http://nfinausa.com
>> Relentless Reliability


-- 

Regards,

Nik

Nik Martin
nfina Technologies, Inc.
+1.251.243.0043 x1003
http://nfinausa.com
Relentless Reliability

Mime
View raw message