cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@citrix.com>
Subject RE: A DevCloud2 problem
Date Sat, 12 Jan 2013 09:55:09 GMT
On master branch devcloud in basic zone should work, at my end I make sure at the end of the
day to run integration tests once using DevCloud :)
I have had several permutation and combinations of the problem myself, based on your observatoin
I think the host was not correct in global settings and after you deploysrvr it would update
host ip so the previous sytemvm would try to connect to the incorrect IP and you see status
as starting. When you restart the new global settings are used and cloudstack tries to connect
to systemvms fails and marks them to be deleted and new ones would start and it would work
for you.

Glad it worked for you.
Cheers.

________________________________________
From: Isaac Chiang [isaacchiang@gmail.com]
Sent: Saturday, January 12, 2013 1:13 PM
To: cloudstack-users@incubator.apache.org
Subject: Re: A DevCloud2 problem

Hi Rohit:
             I did followed the steps in the checklist you mentioned. The
strange thing is that I can play with my DevCloud correctly before few
commits in master branch. The environment was the same, but I didn't see
the log before. I know that there are some significant works merged into
master recently, I'm just wondering if I lost some additional steps for
deploying the DevCloud. BTW. After a few failing trials, I found that the
problem can be solved after restarting the management server. Thanks for
the fast reply :)

Regards

Isaac

On Sat, Jan 12, 2013 at 2:34 PM, Rohit Yadav <rohit.yadav@citrix.com> wrote:

> Hi Isaac,
>
> Checkout troubleshooting section of
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/DevCloud
>
> Checklist:
> - You've deployed devcloud db profile also; mvn -pl
> developer,tools/devcloud -Ddeploydb
> - You've mkisofs and have built systemvm.iso as well; mvn clean install -P
> systemvm,developer
> - Before deploying a zone, check from global settings that host is
> 192.168.56.1 or 192.168.56.10 (if mgmt is running inside devcloud), if they
> are incorrect fix it and restart mgmt server
>
> Hope this helps.
>
> ________________________________________
> From: Isaac Chiang [isaacchiang@gmail.com]
> Sent: Saturday, January 12, 2013 11:42 AM
> To: cloudstack-users@incubator.apache.org
> Subject: A DevCloud2 problem
>
> Hi all:
>              Recently I got a trouble with DevCloud2. When I am trying to
> create a zone, the system vms cannot change the state from starting to
> running.
>
>  Following is the error message:
>
>  WARN  [xen.resource.CitrixResourceBase] (DirectAgent-7:) Detecting a new
> state but couldn't find a old state so adding it to the changes: s-1-VM
>
> The source code is checked out from latest master branch and running in
> DevCloud2. Any help will be appreciated, thanks :)
>
>
> Regards
>
> Isaac
>

Mime
View raw message