cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From FIP)ゾーミョーテッ <fj656...@aa.jp.fujitsu.com>
Subject RE: Regarding system vm issue under instances of CPlatform
Date Tue, 22 Jan 2013 09:39:59 GMT
Hi Pranav,

Thanks for your advice and here is the error logs.

----------------------------------------------------------------------------
------------------------------------
2013-01-22 18:03:29,338 WARN  [xen.resource.CitrixResourceBase]
(DirectAgent-380:null) Task failed! Task record:                 
uuid: d6f8898a-a767-5ce0-babf-16c160ef0979
nameLabel: Async.VM.start_on
nameDescription:
allowedOperations: []
currentOperations: {}
             created: Tue Jan 22 17:52:09 JST 2013
            finished: Tue Jan 22 17:52:10 JST 2013
              status: FAILURE
          residentOn: com.xensource.xenapi.Host@4a3215c0
            progress: 1.0
                type: <none/>
              result:
errorInfo: [INTERNAL_ERROR, xenopsd internal error: VM =
86cff6d0-4584-a8ca-b3ff-192cc699e23d; domid = 21; Bootloader.Bad_error
Traceback (most recent call last):
File "/usr/bin/eliloader", line 945, in ?
    sys.exit(main())
  File "/usr/bin/eliloader", line 935, in main
    handle_first_boot(vm, img, args, other_config)
  File "/usr/bin/eliloader", line 756, in handle_first_boot
    kernel, ramdisk = rhel_first_boot_handler(vm, repo_url)
  File "/usr/bin/eliloader", line 518, in rhel_first_boot_handler
    fetchFile(vmlinuz_url, vmlinuz_file)
  File "/usr/bin/eliloader", line 320, in fetchFile
    shutil.copyfileobj(fd, fd_dest)
  File "/usr/lib/python2.4/shutil.py", line 22, in copyfileobj
    buf = fsrc.read(length)
IOError: [Errno 5] Input/output error
]
         otherConfig: {}
           subtaskOf: com.xensource.xenapi.Task@aaf13f6f
            subtasks: []


        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.checkForSuccess(CitrixR
esourceBase.java:3140)
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.startVM(CitrixResourceB
ase.java:3252)
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceB
ase.java:1303)
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixRe
sourceBase.java:487)
        at
com.cloud.hypervisor.xen.resource.XenServer56Resource.executeRequest(XenServ
er56Resource.java:55)
        at
com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:
192)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at
java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$
101(ScheduledThreadPoolExecutor.java:165)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Sch
eduledThreadPoolExecutor.java:266)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:11
10)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:6
03)
        at java.lang.Thread.run(Thread.java:679)


Thanks again.
Zaw

-----Original Message-----
From: Pranav Saxena [mailto:pranav.saxena@citrix.com] 
Sent: Tuesday, January 22, 2013 6:25 PM
To: cloudstack-users@incubator.apache.org
Subject: RE: Regarding system vm issue under instances of CPlatform

Hey Zaw , 

You got to share the management server logs . Without seeing the exception
stack trace , I can't suggest anything . The error which you are getting
here "Unable to create a deployment for VM ..." would have  thrown an
exception . It could be because of several reasons.  

PS: It's always a good practice to trace the logs and share them whenever
you run into such issues.

Thanks,
Pranav

-----Original Message-----
From: FIP)ゾーミョーテッ [mailto:fj6562ib@aa.jp.fujitsu.com] 
Sent: Tuesday, January 22, 2013 2:49 PM
To: cloudstack-users@incubator.apache.org
Subject: Regarding system vm issue under instances of CPlatform

Hi Pranav,

 

How are you doing? Hope you are doing great.

Can you please do me a favour for one thing? We are facing the following
issue when we create new vm with centos version6.0 under instances of
CPlatform but don’t have an issue with centos version 6.2.

 

----------------------------------------------------------------------------
---------------------------------------------------

Unable to create a deployment for VM[User|file name]

----------------------------------------------------------------------------
---------------------------------------------------

Please share an information who have an experience regarding the above
error.

 

Regards,

Zaw

 



Mime
View raw message