cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Junpei Tsutsui <junpei.tsut...@gmail.com>
Subject Re: Exception in CS4 usage server
Date Sun, 02 Dec 2012 04:37:11 GMT
Thanks!
The workaround works fine and I can get usage records with cloudmonkey.

I hope this bug will be fixed on 4.0.1.

Junpei

On Fri, Nov 30, 2012 at 1:48 AM, David Nalley <david@gnsa.us> wrote:

> On Thu, Nov 29, 2012 at 11:13 AM, Johann Hoehn
> <johann.hoehn@ecommerce.com> wrote:
> > On 11/24/2012 10:53 PM, Junpei Tsutsui wrote:
> >>
> >> Hi,
> >>
> >> I installed CloudStack 4.0.0 following the installation guide and
> >> instances
> >> are running well on it.
> >> I 'm using CentOS 6.3 for management server and XenServer 6.0.2 for
> >> compute
> >> nodes.
> >>
> >> Then, I installed usage server on the management server by "yum install
> >> cloud-usage" and run it.
> >> But the usage job failed due to a SQL error.
> >>
> >>
> >> [Alerts]
> >> Usage job failed. Job id: 1 25 Nov 2012 03:13:00
> >>
> >> [usage.log]
> >> 2012-11-25 03:13:00,154 ERROR [cloud.usage.UsageManagerImpl]
> >> (Usage-Job-1:null) Exception in usage manager
> >> com.cloud.utils.exception.CloudRuntimeException: DB Exception on:
> >> org.apache.commons.dbcp.DelegatingPreparedStatement@5b5a5cf
> >> Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException:
> >> Unknown column 'account.default_zone_id' in 'field list'
> >>
> >> The usage server tried to get "account.default_zone_id" from
> "cloud_usage"
> >> database, but the "account" table doesn't have "default_zone_id" column.
> >>
> >>
> >> I found a same issue for CloudStack 3.0.3 in bug tracker but it's
> already
> >> closed.
> >> http://bugs.cloudstack.org/browse/CS-15170
> >>
> >> Anyone could run usage server well on 4.0.0?
> >>
> >> Thanks,
> >> Junpei
> >>
> > Hi,
> >
> > I also have a fresh install of 4.0.0 and the bug was still there.  I
> added
> > the table and now waiting for usage parser to rerun to verify it is fully
> > fixed.
> >
> >
> > --johann
>
> The workaround for this is executing the following on the cloud_usage
> database:
>
> ALTER TABLE `cloud_usage`.`account` ADD COLUMN `default_zone_id`
> bigint unsigned;
>
> I've filed a blocker bug for 4.0.1 to fix this issue:
> https://issues.apache.org/jira/browse/CLOUDSTACK-560
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message