cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Ottonello <aottone...@gmail.com>
Subject Re: Trying to setup Cloudstack 4.0.0
Date Tue, 18 Dec 2012 10:17:57 GMT
Xen host has no dpkg neither apt-get functions, is a XCP (XenServer) OS,
not Ubuntu...


2012/12/18 Sebastien Goasguen <runseb@gmail.com>

> xen host
>
> On Dec 18, 2012, at 11:10 AM, Andrea Ottonello <aottonello@gmail.com>
> wrote:
>
> > Sorry: for "agent" which machine do you mean? Management/NFS or Xen host?
> >
> >
> > 2012/12/18 Sebastien Goasguen <runseb@gmail.com>
> >
> >> Andrea,
> >>
> >> Looks like your secondary storage is /export/secondary
> >> You should mount it on your xen hosts and make sure the mount works.
> >>
> >> If you have downloaded the systemvm template and pointed to
> >> /export/secondary that should be fine.
> >>
> >> You should check the logs at
> >> /var/log/cloud/management/management-server.log
> >> And tells us what the error is.
> >>
> >> That said, I have a feeling you might be running into an issue with the
> >> agent. I had issues with the Ubuntu setup using the deb packages, I ran
> >> into this bug https://issues.apache.org/jira/browse/CLOUDSTACK-460
> >> It is fixed for the 4.0.1 release but not yet in the packages.
> >>
> >> Try to:
> >> wget
> >>
> http://cloudstack.apt-get.eu/ubuntu/dists/precise/4.0/pool/cloud-system-iso_4.0.0-incubating_amd64.deb
> >> then:
> >> dpkg -i cloud-system-iso_4.0.0-incubating_amd64.deb
> >>
> >> and restart the agent:
> >> service cloud-agent restart
> >>
> >> Finally try to restart the system VMs.
> >>
> >> Cheers,
> >>
> >> -Sebastien
> >>
> >> On Dec 18, 2012, at 10:01 AM, Andrea Ottonello <aottonello@gmail.com>
> >> wrote:
> >>
> >>> Yes. During my many installations,I tried both, compiling from source
> >> code
> >>> using maven3 or using public repository. I also launched
> >>> cloud-setup-management command, missing from guide for first management
> >>> server. And downloading template VM tells successfull, I can see it in
> >>> /export/secondary/tmp/1/1/ (I have my secondary storage on same
> server).
> >> A
> >>> doubt: should I anyway mount secondary storage in /mnt/secondary even
> if
> >> is
> >>> on local machine when downloading the template? I used -m
> >>> /export/secondary/ parameter for tmplt script...
> >>>
> >>>
> >>> 2012/12/18 Sebastien Goasguen <runseb@gmail.com>
> >>>
> >>>> Did you use the deb packages ?
> >>>>
> >>>>
> >>>> On Dec 18, 2012, at 9:19 AM, Andrea Ottonello <aottonello@gmail.com>
> >>>> wrote:
> >>>>
> >>>>> Hallo all.
> >>>>> I'm completely new to Linux and Cloudstack (but comfotable to
> >>>> hypervisors,
> >>>>> SAN, storage and clusters), I'm trying to setup Cloudstack using
XCP
> as
> >>>>> hosts. I've configured correctly a XEN pool of 2 hosts, with a
> primary
> >>>>> storage. It works, I succesfully installed a VM on it.
> >>>>> Now, on another hypervisor (Hyper-V) I'm trying to setup the
> Cloudstack
> >>>>> 4.0.0 managemente server on Ubuntu 12.04. I've followed installation
> >>>> guide
> >>>>> (searched for and solved some "wrong/missing" instructions, for
> example
> >>>> how
> >>>>> to open NFS ports on Ubuntu) setting NFS primary and secondary
> storage
> >> on
> >>>>> management itself.
> >>>>> Setup is successfully, I can logon to GUI, but I'm not able to setup
> a
> >>>> zone
> >>>>> because guided process hangs during "Creating system VMs (this can
> >> take a
> >>>>> while)". I left it running for more than 24 hours, nothing. I
> >> reinstalled
> >>>>> from scratch many times. System template is correctly downloaded
for
> >>>>> XenServer: I tried also without the wizard, creating zone/pod etc.
> from
> >>>>> standard GUI, but when I go to System VMs they are in "starting"
> state,
> >>>>> after a while they go in stopped and when I try strating them it
> fails.
> >>>>> Always same problem. I'm getting crazy, any idea?
> >>>>>
> >>>>> --
> >>>>> Andrea Ottonello
> >>>>
> >>>>
> >>>
> >>>
> >>> --
> >>> Andrea Ottonello
> >>
> >>
> >
> >
> > --
> > Andrea Ottonello
>
>


-- 
Andrea Ottonello

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message