cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siyuan Tian <tiansiy...@gmail.com>
Subject Re: Documentation translation
Date Sat, 08 Dec 2012 02:36:22 GMT
I found a way to solve the word breaks at line ends in created pdf is to
turn off "hyphenate" in /usr/share/publican/xsl/pdf.**xsl

Change:

<xsl:param name="hyphenate">true</xsl:**param>

to:

<xsl:param name="hyphenate">false</xsl:**param>

Cheers,

Tian

On Thu, Nov 29, 2012 at 8:54 PM, Siyuan Tian <tiansiyuan@gmail.com> wrote:

> Sebastien,
>
> It works. The pdf files are created.
>
> I had a glance through the pdf files, there are too many word breaks at
> line ends. I do find such word breaks in the pdf files I get from
> http://incubator.apache.org/cloudstack/docs/en-US/index.html
>
> Thanks a lot,
>
> Tian
>
>
> On Thu, Nov 29, 2012 at 3:42 PM, Sebastien Goasguen <runseb@gmail.com>wrote:
>
>> Siyuan,
>>
>> Here is how I build the docs with publican:
>>
>> cd docs
>>
>> cp -R /usr/share/publican/Common_Content Common_Content
>>
>> cp -R publican-cloudstack Common_Content/cloudstack
>>
>> publican build --config=publican-adminguide.cfg --formats=pdf
>> --langs=en-US --common_content=./Common_Content
>>
>> That's from memory, you may have to tweak the location of the
>> Common_Content directory.
>>
>> Pick the guide that you want to build (different *.cfg file)
>>
>> The resulting pdf will be in /docs/tmp directory
>>
>> Hope that helps,
>>
>> -Sebastien
>>
>>
>> On Nov 29, 2012, at 6:21 AM, Siyuan Tian <tiansiyuan@gmail.com> wrote:
>>
>> > Hi Sebastien,
>> >
>> > Nice blog!
>> >
>> > I have some issue with publican on docs directory in git.
>> >
>> > I have the updated git checkout and follow the steps in README.txt.
>> >
>> > I installed publican on my Ubuntu 12.10 via
>> >
>> >     sudo apt-get install publican
>> >
>> > The version installed is 2.8
>> >
>> > Then I try to run
>> >
>> >    publican build --formats test --langs en-US
>> >
>> > I get
>> >
>> > "Config file not found: publican.cfg. Perhaps you need to run 'publican
>> > old2new' at /usr/bin/publican line 647"
>> >
>> > I try
>> >
>> >   publican old2new
>> >
>> > and get
>> >
>> > "Cannot open Makefile for reading: no such file or directory at
>> > /usr/bin/publican line 493"
>> >
>> > I try again with
>> >
>> >    publican build --config=publican-all.cfg --formats test --langs en-US
>> >
>> > I get
>> >
>> > "Failed to load brand file:
>> > /usr/share/publican/Common_Content/cloudstack/publican.cfg at
>> > /usr/bin/publican line 647"
>> >
>> > It seems the README.txt file is out of date. At the beginning of it, it
>> > says:
>> >
>> > "...
>> > Updated: August 8, 2012
>> > ...
>> > The files are currently incomplete as we are in the process of
>> converting
>> > documentation from an outdated file format into XML files for this repo.
>> > "
>> >
>> > Thanks,
>> >
>> > Tian
>> >
>> > On Wed, Nov 28, 2012 at 11:26 PM, Sebastien Goasguen <runseb@gmail.com
>> >wrote:
>> >
>> >> Hi folks,
>> >>
>> >> I just posted a blog on how to help translate the documentation using
>> >> Transifex:
>> >>
>> >>
>> >>
>> http://sebgoa.blogspot.ch/2012/11/translating-apache-cloudstack-docs-with.html
>> >>
>> >> We need tooonnnns of help !!
>> >>
>> >> -Sebastien
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message