cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim L." <j...@pobox.com>
Subject SOLUTION FOUND: Unable to build Cloudstack 4.0 with VMWare Enabled
Date Thu, 20 Dec 2012 01:30:58 GMT
I reviewed the logs and noticed a couple of things:


The vmware-cloud-base jar file in the local repo was never built correctly;
I performed the following commands to correct the problem:

*cd /vmware-base*
*mvn install*

This corrected the problem with the build for cloud-vmware-base jar file.
 Now the following commands work:

*mvn clean -Dnonoss install*


Also:
The manageontap.jar file was also not correct in the local repo; the
deps/install-non-oss.sh script did not install it correctly.




On Wed, Dec 19, 2012 at 2:28 PM, Jim L. <jiml@pobox.com> wrote:

> Hi,
>
> Following the instructions from:
>
> Chapter 3 from the Cloudstack 4.0 Installation Guide;
>
> https://cwiki.apache.org/CLOUDSTACK/building-with-maven.html;
>
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Hypervisor+VMWare;
>
>
> http://mail-archives.apache.org/mod_mbox/incubator-cloudstack-dev/201212.mbox/%3C35F04D4C394874409D9BE4BF45AC5EA9010B2807B6B0@BANPMAILBOX01.citrite.net%3E
>
> I attempted to build Cloudstack 4.0.0 with vmware enabled using the
> following commands:
>
>
> *mvn -P deps*
> *mvn clean*
> *mvn -P vmware install -e*
>
>
> What I get is the following error:
>
> *Failed to execute goal on project cloud-plugin-hypervisor-vmware: Could
> not resolve dependencies for project
> org.apache.cloudstack:cloud-plugin-hypervisor-vmware:jar:4.0.0-incubating-SNAPSHOT:
> *
> *
> *
> *Caused by: org.apache.maven.project.DependencyResolutionException: Could
> not resolve dependencies for project
> org.apache.cloudstack:cloud-plugin-hypervisor-vmware:jar:4.0.0-incubating-SNAPSHOT:
> Failure to find
> org.apache.cloudstack:cloud-vmware-base:jar:4.0.0-incubating-SNAPSHOT in
> http://repository.apache.org/snapshots was cached in the local
> repository, resolution will not be reattempted until the update interval of
> apache.snapshots has elapsed or updates are forced*
>
>
> In my ~/.m2/repository/com/cloud/com/vmware directory, I have three files:
> vmware-apputils, vmware-vim, vmware-vim25
>
>
> I just want to build the vmware plug-in, because there are other problems
> with using -Dnonoss involving the netapp plug-in (even though I have the
> required manageontap.jar file).
>
>
> Can anyone help/show me how to build Cloudstack 4.0 with vmware enabled?
> This is turning out to be an incredibly frustrating exercise.
>
>
>
> Thanks -- Jim L.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message