cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Jiang <alex.jiang....@gmail.com>
Subject [Help] Use Ceph RBD as primary storage in CloudStack
Date Tue, 13 Nov 2012 05:32:58 GMT
Hi, All

Has somebody used Ceph RBD in CloudStack as primary storage? I see that in
the new features of CS 4.0, RBD is supported for KVM. So I tried using RBD
as primary storage but met with some problems.

I use a CentOS6.3 server as host. First I erase the qemu-kvm(0.12.1) and
libvirt(0.9.10) because their versions are too low (Qemu on the Hypervisor
has to be compiled with RBD enabled .The libvirt version on the Hypervisor
has to be at least 0.10 with RBD enabled).Then I download the latest
qemu(1.2.0) and libvirt(1.0.0) source code and compile and install them.
But when compiling qemu source code,
#wget http://wiki.qemu-project.org/download/qemu-1.2.0.tar.bz2
#tar jxvf qemu-1.2.0.tar.bz2
# cd qemu-1.2.0
# ./configure --enable-rbd

the following errors occur:
ERROR: User requested feature rados block device
ERROR: configure was not able to find it

But on Ubuntu12.04 I tried compiling qemu source code and succeed.Now I am
very confused.How to use Ceph RBD as primary storage in CloudStack on
CentOS6.3?Anyone can help me?

Best Regards,

 Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message