cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edison Su <Edison...@citrix.com>
Subject RE: Cloudstack 4 (Incubating) not working
Date Tue, 20 Nov 2012 18:37:19 GMT


> -----Original Message-----
> From: Christoffer Pedersen [mailto:vrod@vrod.dk]
> Sent: Tuesday, November 20, 2012 2:04 AM
> To: cloudstack-users@incubator.apache.org
> Subject: Cloudstack 4 (Incubating) not working
> 
> Hello there,
> 
> 
> 
> I am trying to set up a Cloudstack version 4.0.0 based (Incubating)
> infrastructure. I have 1 management-server hosted on a ESXi5-hypervisor as
> a VM, and 2 physical hypervisors. All systems are Ubuntu 12.04.
> 
> 
> 
> The hypervisors should access the Primary storage through a 4Gbit
> FibreChannel setup through HBA's which i have setup and works. All the ISO's
> are placed on a NFS-server which is also setup and works.
> 
> 
> 
> I have followed the official install guide for CS4 (Incubating) but after the
> installation was done, i could not access the user interface (simply gave me a
> tomcat error). After a reboot of the management server, i could now see the
> UI, but not login. I looked in the management server log, and found this:
> 
> 
> 
> 2012-11-20 10:23:12,937 DEBUG [utils.script.Script] (main:null) Executing:
> sudo keytool -genkey -keystore /etc/cloud/management/cloud.keystore
> -storepass vmops.com -keypass vmops.com -keyalg RSA -validity 3650 -
> dname cn="Cloudstack User",ou="<deleted>",o="<deleted>",c="Unknown"
> 
> 2012-11-20 10:23:12,953 DEBUG [utils.script.Script] (main:null) Exit value is 1
> 
> 2012-11-20 10:23:12,954 DEBUG [utils.script.Script] (main:null) sudo: no tty
> present and no askpass program specifiedSorry, try again.sudo: no tty
> present and no askpass program specifiedSorry, try again.sudo: no tty
> present and no askpass program specifiedSorry, try again.sudo: 3 incorrect
> password attempts
> 
> 
> 
> I then tried to add "Defaults visiblepw" to my /etc/sudoers file, but now i get
> this:

Do you run cloud-setup-management before start management server, the " requiretty " in /etc/sudoers
should be removed.

> 
> 
> 
> 2012-11-20 10:41:55,761 DEBUG [utils.script.Script] (main:null) Executing:
> sudo keytool -genkey -keystore /etc/cloud/management/cloud.keystore
> -storepass vmops.com -keypass vmops.com -keyalg RSA -validity 3650 -
> dname cn="Cloudstack User",ou="<deleted>",o="<deleted>",c="Unknown"
> 
> 2012-11-20 10:42:00,774 WARN  [utils.script.Script] (Script-1:null) Interrupting
> script.

It seems timeout when running above command. Can you manually execute above command?

> 
> 
> 
> The UI is not reachable anymore, even though the tomcat service is still
> listening on that port. I followed the guide exactly as you should and this is
> the second time I try. Any ideas?
> 
> 
> 
> - Chris
> 
> 
> 
> 


Mime
View raw message