cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Cross" <bcr...@nodetx.com>
Subject RE: Centos 6.3 new install sql connection issue
Date Sun, 25 Nov 2012 03:52:00 GMT
Rohit, thank you. Here's the answers to those questions. 

> No, you run cloud-setup-management only once after deploying or
setting up the database.
In that case, I have done it correctly it appears, because I am running
the database deploy cmd first, and then later after setting up the NFS
mounts, as the final step before attempting to log into the UI, I run
cloud-setup-management

> Looking at your logs, are you running your mgmt server and mysql
server on the same server,  192.168.2.220?

Yes,  I am running them both on the same server which is 192.168.2.220

> In case, checklist:
> 0. You deployed database using correct IP, username and password.
> 1. Are you able to reach the mysql server and it is running either on
localhost or the correct host IP.
> 2. MySql server is running on its default port, 3306, if not make sure
you specify custom port while setting up database see 3. Also, the port
is not blocked, check iptables.
> 3. You have used correct CloudStack deployment procedure:

 The exact cmd I'm deploying with is "cloud-setup-databases
cloud:cloud@localhost --deploy-as=root:12345"
 mysql appears to be running on the default port 3306. I also went ahead
and opened 3306 in iptables and reran the cloud setup database deploy
and setup management commands, but still have been able to log in to the
UI...
Since I'm running mysql on localhost, the documentation skips opening
the port 3306 in iptables but I went ahead and did the command anyway
just in case here.
I'm also able to log into mysql as both cloud, and root, locally, and
remotely. When logging in, I'm able to show the database tables, so I
know I'm in the right place.

> a. Change (append or search and update) the following values in
/etc/my.cnf or /etc/mysql/my.cnf:
> innodb_rollback_on_timeout=1
> innodb_lock_wait_timeout=600
>  max_connections=350
> log-bin=mysql-bin
> binlog-format = 'ROW'

 Yes that has been appended into my my.cnf file

> b. Deploy database: (localhost or custom IP or resolvable domain)
cloud-setup-databases cloud:<dbpassword>@localhost
--deploy-as=root:<password>

as above, I've run that command successfully

> c.Finally setup CloudStack, the following configures CloudStack mgmt
server with appropriate settings:
> cloud-setup-management

Yes, I've also run that command successfully

> 4. Set SELinux to permissive:
> setenforce permissive

> Yup, I did that after receiving the errors while deploying the cloud
database

> 5. You're using MySQL server 5.1.58 or above.

I'm running Server version: 5.1.66


>  Hope this helps.


________________________________________
From: Brandon Cross [bcross@nodetx.com]
Sent: Sunday, November 25, 2012 4:37 AM
To: cloudstack-users@incubator.apache.org
Subject: RE: Centos 6.3 new install sql connection issue

Should I run cloud-setup-management before deploying the databases? I
have to run cloud-setup-management upon each reboot, or the UI will not
load to give me a login prompt on my web browser at
http://server-ip:8080/client

-Brandon Cross, MCSE
President, NODE LLC
309 Breesport
San Antonio, TX 78216
Skype ID: NODETX
Office Phone: (210)319-4382 Ext 102
WWW.NODETX.COM





-----Original Message-----
From: sebgoa [mailto:runseb@gmail.com]
Sent: Saturday, November 24, 2012 5:04 PM
To: cloudstack-users@incubator.apache.org
Subject: Re: Centos 6.3 new install sql connection issue

Brandon, can you try running cloud-setup-management on the mgt server.

I believe you are running in a doc bug.

-Sebastien


On Nov 24, 2012, at 11:58 PM, Brandon Cross wrote:

> Rohit, thanks for replying. The logfile can be located here:
>
> http://www.nodetx.com/management-server.log
>
> -Brandon Cross
>
> -----Original Message-----
> From: Rohit Yadav [mailto:rohit.yadav@citrix.com]
> Sent: Saturday, November 24, 2012 4:48 PM
> To: cloudstack-users@incubator.apache.org
> Subject: RE: Centos 6.3 new install sql connection issue
>
> Brandon, I'm not sure what exactly is the issue, can you share the 
> logs somewhere?
> Also, can you try with a different MySQL server version? There was a 
> global lock bug in mysql long ago, but guess should not be an issue
now.
>
> Lastly, you may try with a MySQL server setup on a different machine 
> (possibly a different distro/environment) and deploy database 
> (cloud-setup-database).
>
> Regards.
>
> ________________________________________
> From: Brandon Cross [bcross@nodetx.com]
> Sent: Sunday, November 25, 2012 4:03 AM
> To: cloudstack-users@incubator.apache.org
> Subject: RE: Centos 6.3 new install sql connection issue
>
> Ok I tried several more times and I consistently get the same
result...
> UI comes up, and I cannot log in.
>
> I shot a video to demonstrate what I'm doing:
>
> http://www.youtube.com/watch?v=9aYbPEWduIY
>
> The sequence of commands I'm using is here:
>
> http://pastebin.com/B0LJJtVL
>
> -Brandon Cross


Mime
View raw message