cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Cross" <bcr...@nodetx.com>
Subject installation question
Date Sat, 24 Nov 2012 15:45:18 GMT
I'm reinstalling on Cent 6.3

 

In the installation guide, 

http://incubator.apache.org/cloudstack/docs/en-US/Apache_CloudStack/4.0.
0-incubating/html/Installation_Guide/sect-source-buildrpm.html

 

Section 3.6 says to run 'mvn -P deps' which I can do successfully

 

Then it wants me to run './waf rpm' which fails to build successfully on
some ant error... I can get more specific if needed.

 

If I skip the rpm build, the next step says to configure my new YUM
repository (Step 3.6.2)

 

At /etc/yum.repos.d/cloudstack.repo

 

I add this code:

 

[apache-cloudstack]

name=Apache CloudStack

baseurl=http://webserver.tld/path/to/repo

enabled=1

gpgcheck=0

 

 

Except for my base URL path, I went to the downloads page of the
cloudstack incubator and found the RPM package repo linked on this page

http://incubator.apache.org/cloudstack/downloads.html

 

[apache-cloudstack]

name=Apache CloudStack

baseurl=http://cloudstack.apt-get.eu/rhel/4.0/

enabled=1

gpgcheck=0

 

When I do that, and then 'yum install cloud-client' I'm able to obtain
what appears to be the correct stuff. I just need to know - is it ok for
me to use that repo (the rpm's at cloudstack), and not successfully run
the './waf rpm' or do I have to still build the rpm's anyway?

 

-Brandon Cross

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message