cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Cross" <>
Subject Centos 6.3 new install sql connection issue
Date Fri, 23 Nov 2012 04:01:27 GMT
Hi all, I'm new here, but dedicated to becoming a contributor and
excited about Cloudstack. I'm trying to deploy it on a CentOS 6.3
management node. I was able to get it deployed with Ubuntu but I'm
having a challenge with CentOS that must be something super trivial
that's missing...


My problem is, after I complete the steps 3 and 4 in the installation
guide, I am unable to log in using admin and password. This only applies
to when I set it up using CentOS. I was successful in building it on
Ubuntu 12.04 and logging in, however I really want to run CentOS. Do I
need to roll back to 6.2 ?


I think the problem looks like a database connectivity error. When I
look at the management-server.log I see  


2012-11-22 05:11:34,217 ERROR [db.Transaction.Transaction] (main:null)
Unexpected exception:

Could not create connection to database server. Attempted reconnect 3
times. Giving up.

Caused by: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException:
Communications link failure

2012-11-22 05:11:34,223 ERROR [utils.db.DbUtil] (main:null) Unable to
acquire DB connection for global lock system

2012-11-22 05:11:34,230 ERROR [utils.component.ComponentLocator]
(main:null) Problems with running checker:DatabaseIntegrityChecker Unable to acquire lock
to check for database integrity.


A snippet of the management-server.log is here


I'm able to get to the UI login, but it just won't accept my password.
I've tried making sure remote mysql connections are enabled. One
interesting thing I've come across is how I'm crafting my
cloud-setup-databases command.


When I run it like this, it fails:


cloud-setup-databases cloud:cloud@


but when I change the IP to localhost then it appears to deploy
successfully without errors, and builds the mysql. I've even logged in
and looked and found the admin username and encrypted password in the
table structure.


cloud-setup-databases cloud:cloud@localhost --deploy-as=root:'rootpwd'


my.cnf looks like this:






# Disabling symbolic-links is recommended to prevent assorted security







I've also pasted my /var/log/mysqld.log here


Any tips?



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message