cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@citrix.com>
Subject RE: Blank page after login on CloudStack 4.0
Date Fri, 09 Nov 2012 14:28:53 GMT
Hi Gaëtan, thanks for reporting the bug. Can you open an issue on https://issues.apache.org/jira/browse/CLOUDSTACK
We need to properly escape the language files or fix the way we use strings in javascript
files for the UI.

Regards.
________________________________________
From: Gaëtan Allart [gaetan@nexylan.com]
Sent: Friday, November 09, 2012 1:36 PM
To: cloudstack-users@incubator.apache.org
Subject: Re: Blank page after login on CloudStack 4.0

rm
/usr/share/cloud/management/webapps/client/WEB-INF/classes/resource/message
s_fr_FR.properties

Did solve this issue. Page is not blank anymore. I think languages files
need reviewing.

Gaëtan




Le 09/11/12 09:02, « Gaëtan Allart » <gaetan@nexylan.com> a écrit :

>I found out the issue :
>
>'message.action.enable.physical.network': 'Confirmer l'activation de ce
>réseau physique.',Uncaught SyntaxError: Unexpected identifier
>
>This is due to french language. "quotes" are not protected.
>(l'activation).
>
>
>
>Gaëtan
>
>
>
>
>Le 09/11/12 07:33, « Musayev, Ilya » <imusayev@webmd.net> a écrit :
>
>>BTW, the FF Version 14.0.1 at home on Win7 is almost OK. The page loads
>>but I do get occasional STATUS pop up in UI with no content and all I
>>have to do - is press Close.. the same happens on IE 8.0 - except its
>>much worse. The initial page after I login is loaded, but when I attempt
>>to do an operation that requires a drill down of several screens like
>>deploy instance, I will get a warning STATUS window with no content and
>>just a CLOSE button.
>>
>>Once IE had a warning at the bottom and when I look for the error
>>details, it points to jquery.js, line 742.
>>
>>I've downloaded jquery.js version 1.6.2 and 1.6.3 (CS4 is using 1.6.1)
>>and it did not help and actually made it worse in some cases so I rolled
>>back,
>>
>>
>>When I attempted to deploy an instance IE warning displayed following
>>
>>Webpage error details
>>
>>User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64;
>>Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR
>>3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; MS-RTC LM 8;
>>.NET4.0E; .NET CLR 1.1.4322)
>>Timestamp: Fri, 9 Nov 2012 06:27:37 UTC
>>
>>
>>Message: 'networkOfferingObjs' is undefined
>>Line: 363
>>Char: 9
>>Code: 0
>>URI:
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/instanceWizar
>>d
>>.js?t=1352442366387
>>
>> IE on Win7 in my case is very unstable.
>>
>>-----Original Message-----
>>From: Musayev, Ilya [mailto:imusayev@webmd.net]
>>Sent: Friday, November 09, 2012 1:17 AM
>>To: cloudstack-users@incubator.apache.org
>>Subject: RE: Blank page after login on CloudStack 4.0
>>
>>Got home, VPNd in and attempted to use CloudStack 4 at work.
>>
>>I have the same blank page :(
>>
>>Inspect Element console page shows these errors. I'm on Chrome Version
>>22.0.1229.94 m on Win7. At work, I run CentOS 6.2 as my desktop and have
>>no issues at on FF or Chrome.
>>
>>GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/jquery.cookies.js
>>505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/excanvas.js 505
>>(HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>c
>>rosshair.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>f
>>illbetween.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>i
>>mage.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>n
>>avigate.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>p
>>ie.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>r
>>esize.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>s
>>tack.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/core.js?t=
>>1
>>352436608092 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/lib/flot/jquery.flot.
>>s
>>ymbol.js 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/utils.js?t
>>=
>>1352436608092 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/events.js?
>>t
>>=1352436608092 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/dialog.js?
>>t
>>=1352436608092 505 (HTTP Version Not Supported) :8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/widgets/mu
>>l
>>tiEdit.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/widgets/ov
>>e
>>rlay.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/widgets/da
>>t
>>aTable.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/widgets/cl
>>o
>>udBrowser.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1558 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui/widgets/li
>>s
>>tView.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1558 Uncaught ReferenceError: cloudStack is not defined
>>treeView.js:144 Uncaught TypeError: Cannot read property 'ui' of
>>undefined notifications.js:262 Uncaught ReferenceError: cloudStack is not
>>defined tagger.js:231 Uncaught ReferenceError: cloudStack is not defined
>>sharedFunctions.js:223 Uncaught ReferenceError: cloudStack is not defined
>>login.js:132 Uncaught ReferenceError: cloudStack is not defined
>>projects.js:737 Uncaught ReferenceError: cloudStack is not defined
>>cloudStack.js:427 Uncaught ReferenceError: cloudStack is not defined
>>lbStickyPolicy.js:314 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/installWizard
>>.
>>js?t=1352436608092 505 (HTTP Version Not Supported) :8080/client/:1560
>>Uncaught ReferenceError: cloudStack is not defined zoneChart.js:419
>>Uncaught ReferenceError: cloudStack is not defined dashboard.js:192 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui-custom/ins
>>t
>>allWizard.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1560 Uncaught ReferenceError: cloudStack is not defined
>>projects.js:1099 Uncaught ReferenceError: cloudStack is not defined
>>dashboard.js:307 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/instanceWizar
>>d
>>.js?t=1352436608092 505 (HTTP Version Not Supported) :8080/client/:1560
>>Uncaught ReferenceError: cloudStack is not defined instanceWizard.js:892
>>Uncaught ReferenceError: cloudStack is not defined instances.js:1330
>>Uncaught ReferenceError: cloudStack is not defined events.js:156 Uncaught
>>ReferenceError: cloudStack is not defined ipRules.js:164 Uncaught
>>ReferenceError: cloudStack is not defined enableStaticNAT.js:168 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/network.js?t=
>>1
>>352436608092 505 (HTTP Version Not Supported) :8080/client/:1560 Uncaught
>>ReferenceError: cloudStack is not defined securityRules.js:73 Uncaught
>>ReferenceError: cloudStack is not defined vpc.js:904 Uncaught
>>ReferenceError: cloudStack is not defined vpc.js:2178 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui-custom/upl
>>o
>>adVolume.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1560 Uncaught ReferenceError: cloudStack is not defined
>>recurringSnapshots.js:213 Uncaught ReferenceError: cloudStack is not
>>defined storage.js:1362 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui-custom/phy
>>s
>>icalResources.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1560 Uncaught ReferenceError: cloudStack is not defined
>>templates.js:1329 Uncaught ReferenceError: cloudStack is not defined
>>accounts.js:1173 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/ui-custom/zon
>>e
>>Wizard.js?t=1352436608092 505 (HTTP Version Not Supported)
>>:8080/client/:1560 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/system.js?t=1
>>3
>>52436608092 505 (HTTP Version Not Supported) :8080/client/:1560 Uncaught
>>ReferenceError: cloudStack is not defined configuration.js:1946 Uncaught
>>ReferenceError: cloudStack is not defined globalSettings.js:175 GET
>>http://cloud04t-ops-08.portal.webmd.com:8080/client/scripts/domains.js?t=
>>1
>>352436608092 505 (HTTP Version Not Supported) :8080/client/:1560 Uncaught
>>ReferenceError: cloudStack is not defined
>>
>>-----Original Message-----
>>From: Brian Federle [mailto:Brian.Federle@citrix.com]
>>Sent: Thursday, November 08, 2012 1:23 PM
>>To: 'cloudstack-users@incubator.apache.org'
>>Subject: RE: Blank page after login on CloudStack 4.0
>>
>>Hello,
>>
>>If you have Firebug installed (or web inspector for Chrome), see if you
>>can access the 'Console' tab. Most likely what you are experiencing is
>>some JavaScript error (might be due to malformed JS during installation),
>>which is causing the rest of the page to be blank. The console view
>>should give you any errors in red.
>>
>>If you see anything, post it here and I can let you know if there is a
>>fix for it.
>>
>>Thanks,
>>Brian
>>
>>-----Original Message-----
>>From: Gaëtan Allart [mailto:gaetan@nexylan.com]
>>Sent: Thursday, November 08, 2012 8:59 AM
>>To: cloudstack-users@incubator.apache.org
>>Subject: Blank page after login on CloudStack 4.0
>>
>>Hi everyone,
>>
>>I've just installed CloudStack on Ubuntu (following every step of
>>documentation).
>>
>>Therefore, when trying to login, I'm getting a blank page. No errors in
>>logs.
>>Moreover, when looking at the source code of the page, HTML code is
>>present.
>>
>>Any idea what I might have done wrong?
>>
>>Thanks,
>>
>>Gaëtan
>>
>>
>>
>>


Mime
View raw message