cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bruc...@v365.com.au
Subject Re: Primary Storage
Date Tue, 23 Oct 2012 06:26:47 GMT
  

Hi

yes we had the same prob on GFS 3.3 on Ubuntu 10.04 using SRP
we could not get SRP to work well, very inconstant, always drops or
fails. Even IPOIB was faulty. we also tried 12.04, same deal.

We didn't
get to the point of using ZFS with GFS, as we tried it on OpenIndiana
and it was very slow. only 2-3GB/s on infiniband. 

We then tried ZFS on
Ubuntu and it was slow there also. So gave up on ZFS until it matures
more, and is part of Kernel , and we felt the same for GFS, needs to
mature more, and resolve infiniband RDMA issues. 

Wed be interested to
work on it long term though.

Cheers
Bruce M

On 23.10.2012 14:18, Bryan
Whitehead wrote:
>> I have installed GlusterFS direct on Solaris with a
modified code.
>> Want you build bigger systems for more then 50 VMs it
is better you split the Solaris and GlusterFS with a separte headnode
for GlusterFS
>>
>> That looks like:
>> Solaris ZFS Backendstorage with
a dataset Volume (Thin Provision) --> ( SRP Target attached direct
without Infiniband switch to GF Node) --> GlusterFS Node the srp target
formatted with xfs filesystem, create a GlusterFS Volume --> (
Infiniband over a Mellanox Port Switch) --> Cloudstack Node mount
glusterFS Volume over RDMA
> 
> What version of glusterfs are you
running? I've had difficulty getting
> native rdma working in the
3.2/3.3 series.
> 
> -Bryan

 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message