cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <Ahmad.Emne...@citrix.com>
Subject Re: CS 4 Trial - CloudStack-oss-4.0.0-524.tar
Date Tue, 16 Oct 2012 00:21:26 GMT
So I see some potential issues with the command. --deploy-as=root:password
doesn¹t have a host pointer. My gut tells me it should look like
--deploy-as=root:password@remote-host.

Now for another potential issue you do a cloud-setup-databases
cloud:@remoteip where I feel you should be doing cloud@remoteip (if you
want cloud user to log in without a password).

I would try with the above deploy-as=root modification, and correct the
cloud user param.


On 10/15/12 5:07 PM, "bruce.m@v365.com.au" <bruce.m@v365.com.au> wrote:

>  
>
>Thanks Ahmad
>
>i tried the format that you suggest. but it sill
>doesn't work.
>
>i have to also install mysql tools before the server will
>connect to the remote mysql host.
>
>ive tried with multiple builds of the
>latest build on ubuntu. Now im trying the nonoss vers
>
>same issue with
>it setting up the DB. AKA have to remove any password from the database
>name on setup of DB
>
>cloud-setup-databases cloud:@remoteip
>--deploy-as=root:password
>
>i have disabled all firewalls on hosts. UB
>12.04.1 LTS
>
>_Not true, for production installs, I always have the db
>server remote to management servers and there are passwords on all
>accounts. One thing to try is have a mysql user password with little to
>no special characters, if you do quote them, for example
>cloud-setup-databases cloud:'mcloudpass'@remote.host.com
>--deploy-as=root:'rootpass'@remote.host.com _
>
> 


-- 
Æ




Mime
View raw message