cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <ch0...@gmail.com>
Subject Re: IP Route is empty
Date Thu, 25 Oct 2012 06:55:04 GMT
apt-get install mysql-connector-python is not able to retrieve it

On Thu, Oct 25, 2012 at 8:19 AM, Edison Su <Edison.su@citrix.com> wrote:

> Need to install mysql-connector-python.
>
> Sent from my iPhone
>
> On Oct 24, 2012, at 10:44 PM, "Charles Moulliard" <ch007m@gmail.com>
> wrote:
>
> > Works better but I get now after doing what you suggest
> >
> > mvn -P developer,deploysvr -pl tools/devcloud -Ddeploysvr
> -DskipTests=true
> > [INFO] Scanning for projects...
> > [INFO]
> >
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Building Apache CloudStack Developer Tools 4.1.0-SNAPSHOT
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO]
> > [INFO] --- maven-remote-resources-plugin:1.3:process (default) @
> > cloud-devcloud ---
> > [INFO]
> > [INFO] --- maven-site-plugin:3.1:attach-descriptor (attach-descriptor) @
> > cloud-devcloud ---
> > [INFO]
> > [INFO] --- exec-maven-plugin:1.2.1:exec (default) @ cloud-devcloud ---
> > Traceback (most recent call last):
> >  File "../marvin/marvin/deployDataCenter.py", line 21, in <module>
> >    import cloudstackTestClient
> >  File
> >
> "/home/cmoulliard/MyRepositories/incubator-cloudstack/tools/marvin/marvin/cloudstackTestClient.py",
> > line 20, in <module>
> >    import dbConnection
> >  File
> >
> "/home/cmoulliard/MyRepositories/incubator-cloudstack/tools/marvin/marvin/dbConnection.py",
> > line 18, in <module>
> >    import mysql
> > ImportError: No module named mysql
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] BUILD FAILURE
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time: 2.663s
> > [INFO] Finished at: Thu Oct 25 07:43:01 CEST 2012
> > [INFO] Final Memory: 17M/213M
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] Failed to execute goal
> > org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (default) on project
> > cloud-devcloud: Command execution failed. Process exited with an error: 1
> > (Exit value: 1) -> [Help 1]
> > [ERROR]
> >
> >
> > On Wed, Oct 24, 2012 at 10:43 PM, Edison Su <Edison.su@citrix.com>
> wrote:
> >
> >> "mvn -P developer install" should create " cloudstackAPI " folder under
> >> tools/marvin/marvin
> >>
> >>> -----Original Message-----
> >>> From: Charles Moulliard [mailto:ch007m@gmail.com]
> >>> Sent: Wednesday, October 24, 2012 1:26 PM
> >>> To: cloudstack-users@incubator.apache.org
> >>> Subject: Re: IP Route is empty
> >>>
> >>> Solved ip empty issue (used network as netmask in
> >>> etc/network/interfaces
> >>> file)
> >>>
> >>> Step 8 generates this error :
> >>>
> >>> mvn -P developer,deploysvr -pl tools/devcloud -Ddeploysvr
> >>> [INFO] Scanning for projects...
> >>> [INFO]
> >>>
> >>> [INFO]
> >>> -----------------------------------------------------------------------
> >>> -
> >>> [INFO] Building Apache CloudStack Developer Tools 4.1.0-SNAPSHOT
> >>> [INFO]
> >>> -----------------------------------------------------------------------
> >>> -
> >>> [INFO]
> >>> [INFO] --- maven-remote-resources-plugin:1.3:process (default) @
> >>> cloud-devcloud ---
> >>> [INFO]
> >>> [INFO] --- maven-site-plugin:3.1:attach-descriptor (attach-descriptor)
> >>> @
> >>> cloud-devcloud ---
> >>> [INFO]
> >>> [INFO] --- exec-maven-plugin:1.2.1:exec (default) @ cloud-devcloud ---
> >>> Traceback (most recent call last):
> >>>  File "../marvin/marvin/deployDataCenter.py", line 19, in <module>
> >>>    import configGenerator
> >>>  File
> >>> "/home/cmoulliard/MyRepositories/incubator-
> >>> cloudstack/tools/marvin/marvin/configGenerator.py",
> >>> line 21, in <module>
> >>>    import jsonHelper
> >>>  File
> >>> "/home/cmoulliard/MyRepositories/incubator-
> >>> cloudstack/tools/marvin/marvin/jsonHelper.py",
> >>> line 21, in <module>
> >>>    from cloudstackAPI import *
> >>> ImportError: No module named cloudstackAPI
> >>> [INFO]
> >>> -----------------------------------------------------------------------
> >>> -
> >>> [INFO] BUILD FAILURE
> >>> [INFO]
> >>> -----------------------------------------------------------------------
> >>> -
> >>> [INFO] Total time: 2.506s
> >>> [INFO] Finished at: Wed Oct 24 22:25:42 CEST 2012
> >>> [INFO] Final Memory: 18M/218M
> >>> [INFO]
> >>> -----------------------------------------------------------------------
> >>> -
> >>> [ERROR] Failed to execute goal
> >>> org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (default) on project
> >>> cloud-devcloud: Command execution failed. Process exited with an error:
> >>> 1
> >>> (Exit value: 1) -> [Help 1]
> >>> [ERROR]
> >>> [ERROR] To see the full stack trace of the errors, re-run Maven with
> >>> the -e
> >>> switch.
> >>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> >>> [ERROR]
> >>> [ERROR] For more information about the errors and possible solutions,
> >>> please read the following articles:
> >>> [ERROR] [Help 1]
> >>>
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> >>>
> >>>
> >>> On Wed, Oct 24, 2012 at 10:12 PM, Donal Lafferty
> >>> <donal.lafferty@citrix.com>wrote:
> >>>
> >>>> Hi Charles,
> >>>>
> >>>> I do apologise if you've already accounted for these problems, but
> >>> here
> >>>> goes...
> >>>>
> >>>> Can you double check step 8?  I updated it recently, possibly after
> >>> you
> >>>> walked through the steps.
> >>>>
> >>>> Also, I think you have to do step 8 from a separate shell, because
> >>> step 7
> >>>> seems to end with the cloudstack management server running in the
> >>>> foreground.
> >>>>
> >>>>
> >>>> DL
> >>>>
> >>>>
> >>>> -----Original Message-----
> >>>> From: Charles Moulliard [mailto:ch007m@gmail.com]
> >>>> Sent: 24 October 2012 19:53
> >>>> To: cloudstack-users@incubator.apache.org
> >>>> Subject: IP Route is empty
> >>>>
> >>>> Hi,
> >>>>
> >>>> I have installed on a ubuntu machine a Virtual Box and follow
> >>> instructions
> >>>> here to install DevCloud image (
> >>>>
> >>>>
> >>>
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/CloudStack+devcl
> >>> oud+environment+setup
> >>>> ).
> >>>> I cannot connect to the DevCloud VM and when I check the config I
> >>> just
> >>>> discovered that "ip route" is empty. What should I do to solve this
> >>> problem
> >>>> ?
> >>>>
> >>>> Regards,
> >>>>
> >>>> --
> >>>> Charles Moulliard
> >>>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>>>
> >>>
> >>>
> >>>
> >>> --
> >>> Charles Moulliard
> >>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>
> >
> >
> >
> > --
> > Charles Moulliard
> > Apache Committer / Sr. Enterprise Architect (RedHat)
> > Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>



-- 
Charles Moulliard
Apache Committer / Sr. Enterprise Architect (RedHat)
Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message