cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donal Lafferty <donal.laffe...@citrix.com>
Subject RE: CloudStack running in Virtualbox
Date Wed, 24 Oct 2012 10:18:43 GMT
This seems to explain the problem you are seeing.

"The disadvantage of NAT mode is that, much like a private network behind a router, the virtual
machine is invisible and unreachable from the outside internet; you cannot run a server this
way unless you set up port forwarding (described below)."

See http://www.virtualbox.org/manual/ch06.html#network_nat


If you want to stick with NAT, you should create a VM in the virtual box install that can
run your browser.  Alternatively, use a bridge adapter.


BTW, where is the DHCP daemon that is allocating addresses to your VMs?




-----Original Message-----
From: Charles Moulliard [mailto:ch007m@gmail.com] 
Sent: 24 October 2012 10:37
To: cloudstack-users@incubator.apache.org
Subject: Re: CloudStack running in Virtualbox

Are you connecting from the host running virtual box to the VM running the
management server over SSH or HTTP?
> No.

 10.0.2.50 = VirtualBox IP address
 10.0.2.15 = CloudStack management server
 10.0.2.179 = an instance created using the console (
http://localhost:8080/client/). I can connect to the web console from the
ubuntu machine where VirtualBox has been installed and running the image
CloudStack

I cannot connect to the management server using address
http://10.0.2.15:8080/client

On Wed, Oct 24, 2012 at 11:07 AM, Donal Lafferty
<donal.lafferty@citrix.com>wrote:

> Hi Charles,
>
> Need more information.
>
> Are you connecting from the host running virtual box to the VM running the
> management server over SSH or HTTP?
>
> For HTTP, AFAIK you not to include the port and virtual path.  E.g.
> http://10.0.2.179:8080/client
>
> Also, can you confirm what IP addresses you have?  10.0.2.50 seems to be
> the VirtualBox gateway and 10.0.2.179 the management server.  So what is
> 10.0.2.15?
>
> DL
>
>
> -----Original Message-----
> From: Charles Moulliard [mailto:ch007m@gmail.com]
> Sent: 24 October 2012 09:49
> To: cloudstack-users@incubator.apache.org
> Subject: CloudStack running in Virtualbox
>
> Hi,
>
> Hi. I have installed successfully the following image in virtualbox (
> http://download.cloud.com/templates/devcloud/DevCloud.ova) and created an
> instance. Unfortunately, I cannot connect to it with its IP address
> (10.0.2.179). VirtualBox uses NAT and a host only adapter + vboxnet
> (10.0.2.50). Is there something else to configure ?
> When I log to the Unix machine (where CloudStack has been deployed), I can
> ping 10.0.2.15 address but not 10.0.2.179.
>
> Regards,
>
> --
> Charles Moulliard
> Apache Committer / Sr. Enterprise Architect (RedHat)
> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>



-- 
Charles Moulliard
Apache Committer / Sr. Enterprise Architect (RedHat)
Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com

Mime
View raw message