cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@citrix.com>
Subject Re: Unable to create an instance - CloudStack 4.0
Date Fri, 26 Oct 2012 12:03:52 GMT

On 26-Oct-2012, at 5:24 PM, Charles Moulliard <ch007m@gmail.com> wrote:

> Here is the trace coming from vmops.log
> 
> https://gist.github.com/95f5ee505eb24af1f914

Looking at your logs, I see that you're indeed using a small instance. But the issue looks
like is with the storage pool. It fails to find suitable storage pool, hence fails to configure/find
a deployment and fails:
2012-10-26 04:45:53,862 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-3:job-31) No suitable
pools found for volume: Vol[11|vm=11|ROOT] under cluster: 1
2012-10-26 04:45:53,862 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-3:job-31) No suitable
pools found
2012-10-26 04:45:53,862 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-3:job-31) No suitable
storagePools found under this Cluster: 1
2012-10-26 04:45:53,862 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-3:job-31) Could
not find suitable Deployment Destination for this VM under any clusters, returning. 

So, checklist:
- Xen host has enough capacity
- Primary storage is reachable and user/passwd has rw access
- Secondary storage is reachable and mgmt server has rw access
- Primary storage has enough space to accommodate vm with that root/data disks

If it still fails, I won't have any idea, probably anyone else can look at it.

Regards.

> 
> On Fri, Oct 26, 2012 at 1:53 PM, Charles Moulliard <ch007m@gmail.com> wrote:
> 
>> - ISO has been successfully downloaded
>> 
>> - Here is my setup during installation :
>> 
>> Zone : devcloud
>> Hypervisor : XenServer
>> Template : ubuntu-10.04-server
>> Compute offering : Small Instance
>> Data Disk Offering : Small
>> Security Groups : fuse
>> 
>> 
>> On Fri, Oct 26, 2012 at 1:30 PM, Rohit Yadav <rohit.yadav@citrix.com>wrote:
>> 
>>> Make sure the iso was successfully uploaded and installed by ssvm; check
>>> status in templates->iso etc.
>>> 
>>> From log looks like there is not enough capacity on the host/hypervisor
>>> to run a VM; may be try to redeploy with small instance and cpu offering
>>> with no data disk.
>>> 
>>> Regards.
>>> 
>>> On 26-Oct-2012, at 4:14 PM, Charles Moulliard <ch007m@gmail.com> wrote:
>>> 
>>>> Hi,
>>>> 
>>>> I have created an iso image in cloudstack to deploy ubuntu server 10.04
>>> (
>>>> http://releases.ubuntu.com/lucid/ubuntu-10.04.4-server-i386.iso).
>>>> 
>>>> When I create the cloud instance, I get the following error :
>>>> 
>>>> [sshexec]      [java] INFO  [api.commands.DeployVMCmd]
>>>> (Job-Executor-2:job-27)
>>>> com.cloud.exception.InsufficientServerCapacityException: Unable to
>>> create a
>>>> deployment for
>>> VM[User|5b198574-cf2b-47b9-8625-127d24298ee8]Scope=interface
>>>> com.cloud.dc.DataCenter; id=1
>>>> [sshexec]
>>>> [sshexec]      [java] WARN  [cloud.api.ApiDispatcher]
>>>> (Job-Executor-2:job-27) class com.cloud.api.ServerApiException : Unable
>>> to
>>>> create a deployment for VM[User|5b198574-cf2b-47b9-8625-127d24298ee8]
>>>> [sshexec]
>>>> 
>>>> How can we get more info about the problem and solve it ?
>>>> 
>>>> Regards,
>>>> 
>>>> --
>>>> Charles Moulliard
>>>> Apache Committer / Sr. Enterprise Architect (RedHat)
>>>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>>> 
>>> 
>> 
>> 
>> --
>> Charles Moulliard
>> Apache Committer / Sr. Enterprise Architect (RedHat)
>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>> 
>> 
>> 
> 
> 
> -- 
> Charles Moulliard
> Apache Committer / Sr. Enterprise Architect (RedHat)
> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com


Mime
View raw message